openSUSE Security Update: Security update for xen
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2022:0940-1
Rating:             important
References:         #1027519 #1191668 #1194267 #1196915 
Cross-References:   CVE-2021-26401 CVE-2022-0001 CVE-2022-0002
                   
CVSS scores:
                    CVE-2021-26401 (NVD) : 5.6 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N
                    CVE-2021-26401 (SUSE): 5.6 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N
                    CVE-2022-0001 (NVD) : 6.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
                    CVE-2022-0001 (SUSE): 5.6 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N
                    CVE-2022-0002 (NVD) : 6.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
                    CVE-2022-0002 (SUSE): 5.6 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N

Affected Products:
                    openSUSE Leap 15.3
______________________________________________________________________________

   An update that solves three vulnerabilities and has one
   errata is now available.

Description:

   This update for xen fixes the following issues:

   Update Xen to version 4.14.4 (bsc#1027519)

   Transient execution side-channel attacks attacking the Branch History
   Buffer (BHB), named "Branch Target Injection" and "Intra-Mode Branch
   History Injection" are now mitigated.

   Security issues fixed:

   - CVE-2022-0001, CVE-2022-0002, CVE-2021-26401: BHB speculation issues
     (bsc#1196915).

   Non-security issues fixed:

   - Fixed issue around xl and virsh operation - virsh list not giving any
     output (bsc#1191668).


Special Instructions and Notes:

   Please reboot the system after installing this update.

Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2022-940=1



Package List:

   - openSUSE Leap 15.3 (aarch64 x86_64):

      xen-4.14.4_02-150300.3.21.1
      xen-debugsource-4.14.4_02-150300.3.21.1
      xen-devel-4.14.4_02-150300.3.21.1
      xen-doc-html-4.14.4_02-150300.3.21.1
      xen-libs-4.14.4_02-150300.3.21.1
      xen-libs-debuginfo-4.14.4_02-150300.3.21.1
      xen-tools-4.14.4_02-150300.3.21.1
      xen-tools-debuginfo-4.14.4_02-150300.3.21.1
      xen-tools-domU-4.14.4_02-150300.3.21.1
      xen-tools-domU-debuginfo-4.14.4_02-150300.3.21.1

   - openSUSE Leap 15.3 (x86_64):

      xen-libs-32bit-4.14.4_02-150300.3.21.1
      xen-libs-32bit-debuginfo-4.14.4_02-150300.3.21.1

   - openSUSE Leap 15.3 (noarch):

      xen-tools-xendomains-wait-disk-4.14.4_02-150300.3.21.1


References:

   https://www.suse.com/security/cve/CVE-2021-26401.html
   https://www.suse.com/security/cve/CVE-2022-0001.html
   https://www.suse.com/security/cve/CVE-2022-0002.html
   https://bugzilla.suse.com/1027519
   https://bugzilla.suse.com/1191668
   https://bugzilla.suse.com/1194267
   https://bugzilla.suse.com/1196915