openSUSE: 2022:0943-1 moderate: slirp4netns | LinuxSecurity.com

   openSUSE Security Update: Security update for slirp4netns
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2022:0943-1
Rating:             moderate
References:         #1179467 
Cross-References:   CVE-2020-29130
CVSS scores:
                    CVE-2020-29130 (NVD) : 4.3 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
                    CVE-2020-29130 (SUSE): 4.3 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Affected Products:
                    openSUSE Leap 15.3
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for slirp4netns fixes the following issues:

   - CVE-2020-29130: Fixed an invalid memory access while processing ARP
     packets (bsc#1179467).


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-943=1

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2022-943=1



Package List:

   - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

      slirp4netns-0.4.7-3.15.1
      slirp4netns-debuginfo-0.4.7-3.15.1
      slirp4netns-debugsource-0.4.7-3.15.1

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      slirp4netns-0.4.7-3.15.1
      slirp4netns-debuginfo-0.4.7-3.15.1
      slirp4netns-debugsource-0.4.7-3.15.1


References:

   https://www.suse.com/security/cve/CVE-2020-29130.html
   https://bugzilla.suse.com/1179467

openSUSE: 2022:0943-1 moderate: slirp4netns

March 24, 2022
An update that fixes one vulnerability is now available

Description

This update for slirp4netns fixes the following issues: - CVE-2020-29130: Fixed an invalid memory access while processing ARP packets (bsc#1179467).

 

Patch

Patch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.4: zypper in -t patch openSUSE-SLE-15.4-2022-943=1 - openSUSE Leap 15.3: zypper in -t patch openSUSE-SLE-15.3-2022-943=1


Package List

- openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64): slirp4netns-0.4.7-3.15.1 slirp4netns-debuginfo-0.4.7-3.15.1 slirp4netns-debugsource-0.4.7-3.15.1 - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64): slirp4netns-0.4.7-3.15.1 slirp4netns-debuginfo-0.4.7-3.15.1 slirp4netns-debugsource-0.4.7-3.15.1


References

https://www.suse.com/security/cve/CVE-2020-29130.html https://bugzilla.suse.com/1179467


Severity
Announcement ID: openSUSE-SU-2022:0943-1
Rating: moderate
Affected Products: openSUSE Leap 15.3 openSUSE Leap 15.4 . Affected Products: openSUSE Leap 15.3 openSUSE Leap 15.4 .

Related News

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.