openSUSE: 2022:2649-1 important: pcre2 | LinuxSecurity.com

   openSUSE Security Update: Security update for pcre2
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2022:2649-1
Rating:             important
References:         #1164384 #1199235 
Cross-References:   CVE-2019-20454 CVE-2022-1587
CVSS scores:
                    CVE-2019-20454 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
                    CVE-2019-20454 (SUSE): 6.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H
                    CVE-2022-1587 (NVD) : 9.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
                    CVE-2022-1587 (SUSE): 8.6 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L

Affected Products:
                    openSUSE Leap Micro 5.2
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for pcre2 fixes the following issues:

   - CVE-2019-20454: Fixed out-of-bounds read in JIT mode when \X is used in
     non-UTF mode (bsc#1164384).
   - CVE-2022-1587: Fixed out-of-bounds read due to bug in recursions
     (bsc#1199235).


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap Micro 5.2:

      zypper in -t patch openSUSE-Leap-Micro-5.2-2022-2649=1



Package List:

   - openSUSE Leap Micro 5.2 (aarch64 x86_64):

      libpcre2-8-0-10.31-150000.3.12.1
      libpcre2-8-0-debuginfo-10.31-150000.3.12.1
      pcre2-debugsource-10.31-150000.3.12.1


References:

   https://www.suse.com/security/cve/CVE-2019-20454.html
   https://www.suse.com/security/cve/CVE-2022-1587.html
   https://bugzilla.suse.com/1164384
   https://bugzilla.suse.com/1199235

openSUSE: 2022:2649-1 important: pcre2

September 1, 2022
An update that fixes two vulnerabilities is now available

Description

This update for pcre2 fixes the following issues: - CVE-2019-20454: Fixed out-of-bounds read in JIT mode when \X is used in non-UTF mode (bsc#1164384). - CVE-2022-1587: Fixed out-of-bounds read due to bug in recursions (bsc#1199235).

 

Patch

Patch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap Micro 5.2: zypper in -t patch openSUSE-Leap-Micro-5.2-2022-2649=1


Package List

- openSUSE Leap Micro 5.2 (aarch64 x86_64): libpcre2-8-0-10.31-150000.3.12.1 libpcre2-8-0-debuginfo-10.31-150000.3.12.1 pcre2-debugsource-10.31-150000.3.12.1


References

https://www.suse.com/security/cve/CVE-2019-20454.html https://www.suse.com/security/cve/CVE-2022-1587.html https://bugzilla.suse.com/1164384 https://bugzilla.suse.com/1199235


Severity
Announcement ID: openSUSE-SU-2022:2649-1
Rating: important
Affected Products: openSUSE Leap Micro 5.2 . Affected Products: openSUSE Leap Micro 5.2 .

Related News

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.