openSUSE: 2022:2941-1 moderate: libslirp | LinuxSecurity.com

   openSUSE Security Update: Security update for libslirp
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2022:2941-1
Rating:             moderate
References:         #1187365 #1201551 
Cross-References:   CVE-2021-3593
CVSS scores:
                    CVE-2021-3593 (NVD) : 3.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N
                    CVE-2021-3593 (SUSE): 3.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N

Affected Products:
                    openSUSE Leap Micro 5.2
______________________________________________________________________________

   An update that solves one vulnerability and has one errata
   is now available.

Description:

   This update for libslirp fixes the following issues:

   - CVE-2021-3593: Fixed invalid pointer initialization may lead to
     information disclosure (udp6) (bsc#1187365).

   Non-security fixes:

   - Fix the version header (bsc#1201551)


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap Micro 5.2:

      zypper in -t patch openSUSE-Leap-Micro-5.2-2022-2941=1



Package List:

   - openSUSE Leap Micro 5.2 (aarch64 x86_64):

      libslirp-debugsource-4.3.1-150300.11.1
      libslirp0-4.3.1-150300.11.1
      libslirp0-debuginfo-4.3.1-150300.11.1


References:

   https://www.suse.com/security/cve/CVE-2021-3593.html
   https://bugzilla.suse.com/1187365
   https://bugzilla.suse.com/1201551

openSUSE: 2022:2941-1 moderate: libslirp

September 1, 2022
An update that solves one vulnerability and has one errata is now available

Description

This update for libslirp fixes the following issues: - CVE-2021-3593: Fixed invalid pointer initialization may lead to information disclosure (udp6) (bsc#1187365). Non-security fixes: - Fix the version header (bsc#1201551)

 

Patch

Patch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap Micro 5.2: zypper in -t patch openSUSE-Leap-Micro-5.2-2022-2941=1


Package List

- openSUSE Leap Micro 5.2 (aarch64 x86_64): libslirp-debugsource-4.3.1-150300.11.1 libslirp0-4.3.1-150300.11.1 libslirp0-debuginfo-4.3.1-150300.11.1


References

https://www.suse.com/security/cve/CVE-2021-3593.html https://bugzilla.suse.com/1187365 https://bugzilla.suse.com/1201551


Severity
Announcement ID: openSUSE-SU-2022:2941-1
Rating: moderate
Affected Products: openSUSE Leap Micro 5.2 ble. Affected Products: openSUSE Leap Micro 5.2 ble.

Related News

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.