Oracle Linux Security Advisory ELSA-2022-0350

https://linux.oracle.com/errata/ELSA-2022-0350.html

The following updated rpms for Oracle Linux 8 have been uploaded to the Unbreakable Linux Network:

x86_64:
nodejs-14.18.2-2.module+el8.5.0+20489+261d51d3.x86_64.rpm
nodejs-devel-14.18.2-2.module+el8.5.0+20489+261d51d3.x86_64.rpm
nodejs-docs-14.18.2-2.module+el8.5.0+20489+261d51d3.noarch.rpm
nodejs-full-i18n-14.18.2-2.module+el8.5.0+20489+261d51d3.x86_64.rpm
nodejs-nodemon-2.0.15-1.module+el8.5.0+20489+261d51d3.noarch.rpm
nodejs-packaging-23-3.module+el8.3.0+7818+6cd30d85.noarch.rpm
npm-6.14.15-1.14.18.2.2.module+el8.5.0+20489+261d51d3.x86_64.rpm

aarch64:
nodejs-14.18.2-2.module+el8.5.0+20489+261d51d3.aarch64.rpm
nodejs-devel-14.18.2-2.module+el8.5.0+20489+261d51d3.aarch64.rpm
nodejs-docs-14.18.2-2.module+el8.5.0+20489+261d51d3.noarch.rpm
nodejs-full-i18n-14.18.2-2.module+el8.5.0+20489+261d51d3.aarch64.rpm
nodejs-nodemon-2.0.15-1.module+el8.5.0+20489+261d51d3.noarch.rpm
nodejs-packaging-23-3.module+el8.3.0+7818+6cd30d85.noarch.rpm
npm-6.14.15-1.14.18.2.2.module+el8.5.0+20489+261d51d3.aarch64.rpm


SRPMS:
https://oss.oracle.com/ol8/SRPMS-updates/nodejs-14.18.2-2.module+el8.5.0+20489+261d51d3.src.rpm
https://oss.oracle.com/ol8/SRPMS-updates/nodejs-nodemon-2.0.15-1.module+el8.5.0+20489+261d51d3.src.rpm
https://oss.oracle.com/ol8/SRPMS-updates/nodejs-packaging-23-3.module+el8.3.0+7818+6cd30d85.src.rpm

Related CVEs:

CVE-2020-7788
CVE-2020-28469
CVE-2021-3807
CVE-2021-3918
CVE-2021-22959
CVE-2021-22960
CVE-2021-33502
CVE-2021-37701
CVE-2021-37712




Description of changes:

nodejs
[1:14.18.2-2]
- Add missing fixes
- Resolves: RHBZ#2027642, RHBZ#2027635

[1:14.18.2-1]
- Resolves: RHBZ#2027609
- Resolves: RHBZ#2027649, RHBZ#2027646, RHBZ#2027642, RHBZ#2027635
- Rebase to new version to fix CVEs

_______________________________________________
El-errata mailing list
[email protected]
https://oss.oracle.com/mailman/listinfo/el-errata