Oracle Linux Security Advisory ELSA-2022-0543

https://linux.oracle.com/errata/ELSA-2022-0543.html

The following updated rpms for Oracle Linux 8 have been uploaded to the Unbreakable Linux Network:

x86_64:
ruby-2.6.9-108.module+el8.5.0+20495+db24e7b4.i686.rpm
ruby-2.6.9-108.module+el8.5.0+20495+db24e7b4.x86_64.rpm
ruby-devel-2.6.9-108.module+el8.5.0+20495+db24e7b4.i686.rpm
ruby-devel-2.6.9-108.module+el8.5.0+20495+db24e7b4.x86_64.rpm
ruby-doc-2.6.9-108.module+el8.5.0+20495+db24e7b4.noarch.rpm
rubygem-abrt-0.3.0-4.module+el8.1.0+5406+ce01f9b9.noarch.rpm
rubygem-abrt-doc-0.3.0-4.module+el8.1.0+5406+ce01f9b9.noarch.rpm
rubygem-bigdecimal-1.4.1-108.module+el8.5.0+20495+db24e7b4.i686.rpm
rubygem-bigdecimal-1.4.1-108.module+el8.5.0+20495+db24e7b4.x86_64.rpm
rubygem-bson-4.5.0-1.module+el8.4.0+20235+1e5b8be3.x86_64.rpm
rubygem-bson-doc-4.5.0-1.module+el8.4.0+20235+1e5b8be3.noarch.rpm
rubygem-bundler-1.17.2-108.module+el8.5.0+20495+db24e7b4.noarch.rpm
rubygem-did_you_mean-1.3.0-108.module+el8.5.0+20495+db24e7b4.noarch.rpm
rubygem-io-console-0.4.7-108.module+el8.5.0+20495+db24e7b4.i686.rpm
rubygem-io-console-0.4.7-108.module+el8.5.0+20495+db24e7b4.x86_64.rpm
rubygem-irb-1.0.0-108.module+el8.5.0+20495+db24e7b4.noarch.rpm
rubygem-json-2.1.0-108.module+el8.5.0+20495+db24e7b4.i686.rpm
rubygem-json-2.1.0-108.module+el8.5.0+20495+db24e7b4.x86_64.rpm
rubygem-minitest-5.11.3-108.module+el8.5.0+20495+db24e7b4.noarch.rpm
rubygem-mongo-2.8.0-1.module+el8.1.0+5406+ce01f9b9.noarch.rpm
rubygem-mongo-doc-2.8.0-1.module+el8.1.0+5406+ce01f9b9.noarch.rpm
rubygem-mysql2-0.5.2-1.module+el8.4.0+20235+1e5b8be3.x86_64.rpm
rubygem-mysql2-doc-0.5.2-1.module+el8.4.0+20235+1e5b8be3.noarch.rpm
rubygem-net-telnet-0.2.0-108.module+el8.5.0+20495+db24e7b4.noarch.rpm
rubygem-openssl-2.1.2-108.module+el8.5.0+20495+db24e7b4.i686.rpm
rubygem-openssl-2.1.2-108.module+el8.5.0+20495+db24e7b4.x86_64.rpm
rubygem-pg-1.1.4-1.module+el8.4.0+20235+1e5b8be3.x86_64.rpm
rubygem-pg-doc-1.1.4-1.module+el8.4.0+20235+1e5b8be3.noarch.rpm
rubygem-power_assert-1.1.3-108.module+el8.5.0+20495+db24e7b4.noarch.rpm
rubygem-psych-3.1.0-108.module+el8.5.0+20495+db24e7b4.i686.rpm
rubygem-psych-3.1.0-108.module+el8.5.0+20495+db24e7b4.x86_64.rpm
rubygem-rake-12.3.3-108.module+el8.5.0+20495+db24e7b4.noarch.rpm
rubygem-rdoc-6.1.2.1-108.module+el8.5.0+20495+db24e7b4.noarch.rpm
rubygems-3.0.3.1-108.module+el8.5.0+20495+db24e7b4.noarch.rpm
rubygems-devel-3.0.3.1-108.module+el8.5.0+20495+db24e7b4.noarch.rpm
rubygem-test-unit-3.2.9-108.module+el8.5.0+20495+db24e7b4.noarch.rpm
rubygem-xmlrpc-0.3.0-108.module+el8.5.0+20495+db24e7b4.noarch.rpm
ruby-libs-2.6.9-108.module+el8.5.0+20495+db24e7b4.i686.rpm
ruby-libs-2.6.9-108.module+el8.5.0+20495+db24e7b4.x86_64.rpm

aarch64:
ruby-2.6.9-108.module+el8.5.0+20495+db24e7b4.aarch64.rpm
ruby-devel-2.6.9-108.module+el8.5.0+20495+db24e7b4.aarch64.rpm
ruby-doc-2.6.9-108.module+el8.5.0+20495+db24e7b4.noarch.rpm
rubygem-abrt-0.3.0-4.module+el8.1.0+5406+ce01f9b9.noarch.rpm
rubygem-abrt-doc-0.3.0-4.module+el8.1.0+5406+ce01f9b9.noarch.rpm
rubygem-bigdecimal-1.4.1-108.module+el8.5.0+20495+db24e7b4.aarch64.rpm
rubygem-bson-4.5.0-1.module+el8.4.0+20235+1e5b8be3.aarch64.rpm
rubygem-bson-doc-4.5.0-1.module+el8.4.0+20235+1e5b8be3.noarch.rpm
rubygem-bundler-1.17.2-108.module+el8.5.0+20495+db24e7b4.noarch.rpm
rubygem-did_you_mean-1.3.0-108.module+el8.5.0+20495+db24e7b4.noarch.rpm
rubygem-io-console-0.4.7-108.module+el8.5.0+20495+db24e7b4.aarch64.rpm
rubygem-irb-1.0.0-108.module+el8.5.0+20495+db24e7b4.noarch.rpm
rubygem-json-2.1.0-108.module+el8.5.0+20495+db24e7b4.aarch64.rpm
rubygem-minitest-5.11.3-108.module+el8.5.0+20495+db24e7b4.noarch.rpm
rubygem-mongo-2.8.0-1.module+el8.1.0+5406+ce01f9b9.noarch.rpm
rubygem-mongo-doc-2.8.0-1.module+el8.1.0+5406+ce01f9b9.noarch.rpm
rubygem-mysql2-0.5.2-1.module+el8.4.0+20235+1e5b8be3.aarch64.rpm
rubygem-mysql2-doc-0.5.2-1.module+el8.4.0+20235+1e5b8be3.noarch.rpm
rubygem-net-telnet-0.2.0-108.module+el8.5.0+20495+db24e7b4.noarch.rpm
rubygem-openssl-2.1.2-108.module+el8.5.0+20495+db24e7b4.aarch64.rpm
rubygem-pg-1.1.4-1.module+el8.4.0+20235+1e5b8be3.aarch64.rpm
rubygem-pg-doc-1.1.4-1.module+el8.4.0+20235+1e5b8be3.noarch.rpm
rubygem-power_assert-1.1.3-108.module+el8.5.0+20495+db24e7b4.noarch.rpm
rubygem-psych-3.1.0-108.module+el8.5.0+20495+db24e7b4.aarch64.rpm
rubygem-rake-12.3.3-108.module+el8.5.0+20495+db24e7b4.noarch.rpm
rubygem-rdoc-6.1.2.1-108.module+el8.5.0+20495+db24e7b4.noarch.rpm
rubygems-3.0.3.1-108.module+el8.5.0+20495+db24e7b4.noarch.rpm
rubygems-devel-3.0.3.1-108.module+el8.5.0+20495+db24e7b4.noarch.rpm
rubygem-test-unit-3.2.9-108.module+el8.5.0+20495+db24e7b4.noarch.rpm
rubygem-xmlrpc-0.3.0-108.module+el8.5.0+20495+db24e7b4.noarch.rpm
ruby-libs-2.6.9-108.module+el8.5.0+20495+db24e7b4.aarch64.rpm


SRPMS:
https://oss.oracle.com/ol8/SRPMS-updates/ruby-2.6.9-108.module+el8.5.0+20495+db24e7b4.src.rpm
https://oss.oracle.com/ol8/SRPMS-updates/rubygem-abrt-0.3.0-4.module+el8.1.0+5406+ce01f9b9.src.rpm
https://oss.oracle.com/ol8/SRPMS-updates/rubygem-bson-4.5.0-1.module+el8.4.0+20235+1e5b8be3.src.rpm
https://oss.oracle.com/ol8/SRPMS-updates/rubygem-mongo-2.8.0-1.module+el8.1.0+5406+ce01f9b9.src.rpm
https://oss.oracle.com/ol8/SRPMS-updates/rubygem-mysql2-0.5.2-1.module+el8.4.0+20235+1e5b8be3.src.rpm
https://oss.oracle.com/ol8/SRPMS-updates/rubygem-pg-1.1.4-1.module+el8.4.0+20235+1e5b8be3.src.rpm

Related CVEs:

CVE-2020-36327
CVE-2021-31799
CVE-2021-31810
CVE-2021-32066
CVE-2021-41817
CVE-2021-41819




Description of changes:

ruby
[2.6.9-108]
- Upgrade to Ruby 2.6.9.
- Skip JIT tests in RHEL 8.
- Fix the issues required to start the "make test-bundler" itself.
- Fix Bundler dependency confusion.
  Resolves: CVE-2020-36327

_______________________________________________
El-errata mailing list
[email protected]
https://oss.oracle.com/mailman/listinfo/el-errata