Oracle Linux Security Advisory ELSA-2022-1556

https://linux.oracle.com/errata/ELSA-2022-1556.html

The following updated rpms for Oracle Linux 8 have been uploaded to the Unbreakable Linux Network:

x86_64:
Judy-1.0.5-18.0.1.module+el8.3.0+9616+7a81225f.x86_64.rpm
galera-25.3.34-4.module+el8.5.0+20629+e1b20d6b.x86_64.rpm
mariadb-10.3.32-2.0.1.module+el8.5.0+20629+e1b20d6b.x86_64.rpm
mariadb-backup-10.3.32-2.0.1.module+el8.5.0+20629+e1b20d6b.x86_64.rpm
mariadb-common-10.3.32-2.0.1.module+el8.5.0+20629+e1b20d6b.x86_64.rpm
mariadb-devel-10.3.32-2.0.1.module+el8.5.0+20629+e1b20d6b.x86_64.rpm
mariadb-embedded-10.3.32-2.0.1.module+el8.5.0+20629+e1b20d6b.x86_64.rpm
mariadb-embedded-devel-10.3.32-2.0.1.module+el8.5.0+20629+e1b20d6b.x86_64.rpm
mariadb-errmsg-10.3.32-2.0.1.module+el8.5.0+20629+e1b20d6b.x86_64.rpm
mariadb-gssapi-server-10.3.32-2.0.1.module+el8.5.0+20629+e1b20d6b.x86_64.rpm
mariadb-oqgraph-engine-10.3.32-2.0.1.module+el8.5.0+20629+e1b20d6b.x86_64.rpm
mariadb-server-10.3.32-2.0.1.module+el8.5.0+20629+e1b20d6b.x86_64.rpm
mariadb-server-galera-10.3.32-2.0.1.module+el8.5.0+20629+e1b20d6b.x86_64.rpm
mariadb-server-utils-10.3.32-2.0.1.module+el8.5.0+20629+e1b20d6b.x86_64.rpm
mariadb-test-10.3.32-2.0.1.module+el8.5.0+20629+e1b20d6b.x86_64.rpm

aarch64:
Judy-1.0.5-18.0.1.module+el8.3.0+9616+7a81225f.aarch64.rpm
galera-25.3.34-4.module+el8.5.0+20629+e1b20d6b.aarch64.rpm
mariadb-10.3.32-2.0.1.module+el8.5.0+20629+e1b20d6b.aarch64.rpm
mariadb-backup-10.3.32-2.0.1.module+el8.5.0+20629+e1b20d6b.aarch64.rpm
mariadb-common-10.3.32-2.0.1.module+el8.5.0+20629+e1b20d6b.aarch64.rpm
mariadb-devel-10.3.32-2.0.1.module+el8.5.0+20629+e1b20d6b.aarch64.rpm
mariadb-embedded-10.3.32-2.0.1.module+el8.5.0+20629+e1b20d6b.aarch64.rpm
mariadb-embedded-devel-10.3.32-2.0.1.module+el8.5.0+20629+e1b20d6b.aarch64.rpm
mariadb-errmsg-10.3.32-2.0.1.module+el8.5.0+20629+e1b20d6b.aarch64.rpm
mariadb-gssapi-server-10.3.32-2.0.1.module+el8.5.0+20629+e1b20d6b.aarch64.rpm
mariadb-oqgraph-engine-10.3.32-2.0.1.module+el8.5.0+20629+e1b20d6b.aarch64.rpm
mariadb-server-10.3.32-2.0.1.module+el8.5.0+20629+e1b20d6b.aarch64.rpm
mariadb-server-galera-10.3.32-2.0.1.module+el8.5.0+20629+e1b20d6b.aarch64.rpm
mariadb-server-utils-10.3.32-2.0.1.module+el8.5.0+20629+e1b20d6b.aarch64.rpm
mariadb-test-10.3.32-2.0.1.module+el8.5.0+20629+e1b20d6b.aarch64.rpm


SRPMS:
https://oss.oracle.com/ol8/SRPMS-updates/galera-25.3.34-4.module+el8.5.0+20629+e1b20d6b.src.rpm
https://oss.oracle.com/ol8/SRPMS-updates/Judy-1.0.5-18.0.1.module+el8.3.0+9616+7a81225f.src.rpm
https://oss.oracle.com/ol8/SRPMS-updates/mariadb-10.3.32-2.0.1.module+el8.5.0+20629+e1b20d6b.src.rpm

Related CVEs:

CVE-2021-2154
CVE-2021-2166
CVE-2021-2372
CVE-2021-2389
CVE-2021-35604
CVE-2021-46657
CVE-2021-46658
CVE-2021-46662
CVE-2021-46666
CVE-2021-46667




Description of changes:

galera
[25.3.34-4]
- Explicitly require the 'procps-ng' package
- Otherwise it will not require it in the lightweight systems (e.g. containers)
- and Galera won't work properly

[25.3.34-3]
- Use downstream garbd-wrapper and garbd.service to ensure compatibility
- Add upstream versions of garbd-wrapper (called garbd-systemd) and garbd.service
  in case user want's to use them

[ 25.3.34-2]
- Switch from SCONS build tooling to CMAKE build tooling

[25.3.34-1]
- Rebase to 25.3.34
  Resolves: #2042298

mariadb
[3:10.3.32-2.0.1]
- Fix changelog

[3:10.3.32-2]
- Add delaycompress option to the logrotate script

[3:10.3.32-1]
- Rebase to 10.3.32

[3:10.3.31-1]
- Rebase to 10.3.31

[3:10.3.30-1]
- Rebase to 10.3.30

[3:10.3.29-2]
- Set user_map.conf file to be noreplace config file

[3:10.3.29-1]
- Rebase to 10.3.29

_______________________________________________
El-errata mailing list
[email protected]
https://oss.oracle.com/mailman/listinfo/el-errata