Oracle Linux Security Advisory ELSA-2022-1557

https://linux.oracle.com/errata/ELSA-2022-1557.html

The following updated rpms for Oracle Linux 8 have been uploaded to the Unbreakable Linux Network:

x86_64:
galera-26.4.9-4.module+el8.5.0+20630+d7805586.x86_64.rpm
Judy-1.0.5-18.module+el8.4.0+20040+caf70fad.x86_64.rpm
mariadb-10.5.13-1.module+el8.5.0+20630+d7805586.x86_64.rpm
mariadb-backup-10.5.13-1.module+el8.5.0+20630+d7805586.x86_64.rpm
mariadb-common-10.5.13-1.module+el8.5.0+20630+d7805586.x86_64.rpm
mariadb-devel-10.5.13-1.module+el8.5.0+20630+d7805586.x86_64.rpm
mariadb-embedded-10.5.13-1.module+el8.5.0+20630+d7805586.x86_64.rpm
mariadb-embedded-devel-10.5.13-1.module+el8.5.0+20630+d7805586.x86_64.rpm
mariadb-errmsg-10.5.13-1.module+el8.5.0+20630+d7805586.x86_64.rpm
mariadb-gssapi-server-10.5.13-1.module+el8.5.0+20630+d7805586.x86_64.rpm
mariadb-oqgraph-engine-10.5.13-1.module+el8.5.0+20630+d7805586.x86_64.rpm
mariadb-pam-10.5.13-1.module+el8.5.0+20630+d7805586.x86_64.rpm
mariadb-server-10.5.13-1.module+el8.5.0+20630+d7805586.x86_64.rpm
mariadb-server-galera-10.5.13-1.module+el8.5.0+20630+d7805586.x86_64.rpm
mariadb-server-utils-10.5.13-1.module+el8.5.0+20630+d7805586.x86_64.rpm
mariadb-test-10.5.13-1.module+el8.5.0+20630+d7805586.x86_64.rpm

aarch64:
galera-26.4.9-4.module+el8.5.0+20630+d7805586.aarch64.rpm
Judy-1.0.5-18.module+el8.4.0+20040+caf70fad.aarch64.rpm
mariadb-10.5.13-1.module+el8.5.0+20630+d7805586.aarch64.rpm
mariadb-backup-10.5.13-1.module+el8.5.0+20630+d7805586.aarch64.rpm
mariadb-common-10.5.13-1.module+el8.5.0+20630+d7805586.aarch64.rpm
mariadb-devel-10.5.13-1.module+el8.5.0+20630+d7805586.aarch64.rpm
mariadb-embedded-10.5.13-1.module+el8.5.0+20630+d7805586.aarch64.rpm
mariadb-embedded-devel-10.5.13-1.module+el8.5.0+20630+d7805586.aarch64.rpm
mariadb-errmsg-10.5.13-1.module+el8.5.0+20630+d7805586.aarch64.rpm
mariadb-gssapi-server-10.5.13-1.module+el8.5.0+20630+d7805586.aarch64.rpm
mariadb-oqgraph-engine-10.5.13-1.module+el8.5.0+20630+d7805586.aarch64.rpm
mariadb-pam-10.5.13-1.module+el8.5.0+20630+d7805586.aarch64.rpm
mariadb-server-10.5.13-1.module+el8.5.0+20630+d7805586.aarch64.rpm
mariadb-server-galera-10.5.13-1.module+el8.5.0+20630+d7805586.aarch64.rpm
mariadb-server-utils-10.5.13-1.module+el8.5.0+20630+d7805586.aarch64.rpm
mariadb-test-10.5.13-1.module+el8.5.0+20630+d7805586.aarch64.rpm


SRPMS:
https://oss.oracle.com/ol8/SRPMS-updates/galera-26.4.9-4.module+el8.5.0+20630+d7805586.src.rpm
https://oss.oracle.com/ol8/SRPMS-updates/Judy-1.0.5-18.module+el8.4.0+20040+caf70fad.src.rpm
https://oss.oracle.com/ol8/SRPMS-updates/mariadb-10.5.13-1.module+el8.5.0+20630+d7805586.src.rpm

Related CVEs:

CVE-2021-2154
CVE-2021-2166
CVE-2021-2372
CVE-2021-2389
CVE-2021-35604
CVE-2021-46657
CVE-2021-46658
CVE-2021-46662
CVE-2021-46666
CVE-2021-46667




Description of changes:

galera
[26.4.9-4]
- Use downstream garbd-wrapper and garbd.service to ensure compatibility
- Add upstream versions of garbd-wrapper (called garbd-systemd) and garbd.service
  in case user want's to use them

[26.4.9-3]
- Explicitly require the 'procps-ng' package
- Otherwise it will not require it in the lightweight systems (e.g. containers)
- and Galera won't work properly

[26.4.9-2]
- Switch from SCONS build tooling to CMAKE build tooling

[26.4.9-1]
- Rebase to 26.4.9

mariadb
[3:10.5.13-1]
- Rebase to 10.5.13
- Add wsrep_sst_rsync_tunnel script

[3:10.5.12-1]
- Rebase to 10.5.12

[3:10.5.11-1]
- Rebase to 10.5.11

[3:10.5.10-2]
- Set user_map.conf file to be noreplace config file
- Resolves: rhbz#1989621

[3:10.5.10-1]
- Rebase to 10.5.10


_______________________________________________
El-errata mailing list
[email protected]
https://oss.oracle.com/mailman/listinfo/el-errata