Oracle8: ELSA-2022-5338: ruby Moderate Security Update | LinuxSecur...

Advisories

Oracle Linux Security Advisory ELSA-2022-5338

https://linux.oracle.com/errata/ELSA-2022-5338.html

The following updated rpms for Oracle Linux 8 have been uploaded to the Unbreakable Linux Network:

x86_64:
ruby-2.6.10-109.module+el8.6.0+20693+52f02d9c.i686.rpm
ruby-2.6.10-109.module+el8.6.0+20693+52f02d9c.x86_64.rpm
ruby-devel-2.6.10-109.module+el8.6.0+20693+52f02d9c.i686.rpm
ruby-devel-2.6.10-109.module+el8.6.0+20693+52f02d9c.x86_64.rpm
ruby-doc-2.6.10-109.module+el8.6.0+20693+52f02d9c.noarch.rpm
rubygem-abrt-0.3.0-4.module+el8.1.0+5406+ce01f9b9.noarch.rpm
rubygem-abrt-doc-0.3.0-4.module+el8.1.0+5406+ce01f9b9.noarch.rpm
rubygem-bigdecimal-1.4.1-109.module+el8.6.0+20693+52f02d9c.i686.rpm
rubygem-bigdecimal-1.4.1-109.module+el8.6.0+20693+52f02d9c.x86_64.rpm
rubygem-bson-4.5.0-1.module+el8.4.0+20235+1e5b8be3.x86_64.rpm
rubygem-bson-doc-4.5.0-1.module+el8.4.0+20235+1e5b8be3.noarch.rpm
rubygem-bundler-1.17.2-109.module+el8.6.0+20693+52f02d9c.noarch.rpm
rubygem-did_you_mean-1.3.0-109.module+el8.6.0+20693+52f02d9c.noarch.rpm
rubygem-io-console-0.4.7-109.module+el8.6.0+20693+52f02d9c.i686.rpm
rubygem-io-console-0.4.7-109.module+el8.6.0+20693+52f02d9c.x86_64.rpm
rubygem-irb-1.0.0-109.module+el8.6.0+20693+52f02d9c.noarch.rpm
rubygem-json-2.1.0-109.module+el8.6.0+20693+52f02d9c.i686.rpm
rubygem-json-2.1.0-109.module+el8.6.0+20693+52f02d9c.x86_64.rpm
rubygem-minitest-5.11.3-109.module+el8.6.0+20693+52f02d9c.noarch.rpm
rubygem-mongo-2.8.0-1.module+el8.1.0+5406+ce01f9b9.noarch.rpm
rubygem-mongo-doc-2.8.0-1.module+el8.1.0+5406+ce01f9b9.noarch.rpm
rubygem-mysql2-0.5.2-1.module+el8.4.0+20235+1e5b8be3.x86_64.rpm
rubygem-mysql2-doc-0.5.2-1.module+el8.4.0+20235+1e5b8be3.noarch.rpm
rubygem-net-telnet-0.2.0-109.module+el8.6.0+20693+52f02d9c.noarch.rpm
rubygem-openssl-2.1.2-109.module+el8.6.0+20693+52f02d9c.i686.rpm
rubygem-openssl-2.1.2-109.module+el8.6.0+20693+52f02d9c.x86_64.rpm
rubygem-pg-1.1.4-1.module+el8.4.0+20235+1e5b8be3.x86_64.rpm
rubygem-pg-doc-1.1.4-1.module+el8.4.0+20235+1e5b8be3.noarch.rpm
rubygem-power_assert-1.1.3-109.module+el8.6.0+20693+52f02d9c.noarch.rpm
rubygem-psych-3.1.0-109.module+el8.6.0+20693+52f02d9c.i686.rpm
rubygem-psych-3.1.0-109.module+el8.6.0+20693+52f02d9c.x86_64.rpm
rubygem-rake-12.3.3-109.module+el8.6.0+20693+52f02d9c.noarch.rpm
rubygem-rdoc-6.1.2.1-109.module+el8.6.0+20693+52f02d9c.noarch.rpm
rubygems-3.0.3.1-109.module+el8.6.0+20693+52f02d9c.noarch.rpm
rubygems-devel-3.0.3.1-109.module+el8.6.0+20693+52f02d9c.noarch.rpm
rubygem-test-unit-3.2.9-109.module+el8.6.0+20693+52f02d9c.noarch.rpm
rubygem-xmlrpc-0.3.0-109.module+el8.6.0+20693+52f02d9c.noarch.rpm
ruby-libs-2.6.10-109.module+el8.6.0+20693+52f02d9c.i686.rpm
ruby-libs-2.6.10-109.module+el8.6.0+20693+52f02d9c.x86_64.rpm

aarch64:
ruby-2.6.10-109.module+el8.6.0+20693+52f02d9c.aarch64.rpm
ruby-devel-2.6.10-109.module+el8.6.0+20693+52f02d9c.aarch64.rpm
ruby-doc-2.6.10-109.module+el8.6.0+20693+52f02d9c.noarch.rpm
rubygem-abrt-0.3.0-4.module+el8.1.0+5406+ce01f9b9.noarch.rpm
rubygem-abrt-doc-0.3.0-4.module+el8.1.0+5406+ce01f9b9.noarch.rpm
rubygem-bigdecimal-1.4.1-109.module+el8.6.0+20693+52f02d9c.aarch64.rpm
rubygem-bson-4.5.0-1.module+el8.4.0+20235+1e5b8be3.aarch64.rpm
rubygem-bson-doc-4.5.0-1.module+el8.4.0+20235+1e5b8be3.noarch.rpm
rubygem-bundler-1.17.2-109.module+el8.6.0+20693+52f02d9c.noarch.rpm
rubygem-did_you_mean-1.3.0-109.module+el8.6.0+20693+52f02d9c.noarch.rpm
rubygem-io-console-0.4.7-109.module+el8.6.0+20693+52f02d9c.aarch64.rpm
rubygem-irb-1.0.0-109.module+el8.6.0+20693+52f02d9c.noarch.rpm
rubygem-json-2.1.0-109.module+el8.6.0+20693+52f02d9c.aarch64.rpm
rubygem-minitest-5.11.3-109.module+el8.6.0+20693+52f02d9c.noarch.rpm
rubygem-mongo-2.8.0-1.module+el8.1.0+5406+ce01f9b9.noarch.rpm
rubygem-mongo-doc-2.8.0-1.module+el8.1.0+5406+ce01f9b9.noarch.rpm
rubygem-mysql2-0.5.2-1.module+el8.4.0+20235+1e5b8be3.aarch64.rpm
rubygem-mysql2-doc-0.5.2-1.module+el8.4.0+20235+1e5b8be3.noarch.rpm
rubygem-net-telnet-0.2.0-109.module+el8.6.0+20693+52f02d9c.noarch.rpm
rubygem-openssl-2.1.2-109.module+el8.6.0+20693+52f02d9c.aarch64.rpm
rubygem-pg-1.1.4-1.module+el8.4.0+20235+1e5b8be3.aarch64.rpm
rubygem-pg-doc-1.1.4-1.module+el8.4.0+20235+1e5b8be3.noarch.rpm
rubygem-power_assert-1.1.3-109.module+el8.6.0+20693+52f02d9c.noarch.rpm
rubygem-psych-3.1.0-109.module+el8.6.0+20693+52f02d9c.aarch64.rpm
rubygem-rake-12.3.3-109.module+el8.6.0+20693+52f02d9c.noarch.rpm
rubygem-rdoc-6.1.2.1-109.module+el8.6.0+20693+52f02d9c.noarch.rpm
rubygems-3.0.3.1-109.module+el8.6.0+20693+52f02d9c.noarch.rpm
rubygems-devel-3.0.3.1-109.module+el8.6.0+20693+52f02d9c.noarch.rpm
rubygem-test-unit-3.2.9-109.module+el8.6.0+20693+52f02d9c.noarch.rpm
rubygem-xmlrpc-0.3.0-109.module+el8.6.0+20693+52f02d9c.noarch.rpm
ruby-libs-2.6.10-109.module+el8.6.0+20693+52f02d9c.aarch64.rpm


SRPMS:
https://oss.oracle.com/ol8/SRPMS-updates/ruby-2.6.10-109.module+el8.6.0+20693+52f02d9c.src.rpm
https://oss.oracle.com/ol8/SRPMS-updates/rubygem-abrt-0.3.0-4.module+el8.1.0+5406+ce01f9b9.src.rpm
https://oss.oracle.com/ol8/SRPMS-updates/rubygem-bson-4.5.0-1.module+el8.4.0+20235+1e5b8be3.src.rpm
https://oss.oracle.com/ol8/SRPMS-updates/rubygem-mongo-2.8.0-1.module+el8.1.0+5406+ce01f9b9.src.rpm
https://oss.oracle.com/ol8/SRPMS-updates/rubygem-mysql2-0.5.2-1.module+el8.4.0+20235+1e5b8be3.src.rpm
https://oss.oracle.com/ol8/SRPMS-updates/rubygem-pg-1.1.4-1.module+el8.4.0+20235+1e5b8be3.src.rpm

Related CVEs:

CVE-2022-28739




Description of changes:

ruby
[2.6.10-109]
- Upgrade to Ruby 2.6.10.
  Resolves: rhbz#2088415
- Fix buffer overrun in String-to-Float conversion.
  Resolves: CVE-2022-28739
- Fix FTBFS due to an incompatible load directive.
- Fix a fiddle import test on an optimized glibc on Power 9.

_______________________________________________
El-errata mailing list
[email protected]
https://oss.oracle.com/mailman/listinfo/el-errata

Oracle8: ELSA-2022-5338: ruby Moderate Security Update

Summary

Description of changes: ruby [2.6.10-109] - Upgrade to Ruby 2.6.10. Resolves: rhbz#2088415 - Fix buffer overrun in String-to-Float conversion. Resolves: CVE-2022-28739 - Fix FTBFS due to an incompatible load directive. - Fix a fiddle import test on an optimized glibc on Power 9.

i386

x86_64

ruby-2.6.10-109.module+el8.6.0+20693+52f02d9c.i686.rpm ruby-2.6.10-109.module+el8.6.0+20693+52f02d9c.x86_64.rpm ruby-devel-2.6.10-109.module+el8.6.0+20693+52f02d9c.i686.rpm ruby-devel-2.6.10-109.module+el8.6.0+20693+52f02d9c.x86_64.rpm ruby-doc-2.6.10-109.module+el8.6.0+20693+52f02d9c.noarch.rpm rubygem-abrt-0.3.0-4.module+el8.1.0+5406+ce01f9b9.noarch.rpm rubygem-abrt-doc-0.3.0-4.module+el8.1.0+5406+ce01f9b9.noarch.rpm rubygem-bigdecimal-1.4.1-109.module+el8.6.0+20693+52f02d9c.i686.rpm rubygem-bigdecimal-1.4.1-109.module+el8.6.0+20693+52f02d9c.x86_64.rpm rubygem-bson-4.5.0-1.module+el8.4.0+20235+1e5b8be3.x86_64.rpm rubygem-bson-doc-4.5.0-1.module+el8.4.0+20235+1e5b8be3.noarch.rpm rubygem-bundler-1.17.2-109.module+el8.6.0+20693+52f02d9c.noarch.rpm rubygem-did_you_mean-1.3.0-109.module+el8.6.0+20693+52f02d9c.noarch.rpm rubygem-io-console-0.4.7-109.module+el8.6.0+20693+52f02d9c.i686.rpm rubygem-io-console-0.4.7-109.module+el8.6.0+20693+52f02d9c.x86_64.rpm rubygem-irb-1.0.0-109.module+el8.6.0+20693+52f02d9c.noarch.rpm rubygem-json-2.1.0-109.module+el8.6.0+20693+52f02d9c.i686.rpm rubygem-json-2.1.0-109.module+el8.6.0+20693+52f02d9c.x86_64.rpm rubygem-minitest-5.11.3-109.module+el8.6.0+20693+52f02d9c.noarch.rpm rubygem-mongo-2.8.0-1.module+el8.1.0+5406+ce01f9b9.noarch.rpm rubygem-mongo-doc-2.8.0-1.module+el8.1.0+5406+ce01f9b9.noarch.rpm rubygem-mysql2-0.5.2-1.module+el8.4.0+20235+1e5b8be3.x86_64.rpm rubygem-mysql2-doc-0.5.2-1.module+el8.4.0+20235+1e5b8be3.noarch.rpm rubygem-net-telnet-0.2.0-109.module+el8.6.0+20693+52f02d9c.noarch.rpm rubygem-openssl-2.1.2-109.module+el8.6.0+20693+52f02d9c.i686.rpm rubygem-openssl-2.1.2-109.module+el8.6.0+20693+52f02d9c.x86_64.rpm rubygem-pg-1.1.4-1.module+el8.4.0+20235+1e5b8be3.x86_64.rpm rubygem-pg-doc-1.1.4-1.module+el8.4.0+20235+1e5b8be3.noarch.rpm rubygem-power_assert-1.1.3-109.module+el8.6.0+20693+52f02d9c.noarch.rpm rubygem-psych-3.1.0-109.module+el8.6.0+20693+52f02d9c.i686.rpm rubygem-psych-3.1.0-109.module+el8.6.0+20693+52f02d9c.x86_64.rpm rubygem-rake-12.3.3-109.module+el8.6.0+20693+52f02d9c.noarch.rpm rubygem-rdoc-6.1.2.1-109.module+el8.6.0+20693+52f02d9c.noarch.rpm rubygems-3.0.3.1-109.module+el8.6.0+20693+52f02d9c.noarch.rpm rubygems-devel-3.0.3.1-109.module+el8.6.0+20693+52f02d9c.noarch.rpm rubygem-test-unit-3.2.9-109.module+el8.6.0+20693+52f02d9c.noarch.rpm rubygem-xmlrpc-0.3.0-109.module+el8.6.0+20693+52f02d9c.noarch.rpm ruby-libs-2.6.10-109.module+el8.6.0+20693+52f02d9c.i686.rpm ruby-libs-2.6.10-109.module+el8.6.0+20693+52f02d9c.x86_64.rpm aarch64: ruby-2.6.10-109.module+el8.6.0+20693+52f02d9c.aarch64.rpm ruby-devel-2.6.10-109.module+el8.6.0+20693+52f02d9c.aarch64.rpm ruby-doc-2.6.10-109.module+el8.6.0+20693+52f02d9c.noarch.rpm rubygem-abrt-0.3.0-4.module+el8.1.0+5406+ce01f9b9.noarch.rpm rubygem-abrt-doc-0.3.0-4.module+el8.1.0+5406+ce01f9b9.noarch.rpm rubygem-bigdecimal-1.4.1-109.module+el8.6.0+20693+52f02d9c.aarch64.rpm rubygem-bson-4.5.0-1.module+el8.4.0+20235+1e5b8be3.aarch64.rpm rubygem-bson-doc-4.5.0-1.module+el8.4.0+20235+1e5b8be3.noarch.rpm rubygem-bundler-1.17.2-109.module+el8.6.0+20693+52f02d9c.noarch.rpm rubygem-did_you_mean-1.3.0-109.module+el8.6.0+20693+52f02d9c.noarch.rpm rubygem-io-console-0.4.7-109.module+el8.6.0+20693+52f02d9c.aarch64.rpm rubygem-irb-1.0.0-109.module+el8.6.0+20693+52f02d9c.noarch.rpm rubygem-json-2.1.0-109.module+el8.6.0+20693+52f02d9c.aarch64.rpm rubygem-minitest-5.11.3-109.module+el8.6.0+20693+52f02d9c.noarch.rpm rubygem-mongo-2.8.0-1.module+el8.1.0+5406+ce01f9b9.noarch.rpm rubygem-mongo-doc-2.8.0-1.module+el8.1.0+5406+ce01f9b9.noarch.rpm rubygem-mysql2-0.5.2-1.module+el8.4.0+20235+1e5b8be3.aarch64.rpm rubygem-mysql2-doc-0.5.2-1.module+el8.4.0+20235+1e5b8be3.noarch.rpm rubygem-net-telnet-0.2.0-109.module+el8.6.0+20693+52f02d9c.noarch.rpm rubygem-openssl-2.1.2-109.module+el8.6.0+20693+52f02d9c.aarch64.rpm rubygem-pg-1.1.4-1.module+el8.4.0+20235+1e5b8be3.aarch64.rpm rubygem-pg-doc-1.1.4-1.module+el8.4.0+20235+1e5b8be3.noarch.rpm rubygem-power_assert-1.1.3-109.module+el8.6.0+20693+52f02d9c.noarch.rpm rubygem-psych-3.1.0-109.module+el8.6.0+20693+52f02d9c.aarch64.rpm rubygem-rake-12.3.3-109.module+el8.6.0+20693+52f02d9c.noarch.rpm rubygem-rdoc-6.1.2.1-109.module+el8.6.0+20693+52f02d9c.noarch.rpm rubygems-3.0.3.1-109.module+el8.6.0+20693+52f02d9c.noarch.rpm rubygems-devel-3.0.3.1-109.module+el8.6.0+20693+52f02d9c.noarch.rpm rubygem-test-unit-3.2.9-109.module+el8.6.0+20693+52f02d9c.noarch.rpm rubygem-xmlrpc-0.3.0-109.module+el8.6.0+20693+52f02d9c.noarch.rpm ruby-libs-2.6.10-109.module+el8.6.0+20693+52f02d9c.aarch64.rpm

SRPMS

https://oss.oracle.com/ol8/SRPMS-updates/ruby-2.6.10-109.module+el8.6.0+20693+52f02d9c.src.rpm https://oss.oracle.com/ol8/SRPMS-updates/rubygem-abrt-0.3.0-4.module+el8.1.0+5406+ce01f9b9.src.rpm https://oss.oracle.com/ol8/SRPMS-updates/rubygem-bson-4.5.0-1.module+el8.4.0+20235+1e5b8be3.src.rpm https://oss.oracle.com/ol8/SRPMS-updates/rubygem-mongo-2.8.0-1.module+el8.1.0+5406+ce01f9b9.src.rpm https://oss.oracle.com/ol8/SRPMS-updates/rubygem-mysql2-0.5.2-1.module+el8.4.0+20235+1e5b8be3.src.rpm https://oss.oracle.com/ol8/SRPMS-updates/rubygem-pg-1.1.4-1.module+el8.4.0+20235+1e5b8be3.src.rpm

Severity
Related CVEs: CVE-2022-28739

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.