Oracle8: ELSA-2022-5467: php Important Security Update | LinuxSecur...

Advisories

Oracle Linux Security Advisory ELSA-2022-5467

https://linux.oracle.com/errata/ELSA-2022-5467.html

The following updated rpms for Oracle Linux 8 have been uploaded to the Unbreakable Linux Network:

x86_64:
apcu-panel-5.1.18-1.module+el8.3.0+7685+72d70b58.noarch.rpm
libzip-1.6.1-1.module+el8.3.0+7685+72d70b58.x86_64.rpm
libzip-devel-1.6.1-1.module+el8.3.0+7685+72d70b58.x86_64.rpm
libzip-tools-1.6.1-1.module+el8.3.0+7685+72d70b58.x86_64.rpm
php-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm
php-bcmath-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm
php-cli-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm
php-common-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm
php-dba-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm
php-dbg-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm
php-devel-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm
php-embedded-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm
php-enchant-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm
php-ffi-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm
php-fpm-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm
php-gd-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm
php-gmp-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm
php-intl-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm
php-json-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm
php-ldap-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm
php-mbstring-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm
php-mysqlnd-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm
php-odbc-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm
php-opcache-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm
php-pdo-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm
php-pear-1.10.12-1.module+el8.3.0+7685+72d70b58.noarch.rpm
php-pecl-apcu-5.1.18-1.module+el8.3.0+7685+72d70b58.x86_64.rpm
php-pecl-apcu-devel-5.1.18-1.module+el8.3.0+7685+72d70b58.x86_64.rpm
php-pecl-rrd-2.0.1-1.module+el8.3.0+7685+72d70b58.x86_64.rpm
php-pecl-xdebug-2.9.5-1.module+el8.3.0+7685+72d70b58.x86_64.rpm
php-pecl-zip-1.18.2-1.module+el8.3.0+7685+72d70b58.x86_64.rpm
php-pgsql-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm
php-process-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm
php-snmp-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm
php-soap-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm
php-xml-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm
php-xmlrpc-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm

aarch64:
apcu-panel-5.1.18-1.module+el8.3.0+7685+72d70b58.noarch.rpm
libzip-1.6.1-1.module+el8.3.0+7685+72d70b58.aarch64.rpm
libzip-devel-1.6.1-1.module+el8.3.0+7685+72d70b58.aarch64.rpm
libzip-tools-1.6.1-1.module+el8.3.0+7685+72d70b58.aarch64.rpm
php-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm
php-bcmath-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm
php-cli-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm
php-common-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm
php-dba-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm
php-dbg-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm
php-devel-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm
php-embedded-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm
php-enchant-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm
php-ffi-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm
php-fpm-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm
php-gd-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm
php-gmp-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm
php-intl-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm
php-json-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm
php-ldap-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm
php-mbstring-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm
php-mysqlnd-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm
php-odbc-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm
php-opcache-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm
php-pdo-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm
php-pear-1.10.12-1.module+el8.3.0+7685+72d70b58.noarch.rpm
php-pecl-apcu-5.1.18-1.module+el8.3.0+7685+72d70b58.aarch64.rpm
php-pecl-apcu-devel-5.1.18-1.module+el8.3.0+7685+72d70b58.aarch64.rpm
php-pecl-rrd-2.0.1-1.module+el8.3.0+7685+72d70b58.aarch64.rpm
php-pecl-xdebug-2.9.5-1.module+el8.3.0+7685+72d70b58.aarch64.rpm
php-pecl-zip-1.18.2-1.module+el8.3.0+7685+72d70b58.aarch64.rpm
php-pgsql-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm
php-process-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm
php-snmp-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm
php-soap-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm
php-xml-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm
php-xmlrpc-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm


SRPMS:
https://oss.oracle.com/ol8/SRPMS-updates/libzip-1.6.1-1.module+el8.3.0+7685+72d70b58.src.rpm
https://oss.oracle.com/ol8/SRPMS-updates/php-7.4.19-3.module+el8.6.0+20697+59319e67.src.rpm
https://oss.oracle.com/ol8/SRPMS-updates/php-pear-1.10.12-1.module+el8.3.0+7685+72d70b58.src.rpm
https://oss.oracle.com/ol8/SRPMS-updates/php-pecl-apcu-5.1.18-1.module+el8.3.0+7685+72d70b58.src.rpm
https://oss.oracle.com/ol8/SRPMS-updates/php-pecl-rrd-2.0.1-1.module+el8.3.0+7685+72d70b58.src.rpm
https://oss.oracle.com/ol8/SRPMS-updates/php-pecl-xdebug-2.9.5-1.module+el8.3.0+7685+72d70b58.src.rpm
https://oss.oracle.com/ol8/SRPMS-updates/php-pecl-zip-1.18.2-1.module+el8.3.0+7685+72d70b58.src.rpm

Related CVEs:

CVE-2022-31626




Description of changes:

php
[7.4.19-3]
- fix password of excessive length triggers buffer overflow leading to RCE
  CVE-2022-31626

_______________________________________________
El-errata mailing list
[email protected]
https://oss.oracle.com/mailman/listinfo/el-errata

Oracle8: ELSA-2022-5467: php Important Security Update

Summary

Description of changes: php [7.4.19-3] - fix password of excessive length triggers buffer overflow leading to RCE CVE-2022-31626

i386

x86_64

apcu-panel-5.1.18-1.module+el8.3.0+7685+72d70b58.noarch.rpm libzip-1.6.1-1.module+el8.3.0+7685+72d70b58.x86_64.rpm libzip-devel-1.6.1-1.module+el8.3.0+7685+72d70b58.x86_64.rpm libzip-tools-1.6.1-1.module+el8.3.0+7685+72d70b58.x86_64.rpm php-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm php-bcmath-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm php-cli-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm php-common-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm php-dba-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm php-dbg-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm php-devel-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm php-embedded-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm php-enchant-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm php-ffi-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm php-fpm-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm php-gd-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm php-gmp-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm php-intl-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm php-json-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm php-ldap-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm php-mbstring-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm php-mysqlnd-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm php-odbc-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm php-opcache-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm php-pdo-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm php-pear-1.10.12-1.module+el8.3.0+7685+72d70b58.noarch.rpm php-pecl-apcu-5.1.18-1.module+el8.3.0+7685+72d70b58.x86_64.rpm php-pecl-apcu-devel-5.1.18-1.module+el8.3.0+7685+72d70b58.x86_64.rpm php-pecl-rrd-2.0.1-1.module+el8.3.0+7685+72d70b58.x86_64.rpm php-pecl-xdebug-2.9.5-1.module+el8.3.0+7685+72d70b58.x86_64.rpm php-pecl-zip-1.18.2-1.module+el8.3.0+7685+72d70b58.x86_64.rpm php-pgsql-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm php-process-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm php-snmp-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm php-soap-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm php-xml-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm php-xmlrpc-7.4.19-3.module+el8.6.0+20697+59319e67.x86_64.rpm aarch64: apcu-panel-5.1.18-1.module+el8.3.0+7685+72d70b58.noarch.rpm libzip-1.6.1-1.module+el8.3.0+7685+72d70b58.aarch64.rpm libzip-devel-1.6.1-1.module+el8.3.0+7685+72d70b58.aarch64.rpm libzip-tools-1.6.1-1.module+el8.3.0+7685+72d70b58.aarch64.rpm php-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm php-bcmath-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm php-cli-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm php-common-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm php-dba-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm php-dbg-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm php-devel-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm php-embedded-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm php-enchant-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm php-ffi-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm php-fpm-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm php-gd-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm php-gmp-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm php-intl-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm php-json-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm php-ldap-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm php-mbstring-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm php-mysqlnd-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm php-odbc-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm php-opcache-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm php-pdo-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm php-pear-1.10.12-1.module+el8.3.0+7685+72d70b58.noarch.rpm php-pecl-apcu-5.1.18-1.module+el8.3.0+7685+72d70b58.aarch64.rpm php-pecl-apcu-devel-5.1.18-1.module+el8.3.0+7685+72d70b58.aarch64.rpm php-pecl-rrd-2.0.1-1.module+el8.3.0+7685+72d70b58.aarch64.rpm php-pecl-xdebug-2.9.5-1.module+el8.3.0+7685+72d70b58.aarch64.rpm php-pecl-zip-1.18.2-1.module+el8.3.0+7685+72d70b58.aarch64.rpm php-pgsql-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm php-process-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm php-snmp-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm php-soap-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm php-xml-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm php-xmlrpc-7.4.19-3.module+el8.6.0+20697+59319e67.aarch64.rpm

SRPMS

https://oss.oracle.com/ol8/SRPMS-updates/libzip-1.6.1-1.module+el8.3.0+7685+72d70b58.src.rpm https://oss.oracle.com/ol8/SRPMS-updates/php-7.4.19-3.module+el8.6.0+20697+59319e67.src.rpm https://oss.oracle.com/ol8/SRPMS-updates/php-pear-1.10.12-1.module+el8.3.0+7685+72d70b58.src.rpm https://oss.oracle.com/ol8/SRPMS-updates/php-pecl-apcu-5.1.18-1.module+el8.3.0+7685+72d70b58.src.rpm https://oss.oracle.com/ol8/SRPMS-updates/php-pecl-rrd-2.0.1-1.module+el8.3.0+7685+72d70b58.src.rpm https://oss.oracle.com/ol8/SRPMS-updates/php-pecl-xdebug-2.9.5-1.module+el8.3.0+7685+72d70b58.src.rpm https://oss.oracle.com/ol8/SRPMS-updates/php-pecl-zip-1.18.2-1.module+el8.3.0+7685+72d70b58.src.rpm

Severity
Related CVEs: CVE-2022-31626

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.