Oracle8: ELSA-2022-5813: vim Moderate Security Update

Advisories

Oracle Linux Security Advisory ELSA-2022-5813

https://linux.oracle.com/errata/ELSA-2022-5813.html

The following updated rpms for Oracle Linux 8 have been uploaded to the Unbreakable Linux Network:

x86_64:
vim-X11-8.0.1763-19.0.1.el8_6.4.x86_64.rpm
vim-common-8.0.1763-19.0.1.el8_6.4.x86_64.rpm
vim-enhanced-8.0.1763-19.0.1.el8_6.4.x86_64.rpm
vim-filesystem-8.0.1763-19.0.1.el8_6.4.noarch.rpm
vim-minimal-8.0.1763-19.0.1.el8_6.4.x86_64.rpm

aarch64:
vim-X11-8.0.1763-19.0.1.el8_6.4.aarch64.rpm
vim-common-8.0.1763-19.0.1.el8_6.4.aarch64.rpm
vim-enhanced-8.0.1763-19.0.1.el8_6.4.aarch64.rpm
vim-filesystem-8.0.1763-19.0.1.el8_6.4.noarch.rpm
vim-minimal-8.0.1763-19.0.1.el8_6.4.aarch64.rpm


SRPMS:
https://oss.oracle.com/ol8/SRPMS-updates/vim-8.0.1763-19.0.1.el8_6.4.src.rpm

Related CVEs:

CVE-2022-1785
CVE-2022-1897
CVE-2022-1927




Description of changes:

[8.0.1763-19.0.1.4]
- Remove upstream references [Orabug: 31197557]
- Added glibc-gconv-extra to common requires to provide ISO-8859-2 [Orabug: 34114984]

[2:8.0.1763-19.4]
- fix issue reported by covscan

[2:8.0.1763-19.3]
- CVE-2022-1785 vim: Out-of-bounds Write
- CVE-2022-1897 vim: out-of-bounds write in vim_regsub_both() in regexp.c
- CVE-2022-1927 vim: buffer over-read in utf_ptr2char() in mbyte.c

_______________________________________________
El-errata mailing list
[email protected]
https://oss.oracle.com/mailman/listinfo/el-errata

Oracle8: ELSA-2022-5813: vim Moderate Security Update

Summary

Description of changes: [8.0.1763-19.0.1.4] - Remove upstream references [Orabug: 31197557] - Added glibc-gconv-extra to common requires to provide ISO-8859-2 [Orabug: 34114984] [2:8.0.1763-19.4] - fix issue reported by covscan [2:8.0.1763-19.3] - CVE-2022-1785 vim: Out-of-bounds Write - CVE-2022-1897 vim: out-of-bounds write in vim_regsub_both() in regexp.c - CVE-2022-1927 vim: buffer over-read in utf_ptr2char() in mbyte.c

i386

x86_64

vim-X11-8.0.1763-19.0.1.el8_6.4.x86_64.rpm vim-common-8.0.1763-19.0.1.el8_6.4.x86_64.rpm vim-enhanced-8.0.1763-19.0.1.el8_6.4.x86_64.rpm vim-filesystem-8.0.1763-19.0.1.el8_6.4.noarch.rpm vim-minimal-8.0.1763-19.0.1.el8_6.4.x86_64.rpm aarch64: vim-X11-8.0.1763-19.0.1.el8_6.4.aarch64.rpm vim-common-8.0.1763-19.0.1.el8_6.4.aarch64.rpm vim-enhanced-8.0.1763-19.0.1.el8_6.4.aarch64.rpm vim-filesystem-8.0.1763-19.0.1.el8_6.4.noarch.rpm vim-minimal-8.0.1763-19.0.1.el8_6.4.aarch64.rpm

SRPMS

https://oss.oracle.com/ol8/SRPMS-updates/vim-8.0.1763-19.0.1.el8_6.4.src.rpm

Severity
Related CVEs: CVE-2022-1785 CVE-2022-1897 CVE-2022-1927

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.