Oracle9: ELSA-2022-5245: curl Moderate Security Update | LinuxSecur...

Advisories

Oracle Linux Security Advisory ELSA-2022-5245

https://linux.oracle.com/errata/ELSA-2022-5245.html

The following updated rpms for Oracle Linux 9 have been uploaded to the Unbreakable Linux Network:


x86_64:
curl-7.76.1-14.el9_0.4.x86_64.rpm
curl-minimal-7.76.1-14.el9_0.4.x86_64.rpm
libcurl-7.76.1-14.el9_0.4.i686.rpm
libcurl-7.76.1-14.el9_0.4.x86_64.rpm
libcurl-devel-7.76.1-14.el9_0.4.i686.rpm
libcurl-devel-7.76.1-14.el9_0.4.x86_64.rpm
libcurl-minimal-7.76.1-14.el9_0.4.i686.rpm
libcurl-minimal-7.76.1-14.el9_0.4.x86_64.rpm

aarch64:
curl-7.76.1-14.el9_0.4.aarch64.rpm
curl-minimal-7.76.1-14.el9_0.4.aarch64.rpm
libcurl-7.76.1-14.el9_0.4.aarch64.rpm
libcurl-devel-7.76.1-14.el9_0.4.aarch64.rpm
libcurl-minimal-7.76.1-14.el9_0.4.aarch64.rpm


SRPMS:
https://oss.oracle.com/ol9/SRPMS-updates/curl-7.76.1-14.el9_0.4.src.rpm

Related CVEs:

CVE-2022-22576
CVE-2022-27774
CVE-2022-27776
CVE-2022-27782




Description of changes:

[7.76.1-14.el9_0.4]
- fix too eager reuse of TLS and SSH connections (CVE-2022-27782)

[7.76.1-14.el9_0.3]
- fix leak of SRP credentials in redirects (CVE-2022-27774)

[7.76.1-14.el9_0.2]
- add missing tests to Makefile

[7.76.1-14.el9_0.1]
- fix credential leak on redirect (CVE-2022-27774)
- fix auth/cookie leak on redirect (CVE-2022-27776)
- fix OAUTH2 bearer bypass in connection re-use (CVE-2022-22576)

_______________________________________________
El-errata mailing list
[email protected]
https://oss.oracle.com/mailman/listinfo/el-errata

Oracle9: ELSA-2022-5245: curl Moderate Security Update

Summary

Description of changes: [7.76.1-14.el9_0.4] - fix too eager reuse of TLS and SSH connections (CVE-2022-27782) [7.76.1-14.el9_0.3] - fix leak of SRP credentials in redirects (CVE-2022-27774) [7.76.1-14.el9_0.2] - add missing tests to Makefile [7.76.1-14.el9_0.1] - fix credential leak on redirect (CVE-2022-27774) - fix auth/cookie leak on redirect (CVE-2022-27776) - fix OAUTH2 bearer bypass in connection re-use (CVE-2022-22576)

i386

x86_64

curl-7.76.1-14.el9_0.4.x86_64.rpm curl-minimal-7.76.1-14.el9_0.4.x86_64.rpm libcurl-7.76.1-14.el9_0.4.i686.rpm libcurl-7.76.1-14.el9_0.4.x86_64.rpm libcurl-devel-7.76.1-14.el9_0.4.i686.rpm libcurl-devel-7.76.1-14.el9_0.4.x86_64.rpm libcurl-minimal-7.76.1-14.el9_0.4.i686.rpm libcurl-minimal-7.76.1-14.el9_0.4.x86_64.rpm aarch64: curl-7.76.1-14.el9_0.4.aarch64.rpm curl-minimal-7.76.1-14.el9_0.4.aarch64.rpm libcurl-7.76.1-14.el9_0.4.aarch64.rpm libcurl-devel-7.76.1-14.el9_0.4.aarch64.rpm libcurl-minimal-7.76.1-14.el9_0.4.aarch64.rpm

SRPMS

https://oss.oracle.com/ol9/SRPMS-updates/curl-7.76.1-14.el9_0.4.src.rpm

Severity
Related CVEs: CVE-2022-22576 CVE-2022-27774 CVE-2022-27776 CVE-2022-27782

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.