Oracle9: ELSA-2023-0321: nodejs and nodejs-nodemon security, bug fi...
Oracle Linux Security Advisory ELSA-2023-0321

https://linux.oracle.com/errata/ELSA-2023-0321.html

The following updated rpms for Oracle Linux 9 have been uploaded to the Unbreakable Linux Network:

x86_64:
nodejs-16.18.1-3.el9_1.x86_64.rpm
nodejs-docs-16.18.1-3.el9_1.noarch.rpm
nodejs-full-i18n-16.18.1-3.el9_1.x86_64.rpm
nodejs-libs-16.18.1-3.el9_1.i686.rpm
nodejs-libs-16.18.1-3.el9_1.x86_64.rpm
nodejs-nodemon-2.0.20-2.el9_1.noarch.rpm
npm-8.19.2-1.16.18.1.3.el9_1.x86_64.rpm

aarch64:
nodejs-16.18.1-3.el9_1.aarch64.rpm
nodejs-docs-16.18.1-3.el9_1.noarch.rpm
nodejs-full-i18n-16.18.1-3.el9_1.aarch64.rpm
nodejs-libs-16.18.1-3.el9_1.aarch64.rpm
nodejs-nodemon-2.0.20-2.el9_1.noarch.rpm
npm-8.19.2-1.16.18.1.3.el9_1.aarch64.rpm


SRPMS:
https://oss.oracle.com/ol9/SRPMS-updates//nodejs-16.18.1-3.el9_1.src.rpm
https://oss.oracle.com/ol9/SRPMS-updates//nodejs-nodemon-2.0.20-2.el9_1.src.rpm

Related CVEs:

CVE-2021-44906
CVE-2022-3517
CVE-2022-35256
CVE-2022-43548




Description of changes:

nodejs
[1:16.18.1-3]
- Update sources of undici WASM blobs
  Resolves: rhbz#2151617

[1:16.18.1-2]
- Add back libs and v8-devel subpackages
- Related: RHBZ#2121126
- Record previously fixed CVE
- Resolves: CVE-2021-44906

[1:16.18.1-1]
- Rebase + CVEs
- Resolves: #2142808
- Resolves: #2142826, #2131745, #2142855

nodejs-nodemon
[2.0.20-2]
- Record CVE fixed in the current or previous upstream versions
- Resolves: CVE-2021-44906


_______________________________________________
El-errata mailing list
[email protected]
https://oss.oracle.com/mailman/listinfo/el-errata

Oracle9: ELSA-2023-0321: nodejs and nodejs-nodemon security, bug fix, and enhancement Mode

The following updated rpms for Oracle Linux 9 have been uploaded to the Unbreakable Linux Network:

Summary

nodejs [1:16.18.1-3] - Update sources of undici WASM blobs Resolves: rhbz#2151617 [1:16.18.1-2] - Add back libs and v8-devel subpackages - Related: RHBZ#2121126 - Record previously fixed CVE - Resolves: CVE-2021-44906 [1:16.18.1-1] - Rebase + CVEs - Resolves: #2142808 - Resolves: #2142826, #2131745, #2142855 nodejs-nodemon [2.0.20-2] - Record CVE fixed in the current or previous upstream versions - Resolves: CVE-2021-44906

SRPMs

https://oss.oracle.com/ol9/SRPMS-updates//nodejs-16.18.1-3.el9_1.src.rpm https://oss.oracle.com/ol9/SRPMS-updates//nodejs-nodemon-2.0.20-2.el9_1.src.rpm

x86_64

nodejs-16.18.1-3.el9_1.x86_64.rpm nodejs-docs-16.18.1-3.el9_1.noarch.rpm nodejs-full-i18n-16.18.1-3.el9_1.x86_64.rpm nodejs-libs-16.18.1-3.el9_1.i686.rpm nodejs-libs-16.18.1-3.el9_1.x86_64.rpm nodejs-nodemon-2.0.20-2.el9_1.noarch.rpm npm-8.19.2-1.16.18.1.3.el9_1.x86_64.rpm

aarch64

nodejs-16.18.1-3.el9_1.aarch64.rpm nodejs-docs-16.18.1-3.el9_1.noarch.rpm nodejs-full-i18n-16.18.1-3.el9_1.aarch64.rpm nodejs-libs-16.18.1-3.el9_1.aarch64.rpm nodejs-nodemon-2.0.20-2.el9_1.noarch.rpm npm-8.19.2-1.16.18.1.3.el9_1.aarch64.rpm

i386

Severity
Related CVEs: CVE-2021-44906 CVE-2022-3517 CVE-2022-35256 CVE-2022-43548

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.