-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Moderate: nodejs:12 security and bug fix update
Advisory ID:       RHSA-2020:5499-01
Product:           Red Hat Enterprise Linux
Advisory URL:      https://access.redhat.com/errata/RHSA-2020:5499
Issue date:        2020-12-15
CVE Names:         CVE-2020-7774 CVE-2020-8277 CVE-2020-15366 
=====================================================================

1. Summary:

An update for the nodejs:12 module is now available for Red Hat Enterprise
Linux 8.

Red Hat Product Security has rated this update as having a security impact
of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which
gives a detailed severity rating, is available for each vulnerability from
the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux AppStream (v. 8) - aarch64, noarch, ppc64le, s390x, x86_64

3. Description:

Node.js is a software development platform for building fast and scalable
network applications in the JavaScript programming language. 

Security Fix(es):

* nodejs-y18n: prototype pollution vulnerability (CVE-2020-7774)

* c-ares: ares_parse_{a,aaaa}_reply() insufficient naddrttls validation DoS
(CVE-2020-8277)

* nodejs-ajv: prototype pollution via crafted JSON schema in ajv.validate
function (CVE-2020-15366)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

Bug Fix(es):

* yarn install crashes with nodejs:12 on aarch64 (BZ#1901045)

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

5. Bugs fixed (https://bugzilla.redhat.com/):

1857977 - CVE-2020-15366 nodejs-ajv: prototype pollution via crafted JSON schema in ajv.validate function
1898554 - CVE-2020-8277 c-ares: ares_parse_{a,aaaa}_reply() insufficient naddrttls validation DoS
1898680 - CVE-2020-7774 nodejs-y18n: prototype pollution vulnerability

6. Package List:

Red Hat Enterprise Linux AppStream (v. 8):

Source:
nodejs-12.19.1-1.module+el8.3.0+8851+b7b41ca0.src.rpm
nodejs-nodemon-1.18.3-1.module+el8.1.0+3369+37ae6a45.src.rpm
nodejs-packaging-17-3.module+el8.1.0+3369+37ae6a45.src.rpm

aarch64:
nodejs-12.19.1-1.module+el8.3.0+8851+b7b41ca0.aarch64.rpm
nodejs-debuginfo-12.19.1-1.module+el8.3.0+8851+b7b41ca0.aarch64.rpm
nodejs-debugsource-12.19.1-1.module+el8.3.0+8851+b7b41ca0.aarch64.rpm
nodejs-devel-12.19.1-1.module+el8.3.0+8851+b7b41ca0.aarch64.rpm
nodejs-full-i18n-12.19.1-1.module+el8.3.0+8851+b7b41ca0.aarch64.rpm
npm-6.14.8-1.12.19.1.1.module+el8.3.0+8851+b7b41ca0.aarch64.rpm

noarch:
nodejs-docs-12.19.1-1.module+el8.3.0+8851+b7b41ca0.noarch.rpm
nodejs-nodemon-1.18.3-1.module+el8.1.0+3369+37ae6a45.noarch.rpm
nodejs-packaging-17-3.module+el8.1.0+3369+37ae6a45.noarch.rpm

ppc64le:
nodejs-12.19.1-1.module+el8.3.0+8851+b7b41ca0.ppc64le.rpm
nodejs-debuginfo-12.19.1-1.module+el8.3.0+8851+b7b41ca0.ppc64le.rpm
nodejs-debugsource-12.19.1-1.module+el8.3.0+8851+b7b41ca0.ppc64le.rpm
nodejs-devel-12.19.1-1.module+el8.3.0+8851+b7b41ca0.ppc64le.rpm
nodejs-full-i18n-12.19.1-1.module+el8.3.0+8851+b7b41ca0.ppc64le.rpm
npm-6.14.8-1.12.19.1.1.module+el8.3.0+8851+b7b41ca0.ppc64le.rpm

s390x:
nodejs-12.19.1-1.module+el8.3.0+8851+b7b41ca0.s390x.rpm
nodejs-debuginfo-12.19.1-1.module+el8.3.0+8851+b7b41ca0.s390x.rpm
nodejs-debugsource-12.19.1-1.module+el8.3.0+8851+b7b41ca0.s390x.rpm
nodejs-devel-12.19.1-1.module+el8.3.0+8851+b7b41ca0.s390x.rpm
nodejs-full-i18n-12.19.1-1.module+el8.3.0+8851+b7b41ca0.s390x.rpm
npm-6.14.8-1.12.19.1.1.module+el8.3.0+8851+b7b41ca0.s390x.rpm

x86_64:
nodejs-12.19.1-1.module+el8.3.0+8851+b7b41ca0.x86_64.rpm
nodejs-debuginfo-12.19.1-1.module+el8.3.0+8851+b7b41ca0.x86_64.rpm
nodejs-debugsource-12.19.1-1.module+el8.3.0+8851+b7b41ca0.x86_64.rpm
nodejs-devel-12.19.1-1.module+el8.3.0+8851+b7b41ca0.x86_64.rpm
nodejs-full-i18n-12.19.1-1.module+el8.3.0+8851+b7b41ca0.x86_64.rpm
npm-6.14.8-1.12.19.1.1.module+el8.3.0+8851+b7b41ca0.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2020-7774
https://access.redhat.com/security/cve/CVE-2020-8277
https://access.redhat.com/security/cve/CVE-2020-15366
https://access.redhat.com/security/updates/classification/#moderate

8. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2020 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIVAwUBX9jwRNzjgjWX9erEAQgn4w//Qik4i/lXf9CWAOuvlAKFIqzJPD22x/iR
DKCJByCYNpdcJzq1POZM9seCrq7qOoPQPxkHBJvo6cT2oXGyeI5dlPkFY1g6oY9o
3obOjTa7/OIA6QZoh77cKZCdIqL92K6OfVtfjYYyeCdqT5J6pKtOsYZ1Hfg2daLC
OflTqGtJvi1ed/Bw0PkFKZAAdGXARl9nxW7bWKXbY6wahSsKvMSUhvpaBIbhufeQ
Dp3C02fnWusJR1KYRl4ke1ObE7PyNk8I3K8oqXTG0dvBu/so/qLiA9rKTd/BuNQ5
kv3wLDuiMSjo/DCWYe1shwvpw7nXkCH5m1SBvr6h3ssfDA0fgfXLoSZIdwbjkxin
qQrUQUa9LJXzepOAYCBI1Oq4fplAtmzs235zhps7/WQEwEQECOzO8HBSLaB2XabL
J9VpN0PHEP2CpJQJuyzUpQoOqUEAqODNj42afvoWey1n9Yi5aRp40clAhqiIQJgk
5l6ymy55J/8PJ9LaF4inC363rKOr30uaUpmrwXPnYV6VYyRNYRJ43LRaObPxsS1c
QJEVP+X3xLSWwB4TiWqD1jmKQBdqe7i1/uiYEIRrAMMXCYQ1BAcua8O4Oww9Ae1K
feBaQCc6+479TlDiQGudnqDiS97ExVSysdVATyCWdUFuBtxNJZFYkdASpGZkcgra
j/Ac5kMs4W0=
=ZA9R
-----END PGP SIGNATURE-----

--
RHSA-announce mailing list
[email protected]
https://www.redhat.com/mailman/listinfo/rhsa-announce