-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Important: postgresql:10 security update
Advisory ID:       RHSA-2020:5567-01
Product:           Red Hat Enterprise Linux
Advisory URL:      https://access.redhat.com/errata/RHSA-2020:5567
Issue date:        2020-12-16
CVE Names:         CVE-2020-25694 CVE-2020-25695 CVE-2020-25696 
=====================================================================

1. Summary:

An update for the postgresql:10 module is now available for Red Hat
Enterprise Linux 8.

Red Hat Product Security has rated this update as having a security impact
of Important. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available for each vulnerability
from the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux AppStream (v. 8) - aarch64, ppc64le, s390x, x86_64

3. Description:

PostgreSQL is an advanced object-relational database management system
(DBMS).

The following packages have been upgraded to a later upstream version:
postgresql (10.15).

Security Fix(es):

* postgresql: Reconnection can downgrade connection security settings
(CVE-2020-25694)

* postgresql: Multiple features escape "security restricted operation"
sandbox (CVE-2020-25695)

* postgresql: psql's \gset allows overwriting specially treated variables
(CVE-2020-25696)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

If the postgresql service is running, it will be automatically restarted
after installing this update.

5. Bugs fixed (https://bugzilla.redhat.com/):

1894423 - CVE-2020-25694 postgresql: Reconnection can downgrade connection security settings
1894425 - CVE-2020-25695 postgresql: Multiple features escape "security restricted operation" sandbox
1894430 - CVE-2020-25696 postgresql: psql's \gset allows overwriting specially treated variables

6. Package List:

Red Hat Enterprise Linux AppStream (v. 8):

Source:
postgresql-10.15-1.module+el8.3.0+8944+1ca16b1f.src.rpm

aarch64:
postgresql-10.15-1.module+el8.3.0+8944+1ca16b1f.aarch64.rpm
postgresql-contrib-10.15-1.module+el8.3.0+8944+1ca16b1f.aarch64.rpm
postgresql-contrib-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.aarch64.rpm
postgresql-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.aarch64.rpm
postgresql-debugsource-10.15-1.module+el8.3.0+8944+1ca16b1f.aarch64.rpm
postgresql-docs-10.15-1.module+el8.3.0+8944+1ca16b1f.aarch64.rpm
postgresql-docs-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.aarch64.rpm
postgresql-plperl-10.15-1.module+el8.3.0+8944+1ca16b1f.aarch64.rpm
postgresql-plperl-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.aarch64.rpm
postgresql-plpython3-10.15-1.module+el8.3.0+8944+1ca16b1f.aarch64.rpm
postgresql-plpython3-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.aarch64.rpm
postgresql-pltcl-10.15-1.module+el8.3.0+8944+1ca16b1f.aarch64.rpm
postgresql-pltcl-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.aarch64.rpm
postgresql-server-10.15-1.module+el8.3.0+8944+1ca16b1f.aarch64.rpm
postgresql-server-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.aarch64.rpm
postgresql-server-devel-10.15-1.module+el8.3.0+8944+1ca16b1f.aarch64.rpm
postgresql-server-devel-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.aarch64.rpm
postgresql-static-10.15-1.module+el8.3.0+8944+1ca16b1f.aarch64.rpm
postgresql-test-10.15-1.module+el8.3.0+8944+1ca16b1f.aarch64.rpm
postgresql-test-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.aarch64.rpm
postgresql-test-rpm-macros-10.15-1.module+el8.3.0+8944+1ca16b1f.aarch64.rpm
postgresql-upgrade-10.15-1.module+el8.3.0+8944+1ca16b1f.aarch64.rpm
postgresql-upgrade-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.aarch64.rpm
postgresql-upgrade-devel-10.15-1.module+el8.3.0+8944+1ca16b1f.aarch64.rpm
postgresql-upgrade-devel-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.aarch64.rpm

ppc64le:
postgresql-10.15-1.module+el8.3.0+8944+1ca16b1f.ppc64le.rpm
postgresql-contrib-10.15-1.module+el8.3.0+8944+1ca16b1f.ppc64le.rpm
postgresql-contrib-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.ppc64le.rpm
postgresql-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.ppc64le.rpm
postgresql-debugsource-10.15-1.module+el8.3.0+8944+1ca16b1f.ppc64le.rpm
postgresql-docs-10.15-1.module+el8.3.0+8944+1ca16b1f.ppc64le.rpm
postgresql-docs-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.ppc64le.rpm
postgresql-plperl-10.15-1.module+el8.3.0+8944+1ca16b1f.ppc64le.rpm
postgresql-plperl-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.ppc64le.rpm
postgresql-plpython3-10.15-1.module+el8.3.0+8944+1ca16b1f.ppc64le.rpm
postgresql-plpython3-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.ppc64le.rpm
postgresql-pltcl-10.15-1.module+el8.3.0+8944+1ca16b1f.ppc64le.rpm
postgresql-pltcl-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.ppc64le.rpm
postgresql-server-10.15-1.module+el8.3.0+8944+1ca16b1f.ppc64le.rpm
postgresql-server-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.ppc64le.rpm
postgresql-server-devel-10.15-1.module+el8.3.0+8944+1ca16b1f.ppc64le.rpm
postgresql-server-devel-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.ppc64le.rpm
postgresql-static-10.15-1.module+el8.3.0+8944+1ca16b1f.ppc64le.rpm
postgresql-test-10.15-1.module+el8.3.0+8944+1ca16b1f.ppc64le.rpm
postgresql-test-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.ppc64le.rpm
postgresql-test-rpm-macros-10.15-1.module+el8.3.0+8944+1ca16b1f.ppc64le.rpm
postgresql-upgrade-10.15-1.module+el8.3.0+8944+1ca16b1f.ppc64le.rpm
postgresql-upgrade-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.ppc64le.rpm
postgresql-upgrade-devel-10.15-1.module+el8.3.0+8944+1ca16b1f.ppc64le.rpm
postgresql-upgrade-devel-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.ppc64le.rpm

s390x:
postgresql-10.15-1.module+el8.3.0+8944+1ca16b1f.s390x.rpm
postgresql-contrib-10.15-1.module+el8.3.0+8944+1ca16b1f.s390x.rpm
postgresql-contrib-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.s390x.rpm
postgresql-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.s390x.rpm
postgresql-debugsource-10.15-1.module+el8.3.0+8944+1ca16b1f.s390x.rpm
postgresql-docs-10.15-1.module+el8.3.0+8944+1ca16b1f.s390x.rpm
postgresql-docs-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.s390x.rpm
postgresql-plperl-10.15-1.module+el8.3.0+8944+1ca16b1f.s390x.rpm
postgresql-plperl-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.s390x.rpm
postgresql-plpython3-10.15-1.module+el8.3.0+8944+1ca16b1f.s390x.rpm
postgresql-plpython3-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.s390x.rpm
postgresql-pltcl-10.15-1.module+el8.3.0+8944+1ca16b1f.s390x.rpm
postgresql-pltcl-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.s390x.rpm
postgresql-server-10.15-1.module+el8.3.0+8944+1ca16b1f.s390x.rpm
postgresql-server-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.s390x.rpm
postgresql-server-devel-10.15-1.module+el8.3.0+8944+1ca16b1f.s390x.rpm
postgresql-server-devel-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.s390x.rpm
postgresql-static-10.15-1.module+el8.3.0+8944+1ca16b1f.s390x.rpm
postgresql-test-10.15-1.module+el8.3.0+8944+1ca16b1f.s390x.rpm
postgresql-test-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.s390x.rpm
postgresql-test-rpm-macros-10.15-1.module+el8.3.0+8944+1ca16b1f.s390x.rpm
postgresql-upgrade-10.15-1.module+el8.3.0+8944+1ca16b1f.s390x.rpm
postgresql-upgrade-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.s390x.rpm
postgresql-upgrade-devel-10.15-1.module+el8.3.0+8944+1ca16b1f.s390x.rpm
postgresql-upgrade-devel-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.s390x.rpm

x86_64:
postgresql-10.15-1.module+el8.3.0+8944+1ca16b1f.x86_64.rpm
postgresql-contrib-10.15-1.module+el8.3.0+8944+1ca16b1f.x86_64.rpm
postgresql-contrib-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.x86_64.rpm
postgresql-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.x86_64.rpm
postgresql-debugsource-10.15-1.module+el8.3.0+8944+1ca16b1f.x86_64.rpm
postgresql-docs-10.15-1.module+el8.3.0+8944+1ca16b1f.x86_64.rpm
postgresql-docs-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.x86_64.rpm
postgresql-plperl-10.15-1.module+el8.3.0+8944+1ca16b1f.x86_64.rpm
postgresql-plperl-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.x86_64.rpm
postgresql-plpython3-10.15-1.module+el8.3.0+8944+1ca16b1f.x86_64.rpm
postgresql-plpython3-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.x86_64.rpm
postgresql-pltcl-10.15-1.module+el8.3.0+8944+1ca16b1f.x86_64.rpm
postgresql-pltcl-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.x86_64.rpm
postgresql-server-10.15-1.module+el8.3.0+8944+1ca16b1f.x86_64.rpm
postgresql-server-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.x86_64.rpm
postgresql-server-devel-10.15-1.module+el8.3.0+8944+1ca16b1f.x86_64.rpm
postgresql-server-devel-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.x86_64.rpm
postgresql-static-10.15-1.module+el8.3.0+8944+1ca16b1f.x86_64.rpm
postgresql-test-10.15-1.module+el8.3.0+8944+1ca16b1f.x86_64.rpm
postgresql-test-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.x86_64.rpm
postgresql-test-rpm-macros-10.15-1.module+el8.3.0+8944+1ca16b1f.x86_64.rpm
postgresql-upgrade-10.15-1.module+el8.3.0+8944+1ca16b1f.x86_64.rpm
postgresql-upgrade-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.x86_64.rpm
postgresql-upgrade-devel-10.15-1.module+el8.3.0+8944+1ca16b1f.x86_64.rpm
postgresql-upgrade-devel-debuginfo-10.15-1.module+el8.3.0+8944+1ca16b1f.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2020-25694
https://access.redhat.com/security/cve/CVE-2020-25695
https://access.redhat.com/security/cve/CVE-2020-25696
https://access.redhat.com/security/updates/classification/#important

8. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2020 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIVAwUBX9nEqtzjgjWX9erEAQiYPQ/+PLzn2TatIDCie7JOQ4ghB7Ruf65S2tIL
WPnAVyd8WBYwCHdL60uwQauJZHS6z9dMqHFDiYWoMShMJUK+HuO+/gV4zKt5m9zR
7ZDfTZJ9TuFtML8KORf/4mKJfCZ2J2eM3luU+eQp/NnwlZ26BXdGvXigHV+eDxty
4H+MpOoZLyX3mcZjHPOAOn9224JS8xPv6VZdMfHVhvs1Q/7V/YcY8aRr3f0IrzLz
M7gxqf7qjx+raNU8WCCT/QdBfOOU5vDh8ENM7MWQPi/grUslDvANfGLLZwZVVVJ+
jzKv+OkR1PvFOhnkHFTVoqap/F/md0V6suj+EIF0wP+4kVrdLORiY8QD9pxHT1jT
2vCfYSF5XFHkEHll7SSU0pE2csjBA90boPqcc8XQeKbRQAiu44eaxWNfcsVzsjVG
gNcmbMpjIxnaDXZAx1qJS4O2n8aYLGxed0LGx3o3gpx4X3+RuuzS6aYASt0KXhYE
cgB3gX/iHXnwbryCivTQ+9s/J3DVq2LvGQwffqgMIBkalXRO5RmmQstPXG/Nt2CV
EPnn15VOMxZ6Cskd742QLpLLNr7vfzzIkqS1HupnM/L9Gfegxn3Aytg470wAPnN7
/ctm1K6CXKKmFaz9vAPVIH6hGCTjB2G9BLSgqWGcNisVo3PvNfRwBZeTfwr4r053
98mVZ6CDZvQ=
=uPHP
-----END PGP SIGNATURE-----

--
RHSA-announce mailing list
[email protected]
https://www.redhat.com/mailman/listinfo/rhsa-announce