RedHat: RHSA-2021-1239:01 Important: dpdk security update | LinuxSe...
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Important: dpdk security update
Advisory ID:       RHSA-2021:1239-01
Product:           Red Hat Enterprise Linux
Advisory URL:      https://access.redhat.com/errata/RHSA-2021:1239
Issue date:        2021-04-19
CVE Names:         CVE-2020-10725 
=====================================================================

1. Summary:

An update for dpdk is now available for Red Hat Enterprise Linux 8.2
Extended Update Support.

Red Hat Product Security has rated this update as having a security impact
of Important. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available for each vulnerability
from the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux AppStream EUS (v. 8.2) - aarch64, noarch, ppc64le, x86_64

3. Description:

The dpdk packages provide the Data Plane Development Kit, which is a set of
libraries and drivers for fast packet processing in the user space.

Security Fix(es):

* dpdk: librte_vhost Malicious guest could cause segfault by sending
invalid Virtio descriptor (CVE-2020-10725)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

5. Bugs fixed (https://bugzilla.redhat.com/):

1828894 - CVE-2020-10725 dpdk: librte_vhost Malicious guest could cause segfault by sending invalid Virtio descriptor

6. Package List:

Red Hat Enterprise Linux AppStream EUS (v. 8.2):

Source:
dpdk-19.11-5.el8_2.src.rpm

aarch64:
dpdk-19.11-5.el8_2.aarch64.rpm
dpdk-debuginfo-19.11-5.el8_2.aarch64.rpm
dpdk-debugsource-19.11-5.el8_2.aarch64.rpm
dpdk-devel-19.11-5.el8_2.aarch64.rpm
dpdk-devel-debuginfo-19.11-5.el8_2.aarch64.rpm
dpdk-tools-19.11-5.el8_2.aarch64.rpm

noarch:
dpdk-doc-19.11-5.el8_2.noarch.rpm

ppc64le:
dpdk-19.11-5.el8_2.ppc64le.rpm
dpdk-debuginfo-19.11-5.el8_2.ppc64le.rpm
dpdk-debugsource-19.11-5.el8_2.ppc64le.rpm
dpdk-devel-19.11-5.el8_2.ppc64le.rpm
dpdk-devel-debuginfo-19.11-5.el8_2.ppc64le.rpm
dpdk-tools-19.11-5.el8_2.ppc64le.rpm

x86_64:
dpdk-19.11-5.el8_2.x86_64.rpm
dpdk-debuginfo-19.11-5.el8_2.x86_64.rpm
dpdk-debugsource-19.11-5.el8_2.x86_64.rpm
dpdk-devel-19.11-5.el8_2.x86_64.rpm
dpdk-devel-debuginfo-19.11-5.el8_2.x86_64.rpm
dpdk-tools-19.11-5.el8_2.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2020-10725
https://access.redhat.com/security/updates/classification/#important

8. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2021 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIVAwUBYH1fAtzjgjWX9erEAQgdCQ//Tcy0GQPnjycMa/QUNb9Sr65WEF3sKnmU
1YZuHpwDqfTkxau8hcBXPUqOCnzv5OTc8mA4pcbIgHMUYVRLRUfo5Qg4yehfyrDz
dmzfPRyUm7Lzz/LJPU92tWzN7A+rcc2/JwBgEQQ+03q+ggrALepI1Vi/UqmwAsDK
2LfHiplnRUOzbXXY5SOPuJbpsOrKdTRpKcR/Iu9gUz8nSFD62+zSl93rVCLyl0Uj
vBTUv0s5gyYkwIRY0FWIpz8eWseYimHFRv7g0xdv1Pe+ZzWmi9z7jvb8n6yuQEAt
j1xO6youm+pYXcagqGGX4wF7uWwtEJyr2O2HHwWtSgzBqs3su7ulcaWH9iDZ4G5o
2Xx6E+E0HYr8zF3VSQhYPslpfYqSuYhP+e9wiHGVn13xUry1R+M+cW5Cz/fCW2il
SAADkIz2xz1hnXiISm88cv3iNOyOtEbWq1nFhyIYZsPqGUZXFweYwwo6VoiOxrnT
KuMpyQrUhoCcXLpFf9ALrqCBtOgB4a98TWo9JPqKNgSLJot+UlssVkWFXjdFbkgV
D28jeZYsVdIPQ4wnRFICk12hJTcuyz3VCcKiHbQwEBJVRsVYBLbncCtvieSQfX4I
Saaf2U20jP5lctIDfwkrJVPdKFi0mkt+p2pJ/Foj2OlV+L6i+OFIyC6cXl07IQSM
8M4guhLm4U8=
=2WOs
-----END PGP SIGNATURE-----

--
RHSA-announce mailing list
[email protected]
https://listman.redhat.com/mailman/listinfo/rhsa-announce

RedHat: RHSA-2021-1239:01 Important: dpdk security update

An update for dpdk is now available for Red Hat Enterprise Linux 8.2 Extended Update Support

Summary

The dpdk packages provide the Data Plane Development Kit, which is a set of libraries and drivers for fast packet processing in the user space.
Security Fix(es):
* dpdk: librte_vhost Malicious guest could cause segfault by sending invalid Virtio descriptor (CVE-2020-10725)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

Solution

For details on how to apply this update, which includes the changesdescribed in this advisory, refer to:https://access.redhat.com/articles/11258

References

https://access.redhat.com/security/cve/CVE-2020-10725 https://access.redhat.com/security/updates/classification/#important

Package List

Red Hat Enterprise Linux AppStream EUS (v. 8.2):
Source: dpdk-19.11-5.el8_2.src.rpm
aarch64: dpdk-19.11-5.el8_2.aarch64.rpm dpdk-debuginfo-19.11-5.el8_2.aarch64.rpm dpdk-debugsource-19.11-5.el8_2.aarch64.rpm dpdk-devel-19.11-5.el8_2.aarch64.rpm dpdk-devel-debuginfo-19.11-5.el8_2.aarch64.rpm dpdk-tools-19.11-5.el8_2.aarch64.rpm
noarch: dpdk-doc-19.11-5.el8_2.noarch.rpm
ppc64le: dpdk-19.11-5.el8_2.ppc64le.rpm dpdk-debuginfo-19.11-5.el8_2.ppc64le.rpm dpdk-debugsource-19.11-5.el8_2.ppc64le.rpm dpdk-devel-19.11-5.el8_2.ppc64le.rpm dpdk-devel-debuginfo-19.11-5.el8_2.ppc64le.rpm dpdk-tools-19.11-5.el8_2.ppc64le.rpm
x86_64: dpdk-19.11-5.el8_2.x86_64.rpm dpdk-debuginfo-19.11-5.el8_2.x86_64.rpm dpdk-debugsource-19.11-5.el8_2.x86_64.rpm dpdk-devel-19.11-5.el8_2.x86_64.rpm dpdk-devel-debuginfo-19.11-5.el8_2.x86_64.rpm dpdk-tools-19.11-5.el8_2.x86_64.rpm
These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from https://access.redhat.com/security/team/key/

Severity
Advisory ID: RHSA-2021:1239-01
Product: Red Hat Enterprise Linux
Advisory URL: https://access.redhat.com/errata/RHSA-2021:1239
Issued Date: : 2021-04-19
CVE Names: CVE-2020-10725

Topic

An update for dpdk is now available for Red Hat Enterprise Linux 8.2Extended Update Support.Red Hat Product Security has rated this update as having a security impactof Important. A Common Vulnerability Scoring System (CVSS) base score,which gives a detailed severity rating, is available for each vulnerabilityfrom the CVE link(s) in the References section.

Relevant Releases Architectures

Red Hat Enterprise Linux AppStream EUS (v. 8.2) - aarch64, noarch, ppc64le, x86_64

Bugs Fixed

1828894 - CVE-2020-10725 dpdk: librte_vhost Malicious guest could cause segfault by sending invalid Virtio descriptor

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.