-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Critical: nss security update
Advisory ID:       RHSA-2021:4933-01
Product:           Red Hat Enterprise Linux
Advisory URL:      https://access.redhat.com/errata/RHSA-2021:4933
Issue date:        2021-12-06
CVE Names:         CVE-2021-43527 
=====================================================================

1. Summary:

An update for nss is now available for Red Hat Enterprise Linux 7.6
Advanced Update Support, Red Hat Enterprise Linux 7.6 Telco Extended Update
Support, and Red Hat Enterprise Linux 7.6 Update Services for SAP
Solutions.

Red Hat Product Security has rated this update as having a security impact
of Critical. A Common Vulnerability Scoring System (CVSS) base score, which
gives a detailed severity rating, is available for each vulnerability from
the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux Server AUS (v. 7.6) - x86_64
Red Hat Enterprise Linux Server E4S (v. 7.6) - ppc64le, x86_64
Red Hat Enterprise Linux Server Optional AUS (v. 7.6) - x86_64
Red Hat Enterprise Linux Server Optional E4S (v. 7.6) - ppc64le, x86_64
Red Hat Enterprise Linux Server Optional TUS (v. 7.6) - x86_64
Red Hat Enterprise Linux Server TUS (v. 7.6) - x86_64

3. Description:

Network Security Services (NSS) is a set of libraries designed to support
the cross-platform development of security-enabled client and server
applications.

Security Fix(es):

* nss: Memory corruption in decodeECorDsaSignature with DSA signatures (and
RSA-PSS) (CVE-2021-43527)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

After installing this update, applications using NSS (for example, Firefox)
must be restarted for this update to take effect.

5. Bugs fixed (https://bugzilla.redhat.com/):

2024370 - CVE-2021-43527 nss: Memory corruption in decodeECorDsaSignature with DSA signatures (and RSA-PSS)

6. Package List:

Red Hat Enterprise Linux Server AUS (v. 7.6):

Source:
nss-3.36.0-10.2.el7_6.src.rpm

x86_64:
nss-3.36.0-10.2.el7_6.i686.rpm
nss-3.36.0-10.2.el7_6.x86_64.rpm
nss-debuginfo-3.36.0-10.2.el7_6.i686.rpm
nss-debuginfo-3.36.0-10.2.el7_6.x86_64.rpm
nss-devel-3.36.0-10.2.el7_6.i686.rpm
nss-devel-3.36.0-10.2.el7_6.x86_64.rpm
nss-sysinit-3.36.0-10.2.el7_6.x86_64.rpm
nss-tools-3.36.0-10.2.el7_6.x86_64.rpm

Red Hat Enterprise Linux Server E4S (v. 7.6):

Source:
nss-3.36.0-10.2.el7_6.src.rpm

ppc64le:
nss-3.36.0-10.2.el7_6.ppc64le.rpm
nss-debuginfo-3.36.0-10.2.el7_6.ppc64le.rpm
nss-devel-3.36.0-10.2.el7_6.ppc64le.rpm
nss-sysinit-3.36.0-10.2.el7_6.ppc64le.rpm
nss-tools-3.36.0-10.2.el7_6.ppc64le.rpm

x86_64:
nss-3.36.0-10.2.el7_6.i686.rpm
nss-3.36.0-10.2.el7_6.x86_64.rpm
nss-debuginfo-3.36.0-10.2.el7_6.i686.rpm
nss-debuginfo-3.36.0-10.2.el7_6.x86_64.rpm
nss-devel-3.36.0-10.2.el7_6.i686.rpm
nss-devel-3.36.0-10.2.el7_6.x86_64.rpm
nss-sysinit-3.36.0-10.2.el7_6.x86_64.rpm
nss-tools-3.36.0-10.2.el7_6.x86_64.rpm

Red Hat Enterprise Linux Server TUS (v. 7.6):

Source:
nss-3.36.0-10.2.el7_6.src.rpm

x86_64:
nss-3.36.0-10.2.el7_6.i686.rpm
nss-3.36.0-10.2.el7_6.x86_64.rpm
nss-debuginfo-3.36.0-10.2.el7_6.i686.rpm
nss-debuginfo-3.36.0-10.2.el7_6.x86_64.rpm
nss-devel-3.36.0-10.2.el7_6.i686.rpm
nss-devel-3.36.0-10.2.el7_6.x86_64.rpm
nss-sysinit-3.36.0-10.2.el7_6.x86_64.rpm
nss-tools-3.36.0-10.2.el7_6.x86_64.rpm

Red Hat Enterprise Linux Server Optional AUS (v. 7.6):

x86_64:
nss-debuginfo-3.36.0-10.2.el7_6.i686.rpm
nss-debuginfo-3.36.0-10.2.el7_6.x86_64.rpm
nss-pkcs11-devel-3.36.0-10.2.el7_6.i686.rpm
nss-pkcs11-devel-3.36.0-10.2.el7_6.x86_64.rpm

Red Hat Enterprise Linux Server Optional E4S (v. 7.6):

ppc64le:
nss-debuginfo-3.36.0-10.2.el7_6.ppc64le.rpm
nss-pkcs11-devel-3.36.0-10.2.el7_6.ppc64le.rpm

x86_64:
nss-debuginfo-3.36.0-10.2.el7_6.i686.rpm
nss-debuginfo-3.36.0-10.2.el7_6.x86_64.rpm
nss-pkcs11-devel-3.36.0-10.2.el7_6.i686.rpm
nss-pkcs11-devel-3.36.0-10.2.el7_6.x86_64.rpm

Red Hat Enterprise Linux Server Optional TUS (v. 7.6):

x86_64:
nss-debuginfo-3.36.0-10.2.el7_6.i686.rpm
nss-debuginfo-3.36.0-10.2.el7_6.x86_64.rpm
nss-pkcs11-devel-3.36.0-10.2.el7_6.i686.rpm
nss-pkcs11-devel-3.36.0-10.2.el7_6.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2021-43527
https://access.redhat.com/security/updates/classification/#critical
https://access.redhat.com/security/vulnerabilities/RHSB-2021-008

8. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2021 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIVAwUBYa4yNdzjgjWX9erEAQgLBw/+JXlHYGB8C7OGIG/W7w4hld3Ols6UbvV9
xa4RxCh3DvRRi6NZnIeFkFJ6S5BoLerm1s9koYZ1gStnIoWACdUuQREeak4mwHfJ
sjc/Yi0rrrjIV9hjn/NzQXn2SBHIWeZqQcCqNyqAqMJ1+DnMUSKzejhsBf8Y+4GM
fyxxM3vXsEsblWv4z8cRAp+yV+SF3UtEECOq5Cjpr/iG68uNc+JHKgcJvPK3Dt7H
ICsrzQA9Gxg0bXBPhxg/skPMwvfj2OSR99ABlq4XoTzBQvG6rEBmfxn+ukOQEeE+
AECP+r7XRfP+R7iWQ+HrUjM1S+HYXj40XaPKvV8EipDohLsAUErF5iTMajrqlFZE
VUeIwcuQWB27gIjbE/WafDyvma9cU/+udP7PvWsg/R5aM6qZTRzLRiMl8IigQA0G
VNjkz0BDfrzabw/dr7oy8W/sYgeAQoWS6LTeTpyNGPcRhzz6je0nyc1T6obSioYQ
2sbA+IWmUVbx0+w2dZhnj5psY5TTF+6B2/IG+pABPqt9Axy+B1Kr1JXKiD5gAZoA
XT/SXT8szRmxiheG0kfvNK01tA0/NM6VuUrIxsyk+nHWfDgs0V2c3vQ1Oy+pARbV
LrOWikg+0tRxI9UgUNa52Beb1uVTV+TdpdWOHBD9L+kliWuYnprjK0F2KIo5EQmS
w3zFywdm3qE=
=LMBt
-----END PGP SIGNATURE-----

--
RHSA-announce mailing list
[email protected]
https://listman.redhat.com/mailman/listinfo/rhsa-announce