-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Moderate: Red Hat OpenStack Platform 16.1 (etcd) security update
Advisory ID:       RHSA-2021:5072-01
Product:           Red Hat OpenStack Platform
Advisory URL:      https://access.redhat.com/errata/RHSA-2021:5072
Issue date:        2021-12-09
CVE Names:         CVE-2021-31525 CVE-2021-33195 CVE-2021-33197 
                   CVE-2021-33198 
=====================================================================

1. Summary:

An update for etcd is now available for Red Hat OpenStack Platform 16.1
(Train).

Red Hat Product Security has rated this update as having a security impact
of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which
gives a detailed severity rating, is available for each vulnerability from
the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat OpenStack Platform 16.1 - ppc64le, x86_64

3. Description:

A highly-available key value store for shared configuration

Security Fix(es):

* net/https: panic in ReadRequest and ReadResponse when reading a very large
header (CVE-2021-31525)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page listed in the References section.

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

5. Bugs fixed (https://bugzilla.redhat.com/):

1958341 - CVE-2021-31525 golang: net/https: panic in ReadRequest and ReadResponse when reading a very large header
1989564 - CVE-2021-33195 golang: net: lookup functions may return invalid host names
1989570 - CVE-2021-33197 golang: net/http/httputil: ReverseProxy forwards connection headers if first one is empty
1989575 - CVE-2021-33198 golang: math/big.Rat: may cause a panic or an unrecoverable fatal error if passed inputs with very large exponents

6. Package List:

Red Hat OpenStack Platform 16.1:

Source:
etcd-3.3.23-3.1.el8ost.1.src.rpm

ppc64le:
etcd-3.3.23-3.1.el8ost.1.ppc64le.rpm
etcd-debuginfo-3.3.23-3.1.el8ost.1.ppc64le.rpm
etcd-debugsource-3.3.23-3.1.el8ost.1.ppc64le.rpm

x86_64:
etcd-3.3.23-3.1.el8ost.1.x86_64.rpm
etcd-debuginfo-3.3.23-3.1.el8ost.1.x86_64.rpm
etcd-debugsource-3.3.23-3.1.el8ost.1.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2021-31525
https://access.redhat.com/security/cve/CVE-2021-33195
https://access.redhat.com/security/cve/CVE-2021-33197
https://access.redhat.com/security/cve/CVE-2021-33198
https://access.redhat.com/security/updates/classification/#moderate

8. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2021 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIVAwUBYbK/eNzjgjWX9erEAQgi1hAAkDi0+sr5a3h6z0Ui8MuUIu6lArCN5rQ0
m9QRRb7oxSLvgUHpJNdFgQEwXCnBcQ7YvQoopmhNQlzZK2/+D+WtlMv37WqOuJlv
e8psYLrLfAakao+ICbwV3MY1hSq6AdAxh5mSw750eyH5XvN4j21x2RCWpjvT8QZL
+5xzR24dJSIeNWs0haMtp2CNtcJ1gjnz4avPSQFUCn7E9bDKWMvyuIf0vsFVGC2p
Q5pWRB1f7HW0zU/W3SlqlvvSiI9m4RTIMp63+wrm6ay36CVObHMkxTsiDSKw+BlU
QfMizejdJFGmOvNh9jIiJlSEqFOkLhCPIfT8x8UVUm2mHbkRfUMDfjRKRQoFchdX
EIW9QbU9FThYlsaUl8eTwGKtGrsPMUrsols61owvBfA+ALtYjarYsUoXejaXunWV
z5VXXe7ceGlrYtvAtdaVRUVPM+W9md1/rpZRuF9zFtISCqz5AOBagA5VCpHz/KFv
aBbV21/dMgY5HZy3GBLiYxDWVEbdbeviAfM0pelZ63MSGvrCFrH7S7CayZfv/60b
kBddmbqJmCSPDoNOgLjlerBlA4hsXP/x8YvkDqrxcCU6P5JhtrF/LtOCtQiUU0+t
skHxklomTknTNTM+FsKvqOWrmGykEpyvYWjUmxZit7GTnsdepVuRmWO8TWQH7q3E
fzmSbYOgNtg=
=0OKe
-----END PGP SIGNATURE-----

--
RHSA-announce mailing list
[email protected]
https://listman.redhat.com/mailman/listinfo/rhsa-announce