RedHat: RHSA-2022-5338:01 Moderate: ruby:2.6 security, bug fix,

Advisories

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Moderate: ruby:2.6 security, bug fix, and enhancement update
Advisory ID:       RHSA-2022:5338-01
Product:           Red Hat Enterprise Linux
Advisory URL:      https://access.redhat.com/errata/RHSA-2022:5338
Issue date:        2022-06-28
CVE Names:         CVE-2022-28739 
=====================================================================

1. Summary:

An update for the ruby:2.6 module is now available for Red Hat Enterprise
Linux 8.

Red Hat Product Security has rated this update as having a security impact
of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which
gives a detailed severity rating, is available for each vulnerability from
the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux AppStream (v. 8) - aarch64, noarch, ppc64le, s390x, x86_64

3. Description:

Ruby is an extensible, interpreted, object-oriented, scripting language. It
has features to process text files and to perform system management tasks.

The following packages have been upgraded to a later upstream version: ruby
(2.6.10). (BZ#2089374)

Security Fix(es):

* Ruby: Buffer overrun in String-to-Float conversion (CVE-2022-28739)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

5. Bugs fixed (https://bugzilla.redhat.com/):

2075687 - CVE-2022-28739 Ruby: Buffer overrun in String-to-Float conversion
2089374 - ruby:2.6/ruby: Rebase to the latest Ruby 2.6 point release [rhel-8] [rhel-8.6.0.z]

6. Package List:

Red Hat Enterprise Linux AppStream (v. 8):

Source:
ruby-2.6.10-109.module+el8.6.0+15475+c55337b4.src.rpm
rubygem-abrt-0.3.0-4.module+el8.1.0+3653+beb38eb0.src.rpm
rubygem-bson-4.5.0-1.module+el8.1.0+3653+beb38eb0.src.rpm
rubygem-mongo-2.8.0-1.module+el8.1.0+3653+beb38eb0.src.rpm
rubygem-mysql2-0.5.2-1.module+el8.1.0+3653+beb38eb0.src.rpm
rubygem-pg-1.1.4-1.module+el8.1.0+3653+beb38eb0.src.rpm

aarch64:
ruby-2.6.10-109.module+el8.6.0+15475+c55337b4.aarch64.rpm
ruby-debuginfo-2.6.10-109.module+el8.6.0+15475+c55337b4.aarch64.rpm
ruby-debugsource-2.6.10-109.module+el8.6.0+15475+c55337b4.aarch64.rpm
ruby-devel-2.6.10-109.module+el8.6.0+15475+c55337b4.aarch64.rpm
ruby-libs-2.6.10-109.module+el8.6.0+15475+c55337b4.aarch64.rpm
ruby-libs-debuginfo-2.6.10-109.module+el8.6.0+15475+c55337b4.aarch64.rpm
rubygem-bigdecimal-1.4.1-109.module+el8.6.0+15475+c55337b4.aarch64.rpm
rubygem-bigdecimal-debuginfo-1.4.1-109.module+el8.6.0+15475+c55337b4.aarch64.rpm
rubygem-bson-4.5.0-1.module+el8.1.0+3653+beb38eb0.aarch64.rpm
rubygem-bson-debuginfo-4.5.0-1.module+el8.1.0+3653+beb38eb0.aarch64.rpm
rubygem-bson-debugsource-4.5.0-1.module+el8.1.0+3653+beb38eb0.aarch64.rpm
rubygem-io-console-0.4.7-109.module+el8.6.0+15475+c55337b4.aarch64.rpm
rubygem-io-console-debuginfo-0.4.7-109.module+el8.6.0+15475+c55337b4.aarch64.rpm
rubygem-json-2.1.0-109.module+el8.6.0+15475+c55337b4.aarch64.rpm
rubygem-json-debuginfo-2.1.0-109.module+el8.6.0+15475+c55337b4.aarch64.rpm
rubygem-mysql2-0.5.2-1.module+el8.1.0+3653+beb38eb0.aarch64.rpm
rubygem-mysql2-debuginfo-0.5.2-1.module+el8.1.0+3653+beb38eb0.aarch64.rpm
rubygem-mysql2-debugsource-0.5.2-1.module+el8.1.0+3653+beb38eb0.aarch64.rpm
rubygem-openssl-2.1.2-109.module+el8.6.0+15475+c55337b4.aarch64.rpm
rubygem-openssl-debuginfo-2.1.2-109.module+el8.6.0+15475+c55337b4.aarch64.rpm
rubygem-pg-1.1.4-1.module+el8.1.0+3653+beb38eb0.aarch64.rpm
rubygem-pg-debuginfo-1.1.4-1.module+el8.1.0+3653+beb38eb0.aarch64.rpm
rubygem-pg-debugsource-1.1.4-1.module+el8.1.0+3653+beb38eb0.aarch64.rpm
rubygem-psych-3.1.0-109.module+el8.6.0+15475+c55337b4.aarch64.rpm
rubygem-psych-debuginfo-3.1.0-109.module+el8.6.0+15475+c55337b4.aarch64.rpm

noarch:
ruby-doc-2.6.10-109.module+el8.6.0+15475+c55337b4.noarch.rpm
rubygem-abrt-0.3.0-4.module+el8.1.0+3653+beb38eb0.noarch.rpm
rubygem-abrt-doc-0.3.0-4.module+el8.1.0+3653+beb38eb0.noarch.rpm
rubygem-bson-doc-4.5.0-1.module+el8.1.0+3653+beb38eb0.noarch.rpm
rubygem-bundler-1.17.2-109.module+el8.6.0+15475+c55337b4.noarch.rpm
rubygem-did_you_mean-1.3.0-109.module+el8.6.0+15475+c55337b4.noarch.rpm
rubygem-irb-1.0.0-109.module+el8.6.0+15475+c55337b4.noarch.rpm
rubygem-minitest-5.11.3-109.module+el8.6.0+15475+c55337b4.noarch.rpm
rubygem-mongo-2.8.0-1.module+el8.1.0+3653+beb38eb0.noarch.rpm
rubygem-mongo-doc-2.8.0-1.module+el8.1.0+3653+beb38eb0.noarch.rpm
rubygem-mysql2-doc-0.5.2-1.module+el8.1.0+3653+beb38eb0.noarch.rpm
rubygem-net-telnet-0.2.0-109.module+el8.6.0+15475+c55337b4.noarch.rpm
rubygem-pg-doc-1.1.4-1.module+el8.1.0+3653+beb38eb0.noarch.rpm
rubygem-power_assert-1.1.3-109.module+el8.6.0+15475+c55337b4.noarch.rpm
rubygem-rake-12.3.3-109.module+el8.6.0+15475+c55337b4.noarch.rpm
rubygem-rdoc-6.1.2.1-109.module+el8.6.0+15475+c55337b4.noarch.rpm
rubygem-test-unit-3.2.9-109.module+el8.6.0+15475+c55337b4.noarch.rpm
rubygem-xmlrpc-0.3.0-109.module+el8.6.0+15475+c55337b4.noarch.rpm
rubygems-3.0.3.1-109.module+el8.6.0+15475+c55337b4.noarch.rpm
rubygems-devel-3.0.3.1-109.module+el8.6.0+15475+c55337b4.noarch.rpm

ppc64le:
ruby-2.6.10-109.module+el8.6.0+15475+c55337b4.ppc64le.rpm
ruby-debuginfo-2.6.10-109.module+el8.6.0+15475+c55337b4.ppc64le.rpm
ruby-debugsource-2.6.10-109.module+el8.6.0+15475+c55337b4.ppc64le.rpm
ruby-devel-2.6.10-109.module+el8.6.0+15475+c55337b4.ppc64le.rpm
ruby-libs-2.6.10-109.module+el8.6.0+15475+c55337b4.ppc64le.rpm
ruby-libs-debuginfo-2.6.10-109.module+el8.6.0+15475+c55337b4.ppc64le.rpm
rubygem-bigdecimal-1.4.1-109.module+el8.6.0+15475+c55337b4.ppc64le.rpm
rubygem-bigdecimal-debuginfo-1.4.1-109.module+el8.6.0+15475+c55337b4.ppc64le.rpm
rubygem-bson-4.5.0-1.module+el8.1.0+3653+beb38eb0.ppc64le.rpm
rubygem-bson-debuginfo-4.5.0-1.module+el8.1.0+3653+beb38eb0.ppc64le.rpm
rubygem-bson-debugsource-4.5.0-1.module+el8.1.0+3653+beb38eb0.ppc64le.rpm
rubygem-io-console-0.4.7-109.module+el8.6.0+15475+c55337b4.ppc64le.rpm
rubygem-io-console-debuginfo-0.4.7-109.module+el8.6.0+15475+c55337b4.ppc64le.rpm
rubygem-json-2.1.0-109.module+el8.6.0+15475+c55337b4.ppc64le.rpm
rubygem-json-debuginfo-2.1.0-109.module+el8.6.0+15475+c55337b4.ppc64le.rpm
rubygem-mysql2-0.5.2-1.module+el8.1.0+3653+beb38eb0.ppc64le.rpm
rubygem-mysql2-debuginfo-0.5.2-1.module+el8.1.0+3653+beb38eb0.ppc64le.rpm
rubygem-mysql2-debugsource-0.5.2-1.module+el8.1.0+3653+beb38eb0.ppc64le.rpm
rubygem-openssl-2.1.2-109.module+el8.6.0+15475+c55337b4.ppc64le.rpm
rubygem-openssl-debuginfo-2.1.2-109.module+el8.6.0+15475+c55337b4.ppc64le.rpm
rubygem-pg-1.1.4-1.module+el8.1.0+3653+beb38eb0.ppc64le.rpm
rubygem-pg-debuginfo-1.1.4-1.module+el8.1.0+3653+beb38eb0.ppc64le.rpm
rubygem-pg-debugsource-1.1.4-1.module+el8.1.0+3653+beb38eb0.ppc64le.rpm
rubygem-psych-3.1.0-109.module+el8.6.0+15475+c55337b4.ppc64le.rpm
rubygem-psych-debuginfo-3.1.0-109.module+el8.6.0+15475+c55337b4.ppc64le.rpm

s390x:
ruby-2.6.10-109.module+el8.6.0+15475+c55337b4.s390x.rpm
ruby-debuginfo-2.6.10-109.module+el8.6.0+15475+c55337b4.s390x.rpm
ruby-debugsource-2.6.10-109.module+el8.6.0+15475+c55337b4.s390x.rpm
ruby-devel-2.6.10-109.module+el8.6.0+15475+c55337b4.s390x.rpm
ruby-libs-2.6.10-109.module+el8.6.0+15475+c55337b4.s390x.rpm
ruby-libs-debuginfo-2.6.10-109.module+el8.6.0+15475+c55337b4.s390x.rpm
rubygem-bigdecimal-1.4.1-109.module+el8.6.0+15475+c55337b4.s390x.rpm
rubygem-bigdecimal-debuginfo-1.4.1-109.module+el8.6.0+15475+c55337b4.s390x.rpm
rubygem-bson-4.5.0-1.module+el8.1.0+3653+beb38eb0.s390x.rpm
rubygem-bson-debuginfo-4.5.0-1.module+el8.1.0+3653+beb38eb0.s390x.rpm
rubygem-bson-debugsource-4.5.0-1.module+el8.1.0+3653+beb38eb0.s390x.rpm
rubygem-io-console-0.4.7-109.module+el8.6.0+15475+c55337b4.s390x.rpm
rubygem-io-console-debuginfo-0.4.7-109.module+el8.6.0+15475+c55337b4.s390x.rpm
rubygem-json-2.1.0-109.module+el8.6.0+15475+c55337b4.s390x.rpm
rubygem-json-debuginfo-2.1.0-109.module+el8.6.0+15475+c55337b4.s390x.rpm
rubygem-mysql2-0.5.2-1.module+el8.1.0+3653+beb38eb0.s390x.rpm
rubygem-mysql2-debuginfo-0.5.2-1.module+el8.1.0+3653+beb38eb0.s390x.rpm
rubygem-mysql2-debugsource-0.5.2-1.module+el8.1.0+3653+beb38eb0.s390x.rpm
rubygem-openssl-2.1.2-109.module+el8.6.0+15475+c55337b4.s390x.rpm
rubygem-openssl-debuginfo-2.1.2-109.module+el8.6.0+15475+c55337b4.s390x.rpm
rubygem-pg-1.1.4-1.module+el8.1.0+3653+beb38eb0.s390x.rpm
rubygem-pg-debuginfo-1.1.4-1.module+el8.1.0+3653+beb38eb0.s390x.rpm
rubygem-pg-debugsource-1.1.4-1.module+el8.1.0+3653+beb38eb0.s390x.rpm
rubygem-psych-3.1.0-109.module+el8.6.0+15475+c55337b4.s390x.rpm
rubygem-psych-debuginfo-3.1.0-109.module+el8.6.0+15475+c55337b4.s390x.rpm

x86_64:
ruby-2.6.10-109.module+el8.6.0+15475+c55337b4.i686.rpm
ruby-2.6.10-109.module+el8.6.0+15475+c55337b4.x86_64.rpm
ruby-debuginfo-2.6.10-109.module+el8.6.0+15475+c55337b4.i686.rpm
ruby-debuginfo-2.6.10-109.module+el8.6.0+15475+c55337b4.x86_64.rpm
ruby-debugsource-2.6.10-109.module+el8.6.0+15475+c55337b4.i686.rpm
ruby-debugsource-2.6.10-109.module+el8.6.0+15475+c55337b4.x86_64.rpm
ruby-devel-2.6.10-109.module+el8.6.0+15475+c55337b4.i686.rpm
ruby-devel-2.6.10-109.module+el8.6.0+15475+c55337b4.x86_64.rpm
ruby-libs-2.6.10-109.module+el8.6.0+15475+c55337b4.i686.rpm
ruby-libs-2.6.10-109.module+el8.6.0+15475+c55337b4.x86_64.rpm
ruby-libs-debuginfo-2.6.10-109.module+el8.6.0+15475+c55337b4.i686.rpm
ruby-libs-debuginfo-2.6.10-109.module+el8.6.0+15475+c55337b4.x86_64.rpm
rubygem-bigdecimal-1.4.1-109.module+el8.6.0+15475+c55337b4.i686.rpm
rubygem-bigdecimal-1.4.1-109.module+el8.6.0+15475+c55337b4.x86_64.rpm
rubygem-bigdecimal-debuginfo-1.4.1-109.module+el8.6.0+15475+c55337b4.i686.rpm
rubygem-bigdecimal-debuginfo-1.4.1-109.module+el8.6.0+15475+c55337b4.x86_64.rpm
rubygem-bson-4.5.0-1.module+el8.1.0+3653+beb38eb0.x86_64.rpm
rubygem-bson-debuginfo-4.5.0-1.module+el8.1.0+3653+beb38eb0.x86_64.rpm
rubygem-bson-debugsource-4.5.0-1.module+el8.1.0+3653+beb38eb0.x86_64.rpm
rubygem-io-console-0.4.7-109.module+el8.6.0+15475+c55337b4.i686.rpm
rubygem-io-console-0.4.7-109.module+el8.6.0+15475+c55337b4.x86_64.rpm
rubygem-io-console-debuginfo-0.4.7-109.module+el8.6.0+15475+c55337b4.i686.rpm
rubygem-io-console-debuginfo-0.4.7-109.module+el8.6.0+15475+c55337b4.x86_64.rpm
rubygem-json-2.1.0-109.module+el8.6.0+15475+c55337b4.i686.rpm
rubygem-json-2.1.0-109.module+el8.6.0+15475+c55337b4.x86_64.rpm
rubygem-json-debuginfo-2.1.0-109.module+el8.6.0+15475+c55337b4.i686.rpm
rubygem-json-debuginfo-2.1.0-109.module+el8.6.0+15475+c55337b4.x86_64.rpm
rubygem-mysql2-0.5.2-1.module+el8.1.0+3653+beb38eb0.x86_64.rpm
rubygem-mysql2-debuginfo-0.5.2-1.module+el8.1.0+3653+beb38eb0.x86_64.rpm
rubygem-mysql2-debugsource-0.5.2-1.module+el8.1.0+3653+beb38eb0.x86_64.rpm
rubygem-openssl-2.1.2-109.module+el8.6.0+15475+c55337b4.i686.rpm
rubygem-openssl-2.1.2-109.module+el8.6.0+15475+c55337b4.x86_64.rpm
rubygem-openssl-debuginfo-2.1.2-109.module+el8.6.0+15475+c55337b4.i686.rpm
rubygem-openssl-debuginfo-2.1.2-109.module+el8.6.0+15475+c55337b4.x86_64.rpm
rubygem-pg-1.1.4-1.module+el8.1.0+3653+beb38eb0.x86_64.rpm
rubygem-pg-debuginfo-1.1.4-1.module+el8.1.0+3653+beb38eb0.x86_64.rpm
rubygem-pg-debugsource-1.1.4-1.module+el8.1.0+3653+beb38eb0.x86_64.rpm
rubygem-psych-3.1.0-109.module+el8.6.0+15475+c55337b4.i686.rpm
rubygem-psych-3.1.0-109.module+el8.6.0+15475+c55337b4.x86_64.rpm
rubygem-psych-debuginfo-3.1.0-109.module+el8.6.0+15475+c55337b4.i686.rpm
rubygem-psych-debuginfo-3.1.0-109.module+el8.6.0+15475+c55337b4.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2022-28739
https://access.redhat.com/security/updates/classification/#moderate

8. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2022 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIVAwUBYr5BdtzjgjWX9erEAQjJNg//aMV8gwcjxgJsrKs17hpExxVLB7OuKWo/
uquO6Ejnmd3MWlJmBSqzQ45OLTwKWatqldQDmNsKJjZkEqF12UijPuAWrjW8Y2tn
syEdYispTdnVSf40hSNaNY5vOEcKILZM8LnEIO5krFtx1jvqzJpYrkUOYWdxSuws
Ey4as204xnqwOml0yzysLHokvdG56KgADogfVBZqE1L22xMz/O5n2MJZCn/+N34C
VjtQjIp1i/PK+NiJcx3p2tZgkDSF/YV1iXwXq05rvIpWeKLXW0C07GafjHmaRa+V
7NR4kRH3ZqHAOSVle9dcgER6pvNKOHjY/0NI9+41/KwEzrq+KvSABwJoieduRDrg
wPNP5OP8aASi/5T5ha001mO+viqKU5hYterZ2xbCw5bb11YEkowRW5BjeTC9Jtj3
N0SS1NubY8EZkN02k0/ORpAq8z3VuRrMrQxHmybrBflzndXF97UMSCtlayOKql+A
SEu7GvLE6EJ0yuWetTopWDKuXxLS//pb2N9i57jNhw/YoTEvfbmoF4zihL9BssKk
So398FfwSZqRx3xmsGRLbd2EjwlqD0mE7f2sKN9NXXEherzb3IGxbs0yA6QUWBUq
NaAlNKiDRvr1xNii5fdG9m3pJ/4uR8JxZ9s6hzbWHS25e3BuPJwXw9HWKuCRl6a0
lNjbIQ2UtqQ=
=MUrM
-----END PGP SIGNATURE-----
--
RHSA-announce mailing list
[email protected]
https://listman.redhat.com/mailman/listinfo/rhsa-announce

RedHat: RHSA-2022-5338:01 Moderate: ruby:2.6 security, bug fix,

An update for the ruby:2.6 module is now available for Red Hat Enterprise Linux 8

Summary

Ruby is an extensible, interpreted, object-oriented, scripting language. It has features to process text files and to perform system management tasks.
The following packages have been upgraded to a later upstream version: ruby (2.6.10). (BZ#2089374)
Security Fix(es):
* Ruby: Buffer overrun in String-to-Float conversion (CVE-2022-28739)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

Solution

For details on how to apply this update, which includes the changesdescribed in this advisory, refer to:https://access.redhat.com/articles/11258

References

https://access.redhat.com/security/cve/CVE-2022-28739 https://access.redhat.com/security/updates/classification/#moderate

Package List

Red Hat Enterprise Linux AppStream (v. 8):
Source: ruby-2.6.10-109.module+el8.6.0+15475+c55337b4.src.rpm rubygem-abrt-0.3.0-4.module+el8.1.0+3653+beb38eb0.src.rpm rubygem-bson-4.5.0-1.module+el8.1.0+3653+beb38eb0.src.rpm rubygem-mongo-2.8.0-1.module+el8.1.0+3653+beb38eb0.src.rpm rubygem-mysql2-0.5.2-1.module+el8.1.0+3653+beb38eb0.src.rpm rubygem-pg-1.1.4-1.module+el8.1.0+3653+beb38eb0.src.rpm
aarch64: ruby-2.6.10-109.module+el8.6.0+15475+c55337b4.aarch64.rpm ruby-debuginfo-2.6.10-109.module+el8.6.0+15475+c55337b4.aarch64.rpm ruby-debugsource-2.6.10-109.module+el8.6.0+15475+c55337b4.aarch64.rpm ruby-devel-2.6.10-109.module+el8.6.0+15475+c55337b4.aarch64.rpm ruby-libs-2.6.10-109.module+el8.6.0+15475+c55337b4.aarch64.rpm ruby-libs-debuginfo-2.6.10-109.module+el8.6.0+15475+c55337b4.aarch64.rpm rubygem-bigdecimal-1.4.1-109.module+el8.6.0+15475+c55337b4.aarch64.rpm rubygem-bigdecimal-debuginfo-1.4.1-109.module+el8.6.0+15475+c55337b4.aarch64.rpm rubygem-bson-4.5.0-1.module+el8.1.0+3653+beb38eb0.aarch64.rpm rubygem-bson-debuginfo-4.5.0-1.module+el8.1.0+3653+beb38eb0.aarch64.rpm rubygem-bson-debugsource-4.5.0-1.module+el8.1.0+3653+beb38eb0.aarch64.rpm rubygem-io-console-0.4.7-109.module+el8.6.0+15475+c55337b4.aarch64.rpm rubygem-io-console-debuginfo-0.4.7-109.module+el8.6.0+15475+c55337b4.aarch64.rpm rubygem-json-2.1.0-109.module+el8.6.0+15475+c55337b4.aarch64.rpm rubygem-json-debuginfo-2.1.0-109.module+el8.6.0+15475+c55337b4.aarch64.rpm rubygem-mysql2-0.5.2-1.module+el8.1.0+3653+beb38eb0.aarch64.rpm rubygem-mysql2-debuginfo-0.5.2-1.module+el8.1.0+3653+beb38eb0.aarch64.rpm rubygem-mysql2-debugsource-0.5.2-1.module+el8.1.0+3653+beb38eb0.aarch64.rpm rubygem-openssl-2.1.2-109.module+el8.6.0+15475+c55337b4.aarch64.rpm rubygem-openssl-debuginfo-2.1.2-109.module+el8.6.0+15475+c55337b4.aarch64.rpm rubygem-pg-1.1.4-1.module+el8.1.0+3653+beb38eb0.aarch64.rpm rubygem-pg-debuginfo-1.1.4-1.module+el8.1.0+3653+beb38eb0.aarch64.rpm rubygem-pg-debugsource-1.1.4-1.module+el8.1.0+3653+beb38eb0.aarch64.rpm rubygem-psych-3.1.0-109.module+el8.6.0+15475+c55337b4.aarch64.rpm rubygem-psych-debuginfo-3.1.0-109.module+el8.6.0+15475+c55337b4.aarch64.rpm
noarch: ruby-doc-2.6.10-109.module+el8.6.0+15475+c55337b4.noarch.rpm rubygem-abrt-0.3.0-4.module+el8.1.0+3653+beb38eb0.noarch.rpm rubygem-abrt-doc-0.3.0-4.module+el8.1.0+3653+beb38eb0.noarch.rpm rubygem-bson-doc-4.5.0-1.module+el8.1.0+3653+beb38eb0.noarch.rpm rubygem-bundler-1.17.2-109.module+el8.6.0+15475+c55337b4.noarch.rpm rubygem-did_you_mean-1.3.0-109.module+el8.6.0+15475+c55337b4.noarch.rpm rubygem-irb-1.0.0-109.module+el8.6.0+15475+c55337b4.noarch.rpm rubygem-minitest-5.11.3-109.module+el8.6.0+15475+c55337b4.noarch.rpm rubygem-mongo-2.8.0-1.module+el8.1.0+3653+beb38eb0.noarch.rpm rubygem-mongo-doc-2.8.0-1.module+el8.1.0+3653+beb38eb0.noarch.rpm rubygem-mysql2-doc-0.5.2-1.module+el8.1.0+3653+beb38eb0.noarch.rpm rubygem-net-telnet-0.2.0-109.module+el8.6.0+15475+c55337b4.noarch.rpm rubygem-pg-doc-1.1.4-1.module+el8.1.0+3653+beb38eb0.noarch.rpm rubygem-power_assert-1.1.3-109.module+el8.6.0+15475+c55337b4.noarch.rpm rubygem-rake-12.3.3-109.module+el8.6.0+15475+c55337b4.noarch.rpm rubygem-rdoc-6.1.2.1-109.module+el8.6.0+15475+c55337b4.noarch.rpm rubygem-test-unit-3.2.9-109.module+el8.6.0+15475+c55337b4.noarch.rpm rubygem-xmlrpc-0.3.0-109.module+el8.6.0+15475+c55337b4.noarch.rpm rubygems-3.0.3.1-109.module+el8.6.0+15475+c55337b4.noarch.rpm rubygems-devel-3.0.3.1-109.module+el8.6.0+15475+c55337b4.noarch.rpm
ppc64le: ruby-2.6.10-109.module+el8.6.0+15475+c55337b4.ppc64le.rpm ruby-debuginfo-2.6.10-109.module+el8.6.0+15475+c55337b4.ppc64le.rpm ruby-debugsource-2.6.10-109.module+el8.6.0+15475+c55337b4.ppc64le.rpm ruby-devel-2.6.10-109.module+el8.6.0+15475+c55337b4.ppc64le.rpm ruby-libs-2.6.10-109.module+el8.6.0+15475+c55337b4.ppc64le.rpm ruby-libs-debuginfo-2.6.10-109.module+el8.6.0+15475+c55337b4.ppc64le.rpm rubygem-bigdecimal-1.4.1-109.module+el8.6.0+15475+c55337b4.ppc64le.rpm rubygem-bigdecimal-debuginfo-1.4.1-109.module+el8.6.0+15475+c55337b4.ppc64le.rpm rubygem-bson-4.5.0-1.module+el8.1.0+3653+beb38eb0.ppc64le.rpm rubygem-bson-debuginfo-4.5.0-1.module+el8.1.0+3653+beb38eb0.ppc64le.rpm rubygem-bson-debugsource-4.5.0-1.module+el8.1.0+3653+beb38eb0.ppc64le.rpm rubygem-io-console-0.4.7-109.module+el8.6.0+15475+c55337b4.ppc64le.rpm rubygem-io-console-debuginfo-0.4.7-109.module+el8.6.0+15475+c55337b4.ppc64le.rpm rubygem-json-2.1.0-109.module+el8.6.0+15475+c55337b4.ppc64le.rpm rubygem-json-debuginfo-2.1.0-109.module+el8.6.0+15475+c55337b4.ppc64le.rpm rubygem-mysql2-0.5.2-1.module+el8.1.0+3653+beb38eb0.ppc64le.rpm rubygem-mysql2-debuginfo-0.5.2-1.module+el8.1.0+3653+beb38eb0.ppc64le.rpm rubygem-mysql2-debugsource-0.5.2-1.module+el8.1.0+3653+beb38eb0.ppc64le.rpm rubygem-openssl-2.1.2-109.module+el8.6.0+15475+c55337b4.ppc64le.rpm rubygem-openssl-debuginfo-2.1.2-109.module+el8.6.0+15475+c55337b4.ppc64le.rpm rubygem-pg-1.1.4-1.module+el8.1.0+3653+beb38eb0.ppc64le.rpm rubygem-pg-debuginfo-1.1.4-1.module+el8.1.0+3653+beb38eb0.ppc64le.rpm rubygem-pg-debugsource-1.1.4-1.module+el8.1.0+3653+beb38eb0.ppc64le.rpm rubygem-psych-3.1.0-109.module+el8.6.0+15475+c55337b4.ppc64le.rpm rubygem-psych-debuginfo-3.1.0-109.module+el8.6.0+15475+c55337b4.ppc64le.rpm
s390x: ruby-2.6.10-109.module+el8.6.0+15475+c55337b4.s390x.rpm ruby-debuginfo-2.6.10-109.module+el8.6.0+15475+c55337b4.s390x.rpm ruby-debugsource-2.6.10-109.module+el8.6.0+15475+c55337b4.s390x.rpm ruby-devel-2.6.10-109.module+el8.6.0+15475+c55337b4.s390x.rpm ruby-libs-2.6.10-109.module+el8.6.0+15475+c55337b4.s390x.rpm ruby-libs-debuginfo-2.6.10-109.module+el8.6.0+15475+c55337b4.s390x.rpm rubygem-bigdecimal-1.4.1-109.module+el8.6.0+15475+c55337b4.s390x.rpm rubygem-bigdecimal-debuginfo-1.4.1-109.module+el8.6.0+15475+c55337b4.s390x.rpm rubygem-bson-4.5.0-1.module+el8.1.0+3653+beb38eb0.s390x.rpm rubygem-bson-debuginfo-4.5.0-1.module+el8.1.0+3653+beb38eb0.s390x.rpm rubygem-bson-debugsource-4.5.0-1.module+el8.1.0+3653+beb38eb0.s390x.rpm rubygem-io-console-0.4.7-109.module+el8.6.0+15475+c55337b4.s390x.rpm rubygem-io-console-debuginfo-0.4.7-109.module+el8.6.0+15475+c55337b4.s390x.rpm rubygem-json-2.1.0-109.module+el8.6.0+15475+c55337b4.s390x.rpm rubygem-json-debuginfo-2.1.0-109.module+el8.6.0+15475+c55337b4.s390x.rpm rubygem-mysql2-0.5.2-1.module+el8.1.0+3653+beb38eb0.s390x.rpm rubygem-mysql2-debuginfo-0.5.2-1.module+el8.1.0+3653+beb38eb0.s390x.rpm rubygem-mysql2-debugsource-0.5.2-1.module+el8.1.0+3653+beb38eb0.s390x.rpm rubygem-openssl-2.1.2-109.module+el8.6.0+15475+c55337b4.s390x.rpm rubygem-openssl-debuginfo-2.1.2-109.module+el8.6.0+15475+c55337b4.s390x.rpm rubygem-pg-1.1.4-1.module+el8.1.0+3653+beb38eb0.s390x.rpm rubygem-pg-debuginfo-1.1.4-1.module+el8.1.0+3653+beb38eb0.s390x.rpm rubygem-pg-debugsource-1.1.4-1.module+el8.1.0+3653+beb38eb0.s390x.rpm rubygem-psych-3.1.0-109.module+el8.6.0+15475+c55337b4.s390x.rpm rubygem-psych-debuginfo-3.1.0-109.module+el8.6.0+15475+c55337b4.s390x.rpm
x86_64: ruby-2.6.10-109.module+el8.6.0+15475+c55337b4.i686.rpm ruby-2.6.10-109.module+el8.6.0+15475+c55337b4.x86_64.rpm ruby-debuginfo-2.6.10-109.module+el8.6.0+15475+c55337b4.i686.rpm ruby-debuginfo-2.6.10-109.module+el8.6.0+15475+c55337b4.x86_64.rpm ruby-debugsource-2.6.10-109.module+el8.6.0+15475+c55337b4.i686.rpm ruby-debugsource-2.6.10-109.module+el8.6.0+15475+c55337b4.x86_64.rpm ruby-devel-2.6.10-109.module+el8.6.0+15475+c55337b4.i686.rpm ruby-devel-2.6.10-109.module+el8.6.0+15475+c55337b4.x86_64.rpm ruby-libs-2.6.10-109.module+el8.6.0+15475+c55337b4.i686.rpm ruby-libs-2.6.10-109.module+el8.6.0+15475+c55337b4.x86_64.rpm ruby-libs-debuginfo-2.6.10-109.module+el8.6.0+15475+c55337b4.i686.rpm ruby-libs-debuginfo-2.6.10-109.module+el8.6.0+15475+c55337b4.x86_64.rpm rubygem-bigdecimal-1.4.1-109.module+el8.6.0+15475+c55337b4.i686.rpm rubygem-bigdecimal-1.4.1-109.module+el8.6.0+15475+c55337b4.x86_64.rpm rubygem-bigdecimal-debuginfo-1.4.1-109.module+el8.6.0+15475+c55337b4.i686.rpm rubygem-bigdecimal-debuginfo-1.4.1-109.module+el8.6.0+15475+c55337b4.x86_64.rpm rubygem-bson-4.5.0-1.module+el8.1.0+3653+beb38eb0.x86_64.rpm rubygem-bson-debuginfo-4.5.0-1.module+el8.1.0+3653+beb38eb0.x86_64.rpm rubygem-bson-debugsource-4.5.0-1.module+el8.1.0+3653+beb38eb0.x86_64.rpm rubygem-io-console-0.4.7-109.module+el8.6.0+15475+c55337b4.i686.rpm rubygem-io-console-0.4.7-109.module+el8.6.0+15475+c55337b4.x86_64.rpm rubygem-io-console-debuginfo-0.4.7-109.module+el8.6.0+15475+c55337b4.i686.rpm rubygem-io-console-debuginfo-0.4.7-109.module+el8.6.0+15475+c55337b4.x86_64.rpm rubygem-json-2.1.0-109.module+el8.6.0+15475+c55337b4.i686.rpm rubygem-json-2.1.0-109.module+el8.6.0+15475+c55337b4.x86_64.rpm rubygem-json-debuginfo-2.1.0-109.module+el8.6.0+15475+c55337b4.i686.rpm rubygem-json-debuginfo-2.1.0-109.module+el8.6.0+15475+c55337b4.x86_64.rpm rubygem-mysql2-0.5.2-1.module+el8.1.0+3653+beb38eb0.x86_64.rpm rubygem-mysql2-debuginfo-0.5.2-1.module+el8.1.0+3653+beb38eb0.x86_64.rpm rubygem-mysql2-debugsource-0.5.2-1.module+el8.1.0+3653+beb38eb0.x86_64.rpm rubygem-openssl-2.1.2-109.module+el8.6.0+15475+c55337b4.i686.rpm rubygem-openssl-2.1.2-109.module+el8.6.0+15475+c55337b4.x86_64.rpm rubygem-openssl-debuginfo-2.1.2-109.module+el8.6.0+15475+c55337b4.i686.rpm rubygem-openssl-debuginfo-2.1.2-109.module+el8.6.0+15475+c55337b4.x86_64.rpm rubygem-pg-1.1.4-1.module+el8.1.0+3653+beb38eb0.x86_64.rpm rubygem-pg-debuginfo-1.1.4-1.module+el8.1.0+3653+beb38eb0.x86_64.rpm rubygem-pg-debugsource-1.1.4-1.module+el8.1.0+3653+beb38eb0.x86_64.rpm rubygem-psych-3.1.0-109.module+el8.6.0+15475+c55337b4.i686.rpm rubygem-psych-3.1.0-109.module+el8.6.0+15475+c55337b4.x86_64.rpm rubygem-psych-debuginfo-3.1.0-109.module+el8.6.0+15475+c55337b4.i686.rpm rubygem-psych-debuginfo-3.1.0-109.module+el8.6.0+15475+c55337b4.x86_64.rpm
These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from https://access.redhat.com/security/team/key/

Severity
Advisory ID: RHSA-2022:5338-01
Product: Red Hat Enterprise Linux
Advisory URL: https://access.redhat.com/errata/RHSA-2022:5338
Issued Date: : 2022-06-28
CVE Names: CVE-2022-28739

Topic

An update for the ruby:2.6 module is now available for Red Hat EnterpriseLinux 8.Red Hat Product Security has rated this update as having a security impactof Moderate. A Common Vulnerability Scoring System (CVSS) base score, whichgives a detailed severity rating, is available for each vulnerability fromthe CVE link(s) in the References section.

Relevant Releases Architectures

Red Hat Enterprise Linux AppStream (v. 8) - aarch64, noarch, ppc64le, s390x, x86_64

Bugs Fixed

2075687 - CVE-2022-28739 Ruby: Buffer overrun in String-to-Float conversion

2089374 - ruby:2.6/ruby: Rebase to the latest Ruby 2.6 point release [rhel-8] [rhel-8.6.0.z]

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.