RedHat: RHSA-2022-5806:01 Important: kernel security update | Linux...

Advisories

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Important: kernel security update
Advisory ID:       RHSA-2022:5806-01
Product:           Red Hat Enterprise Linux
Advisory URL:      https://access.redhat.com/errata/RHSA-2022:5806
Issue date:        2022-08-02
CVE Names:         CVE-2022-1729 CVE-2022-32250 
=====================================================================

1. Summary:

An update for kernel is now available for Red Hat Enterprise Linux 7.3
Advanced Update Support.

Red Hat Product Security has rated this update as having a security impact
of Important. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available for each vulnerability
from the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux Server AUS (v. 7.3) - noarch, x86_64
Red Hat Enterprise Linux Server Optional AUS (v. 7.3) - x86_64

3. Description:

The kernel packages contain the Linux kernel, the core of any Linux
operating system.

Security Fix(es):

* kernel: race condition in perf_event_open leads to privilege escalation
(CVE-2022-1729)

* kernel: a use-after-free write in the netfilter subsystem can lead to
privilege escalation to root (CVE-2022-32250)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

The system must be rebooted for this update to take effect.

5. Bugs fixed (https://bugzilla.redhat.com/):

2086753 - CVE-2022-1729 kernel: race condition in perf_event_open leads to privilege escalation
2092427 - CVE-2022-32250 kernel: a use-after-free write in the netfilter subsystem can lead to privilege escalation to root

6. Package List:

Red Hat Enterprise Linux Server AUS (v. 7.3):

Source:
kernel-3.10.0-514.104.1.el7.src.rpm

noarch:
kernel-abi-whitelists-3.10.0-514.104.1.el7.noarch.rpm
kernel-doc-3.10.0-514.104.1.el7.noarch.rpm

x86_64:
kernel-3.10.0-514.104.1.el7.x86_64.rpm
kernel-debug-3.10.0-514.104.1.el7.x86_64.rpm
kernel-debug-debuginfo-3.10.0-514.104.1.el7.x86_64.rpm
kernel-debug-devel-3.10.0-514.104.1.el7.x86_64.rpm
kernel-debuginfo-3.10.0-514.104.1.el7.x86_64.rpm
kernel-debuginfo-common-x86_64-3.10.0-514.104.1.el7.x86_64.rpm
kernel-devel-3.10.0-514.104.1.el7.x86_64.rpm
kernel-headers-3.10.0-514.104.1.el7.x86_64.rpm
kernel-tools-3.10.0-514.104.1.el7.x86_64.rpm
kernel-tools-debuginfo-3.10.0-514.104.1.el7.x86_64.rpm
kernel-tools-libs-3.10.0-514.104.1.el7.x86_64.rpm
perf-3.10.0-514.104.1.el7.x86_64.rpm
perf-debuginfo-3.10.0-514.104.1.el7.x86_64.rpm
python-perf-3.10.0-514.104.1.el7.x86_64.rpm
python-perf-debuginfo-3.10.0-514.104.1.el7.x86_64.rpm

Red Hat Enterprise Linux Server Optional AUS (v. 7.3):

x86_64:
kernel-debug-debuginfo-3.10.0-514.104.1.el7.x86_64.rpm
kernel-debuginfo-3.10.0-514.104.1.el7.x86_64.rpm
kernel-debuginfo-common-x86_64-3.10.0-514.104.1.el7.x86_64.rpm
kernel-tools-debuginfo-3.10.0-514.104.1.el7.x86_64.rpm
kernel-tools-libs-devel-3.10.0-514.104.1.el7.x86_64.rpm
perf-debuginfo-3.10.0-514.104.1.el7.x86_64.rpm
python-perf-debuginfo-3.10.0-514.104.1.el7.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2022-1729
https://access.redhat.com/security/cve/CVE-2022-32250
https://access.redhat.com/security/updates/classification/#important

8. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2022 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIVAwUBYuqtP9zjgjWX9erEAQgzvA/9HXmULo15WD62TmsnR2NgTXqiuuWW0bBT
cnxiZHO6iognwZb5Q3Oj+M+HmzLcSTlxlGRpOA68NzDOsue6WewrGDg6JJSdyNal
iLVKyLmay2FA/MMJ/RStQMHUwUdWPAX2UG0oB9tq869O7H3l/CwcJt1D0u2JkfJ0
YP8V85E7nKDVUjQfUbkB0KNd49aNiApY5P/m2R6Zm2F/6snLA1cemVfZ2YTAm4KF
9lDFyCy6WFe8iiMadX1te76e/elw2rGRgm58HH9gc6VLTIc/qokSdauZ3eo4/j9w
uJRjDnsYyeC7YOW3+CEwZjx1PEzoHE+r6Jvnfel+pchQgDAK7p64yVyh1Qvz+AsV
SioCtcotMYkuEgpp0JX8M96rWcF/5GxnBHRhHvweFBOJ5f9GbmuVPtje2A05nSeZ
dWmsV1LM5rnHJ1Zw449bBViWyV3Jaivn+7v8GEuOQYPNgJCMT5edVk+J4JPSlL4x
tFafcRlmH59JS0XuebdN7Nrith+tMxUUrZOqVffL0HZ6FWmIitQuV7la5ZAkFmfB
2THR6Lw4H2GtCKhB6WZirv9JaO+SRYFtcy1Pxe+az5o2il30ltg7I/RhpN/JDwrf
FrypuykqjN+0eLXo4F+FdEP+q4WRRQ7RgAh0uhLPz1Itb+xBMLmnPzSCXOQr1pPC
tK5qHYRiAEo=
=SnUb
-----END PGP SIGNATURE-----
--
RHSA-announce mailing list
[email protected]
https://listman.redhat.com/mailman/listinfo/rhsa-announce

RedHat: RHSA-2022-5806:01 Important: kernel security update

An update for kernel is now available for Red Hat Enterprise Linux 7.3 Advanced Update Support

Summary

The kernel packages contain the Linux kernel, the core of any Linux operating system.
Security Fix(es):
* kernel: race condition in perf_event_open leads to privilege escalation (CVE-2022-1729)
* kernel: a use-after-free write in the netfilter subsystem can lead to privilege escalation to root (CVE-2022-32250)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

Solution

For details on how to apply this update, which includes the changesdescribed in this advisory, refer to:https://access.redhat.com/articles/11258The system must be rebooted for this update to take effect.

References

https://access.redhat.com/security/cve/CVE-2022-1729 https://access.redhat.com/security/cve/CVE-2022-32250 https://access.redhat.com/security/updates/classification/#important

Package List

Red Hat Enterprise Linux Server AUS (v. 7.3):
Source: kernel-3.10.0-514.104.1.el7.src.rpm
noarch: kernel-abi-whitelists-3.10.0-514.104.1.el7.noarch.rpm kernel-doc-3.10.0-514.104.1.el7.noarch.rpm
x86_64: kernel-3.10.0-514.104.1.el7.x86_64.rpm kernel-debug-3.10.0-514.104.1.el7.x86_64.rpm kernel-debug-debuginfo-3.10.0-514.104.1.el7.x86_64.rpm kernel-debug-devel-3.10.0-514.104.1.el7.x86_64.rpm kernel-debuginfo-3.10.0-514.104.1.el7.x86_64.rpm kernel-debuginfo-common-x86_64-3.10.0-514.104.1.el7.x86_64.rpm kernel-devel-3.10.0-514.104.1.el7.x86_64.rpm kernel-headers-3.10.0-514.104.1.el7.x86_64.rpm kernel-tools-3.10.0-514.104.1.el7.x86_64.rpm kernel-tools-debuginfo-3.10.0-514.104.1.el7.x86_64.rpm kernel-tools-libs-3.10.0-514.104.1.el7.x86_64.rpm perf-3.10.0-514.104.1.el7.x86_64.rpm perf-debuginfo-3.10.0-514.104.1.el7.x86_64.rpm python-perf-3.10.0-514.104.1.el7.x86_64.rpm python-perf-debuginfo-3.10.0-514.104.1.el7.x86_64.rpm
Red Hat Enterprise Linux Server Optional AUS (v. 7.3):
x86_64: kernel-debug-debuginfo-3.10.0-514.104.1.el7.x86_64.rpm kernel-debuginfo-3.10.0-514.104.1.el7.x86_64.rpm kernel-debuginfo-common-x86_64-3.10.0-514.104.1.el7.x86_64.rpm kernel-tools-debuginfo-3.10.0-514.104.1.el7.x86_64.rpm kernel-tools-libs-devel-3.10.0-514.104.1.el7.x86_64.rpm perf-debuginfo-3.10.0-514.104.1.el7.x86_64.rpm python-perf-debuginfo-3.10.0-514.104.1.el7.x86_64.rpm
These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from https://access.redhat.com/security/team/key/

Severity
Advisory ID: RHSA-2022:5806-01
Product: Red Hat Enterprise Linux
Advisory URL: https://access.redhat.com/errata/RHSA-2022:5806
Issued Date: : 2022-08-02
CVE Names: CVE-2022-1729 CVE-2022-32250

Topic

An update for kernel is now available for Red Hat Enterprise Linux 7.3Advanced Update Support.Red Hat Product Security has rated this update as having a security impactof Important. A Common Vulnerability Scoring System (CVSS) base score,which gives a detailed severity rating, is available for each vulnerabilityfrom the CVE link(s) in the References section.

Relevant Releases Architectures

Red Hat Enterprise Linux Server AUS (v. 7.3) - noarch, x86_64

Red Hat Enterprise Linux Server Optional AUS (v. 7.3) - x86_64

Bugs Fixed

2086753 - CVE-2022-1729 kernel: race condition in perf_event_open leads to privilege escalation

2092427 - CVE-2022-32250 kernel: a use-after-free write in the netfilter subsystem can lead to privilege escalation to root

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.