RedHat: RHSA-2022-8639:01 Important: krb5 security update | LinuxSe...
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Important: krb5 security update
Advisory ID:       RHSA-2022:8639-01
Product:           Red Hat Enterprise Linux
Advisory URL:      https://access.redhat.com/errata/RHSA-2022:8639
Issue date:        2022-11-28
CVE Names:         CVE-2022-42898 
=====================================================================

1. Summary:

An update for krb5 is now available for Red Hat Enterprise Linux 8.4
Extended Update Support.

Red Hat Product Security has rated this update as having a security impact
of Important. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available for each vulnerability
from the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux BaseOS EUS (v.8.4) - aarch64, ppc64le, s390x, x86_64

3. Description:

Kerberos is a network authentication system, which can improve the security
of your network by eliminating the insecure practice of sending passwords
over the network in unencrypted form. It allows clients and servers to
authenticate to each other with the help of a trusted third party, the
Kerberos key distribution center (KDC).

Security Fix(es):

* krb5: integer overflow vulnerabilities in PAC parsing (CVE-2022-42898)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

After installing the updated packages, running Kerberos services (krb5kdc,
kadmin, and kprop) will be restarted automatically.

5. Bugs fixed (https://bugzilla.redhat.com/):

2140960 - CVE-2022-42898 krb5: integer overflow vulnerabilities in PAC parsing

6. Package List:

Red Hat Enterprise Linux BaseOS EUS (v.8.4):

Source:
krb5-1.18.2-9.el8_4.src.rpm

aarch64:
krb5-debuginfo-1.18.2-9.el8_4.aarch64.rpm
krb5-debugsource-1.18.2-9.el8_4.aarch64.rpm
krb5-devel-1.18.2-9.el8_4.aarch64.rpm
krb5-devel-debuginfo-1.18.2-9.el8_4.aarch64.rpm
krb5-libs-1.18.2-9.el8_4.aarch64.rpm
krb5-libs-debuginfo-1.18.2-9.el8_4.aarch64.rpm
krb5-pkinit-1.18.2-9.el8_4.aarch64.rpm
krb5-pkinit-debuginfo-1.18.2-9.el8_4.aarch64.rpm
krb5-server-1.18.2-9.el8_4.aarch64.rpm
krb5-server-debuginfo-1.18.2-9.el8_4.aarch64.rpm
krb5-server-ldap-1.18.2-9.el8_4.aarch64.rpm
krb5-server-ldap-debuginfo-1.18.2-9.el8_4.aarch64.rpm
krb5-workstation-1.18.2-9.el8_4.aarch64.rpm
krb5-workstation-debuginfo-1.18.2-9.el8_4.aarch64.rpm
libkadm5-1.18.2-9.el8_4.aarch64.rpm
libkadm5-debuginfo-1.18.2-9.el8_4.aarch64.rpm

ppc64le:
krb5-debuginfo-1.18.2-9.el8_4.ppc64le.rpm
krb5-debugsource-1.18.2-9.el8_4.ppc64le.rpm
krb5-devel-1.18.2-9.el8_4.ppc64le.rpm
krb5-devel-debuginfo-1.18.2-9.el8_4.ppc64le.rpm
krb5-libs-1.18.2-9.el8_4.ppc64le.rpm
krb5-libs-debuginfo-1.18.2-9.el8_4.ppc64le.rpm
krb5-pkinit-1.18.2-9.el8_4.ppc64le.rpm
krb5-pkinit-debuginfo-1.18.2-9.el8_4.ppc64le.rpm
krb5-server-1.18.2-9.el8_4.ppc64le.rpm
krb5-server-debuginfo-1.18.2-9.el8_4.ppc64le.rpm
krb5-server-ldap-1.18.2-9.el8_4.ppc64le.rpm
krb5-server-ldap-debuginfo-1.18.2-9.el8_4.ppc64le.rpm
krb5-workstation-1.18.2-9.el8_4.ppc64le.rpm
krb5-workstation-debuginfo-1.18.2-9.el8_4.ppc64le.rpm
libkadm5-1.18.2-9.el8_4.ppc64le.rpm
libkadm5-debuginfo-1.18.2-9.el8_4.ppc64le.rpm

s390x:
krb5-debuginfo-1.18.2-9.el8_4.s390x.rpm
krb5-debugsource-1.18.2-9.el8_4.s390x.rpm
krb5-devel-1.18.2-9.el8_4.s390x.rpm
krb5-devel-debuginfo-1.18.2-9.el8_4.s390x.rpm
krb5-libs-1.18.2-9.el8_4.s390x.rpm
krb5-libs-debuginfo-1.18.2-9.el8_4.s390x.rpm
krb5-pkinit-1.18.2-9.el8_4.s390x.rpm
krb5-pkinit-debuginfo-1.18.2-9.el8_4.s390x.rpm
krb5-server-1.18.2-9.el8_4.s390x.rpm
krb5-server-debuginfo-1.18.2-9.el8_4.s390x.rpm
krb5-server-ldap-1.18.2-9.el8_4.s390x.rpm
krb5-server-ldap-debuginfo-1.18.2-9.el8_4.s390x.rpm
krb5-workstation-1.18.2-9.el8_4.s390x.rpm
krb5-workstation-debuginfo-1.18.2-9.el8_4.s390x.rpm
libkadm5-1.18.2-9.el8_4.s390x.rpm
libkadm5-debuginfo-1.18.2-9.el8_4.s390x.rpm

x86_64:
krb5-debuginfo-1.18.2-9.el8_4.i686.rpm
krb5-debuginfo-1.18.2-9.el8_4.x86_64.rpm
krb5-debugsource-1.18.2-9.el8_4.i686.rpm
krb5-debugsource-1.18.2-9.el8_4.x86_64.rpm
krb5-devel-1.18.2-9.el8_4.i686.rpm
krb5-devel-1.18.2-9.el8_4.x86_64.rpm
krb5-devel-debuginfo-1.18.2-9.el8_4.i686.rpm
krb5-devel-debuginfo-1.18.2-9.el8_4.x86_64.rpm
krb5-libs-1.18.2-9.el8_4.i686.rpm
krb5-libs-1.18.2-9.el8_4.x86_64.rpm
krb5-libs-debuginfo-1.18.2-9.el8_4.i686.rpm
krb5-libs-debuginfo-1.18.2-9.el8_4.x86_64.rpm
krb5-pkinit-1.18.2-9.el8_4.i686.rpm
krb5-pkinit-1.18.2-9.el8_4.x86_64.rpm
krb5-pkinit-debuginfo-1.18.2-9.el8_4.i686.rpm
krb5-pkinit-debuginfo-1.18.2-9.el8_4.x86_64.rpm
krb5-server-1.18.2-9.el8_4.i686.rpm
krb5-server-1.18.2-9.el8_4.x86_64.rpm
krb5-server-debuginfo-1.18.2-9.el8_4.i686.rpm
krb5-server-debuginfo-1.18.2-9.el8_4.x86_64.rpm
krb5-server-ldap-1.18.2-9.el8_4.i686.rpm
krb5-server-ldap-1.18.2-9.el8_4.x86_64.rpm
krb5-server-ldap-debuginfo-1.18.2-9.el8_4.i686.rpm
krb5-server-ldap-debuginfo-1.18.2-9.el8_4.x86_64.rpm
krb5-workstation-1.18.2-9.el8_4.x86_64.rpm
krb5-workstation-debuginfo-1.18.2-9.el8_4.i686.rpm
krb5-workstation-debuginfo-1.18.2-9.el8_4.x86_64.rpm
libkadm5-1.18.2-9.el8_4.i686.rpm
libkadm5-1.18.2-9.el8_4.x86_64.rpm
libkadm5-debuginfo-1.18.2-9.el8_4.i686.rpm
libkadm5-debuginfo-1.18.2-9.el8_4.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2022-42898
https://access.redhat.com/security/updates/classification/#important

8. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2022 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIVAwUBY4Sv49zjgjWX9erEAQh3SxAAlHs8v0C9eICUBCsbk8FUMOwLA8ucF3+0
ZsxR7sOmbAkP+yn/wscpy2r7Y1UrvAgD8wNmthhXYT3P9ECwKn6jzo0rOOYK/hCt
KNvTJ0/J4T4OY+P2p8iq0FFnoreyY4/YDrl/xdQitlS/kchg7NBop1ci7bGXQIZQ
ZhVujO2BZ0DC4x3h7VPAdZRuMPbeApxHAh7WAEmh9UGDybxZNl7h2PkILyw2Gbxk
KVjykj8UhM5ABJAQ8zHoug54c3FIIbIOGhLWTw+jig89NtHPber5A2MsuzAOfsvX
5INthSiy1kCPUIAiu9cNeK1Lvq6lRBWT/lGirWeSo3MIByIeKGsFbDOXtJ/SxDRV
zpkNDpEfMdFQEM4yj3f1Pu7/Uqm5733K/RVc9Dkjp4+Kfvazgn5RoCfZgjagB8pa
fZcVgQnaaRg3rKxTENDKfHIrtbbtud5wnZPyBuw00Oc9eflsemxgaqEbWUdKorrx
FqjM7wvOzhrpJDd6L65mEWkCqmMGZ/jLd5fkNegaJAxiNjhY6KtjQf6fkAKs3w/m
L6VapI6lJKIJ9MRD0on1WeAFEu72MoD9HorRbZQttJzpejnHawLg4sj7QyAcCD+M
dTSxEXOUICYs5I+YzDW19LoB2l6J+1/BoHHD9XZ0JrbplVQs3muIUurk/Q2nDIET
A71ohPLD1Gw=
=5VSF
-----END PGP SIGNATURE-----
--
RHSA-announce mailing list
[email protected]
https://listman.redhat.com/mailman/listinfo/rhsa-announce

RedHat: RHSA-2022-8639:01 Important: krb5 security update

An update for krb5 is now available for Red Hat Enterprise Linux 8.4 Extended Update Support

Summary

Kerberos is a network authentication system, which can improve the security of your network by eliminating the insecure practice of sending passwords over the network in unencrypted form. It allows clients and servers to authenticate to each other with the help of a trusted third party, the Kerberos key distribution center (KDC).
Security Fix(es):
* krb5: integer overflow vulnerabilities in PAC parsing (CVE-2022-42898)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

Solution

For details on how to apply this update, which includes the changesdescribed in this advisory, refer to:https://access.redhat.com/articles/11258After installing the updated packages, running Kerberos services (krb5kdc,kadmin, and kprop) will be restarted automatically.

References

https://access.redhat.com/security/cve/CVE-2022-42898 https://access.redhat.com/security/updates/classification/#important

Package List

Red Hat Enterprise Linux BaseOS EUS (v.8.4):
Source: krb5-1.18.2-9.el8_4.src.rpm
aarch64: krb5-debuginfo-1.18.2-9.el8_4.aarch64.rpm krb5-debugsource-1.18.2-9.el8_4.aarch64.rpm krb5-devel-1.18.2-9.el8_4.aarch64.rpm krb5-devel-debuginfo-1.18.2-9.el8_4.aarch64.rpm krb5-libs-1.18.2-9.el8_4.aarch64.rpm krb5-libs-debuginfo-1.18.2-9.el8_4.aarch64.rpm krb5-pkinit-1.18.2-9.el8_4.aarch64.rpm krb5-pkinit-debuginfo-1.18.2-9.el8_4.aarch64.rpm krb5-server-1.18.2-9.el8_4.aarch64.rpm krb5-server-debuginfo-1.18.2-9.el8_4.aarch64.rpm krb5-server-ldap-1.18.2-9.el8_4.aarch64.rpm krb5-server-ldap-debuginfo-1.18.2-9.el8_4.aarch64.rpm krb5-workstation-1.18.2-9.el8_4.aarch64.rpm krb5-workstation-debuginfo-1.18.2-9.el8_4.aarch64.rpm libkadm5-1.18.2-9.el8_4.aarch64.rpm libkadm5-debuginfo-1.18.2-9.el8_4.aarch64.rpm
ppc64le: krb5-debuginfo-1.18.2-9.el8_4.ppc64le.rpm krb5-debugsource-1.18.2-9.el8_4.ppc64le.rpm krb5-devel-1.18.2-9.el8_4.ppc64le.rpm krb5-devel-debuginfo-1.18.2-9.el8_4.ppc64le.rpm krb5-libs-1.18.2-9.el8_4.ppc64le.rpm krb5-libs-debuginfo-1.18.2-9.el8_4.ppc64le.rpm krb5-pkinit-1.18.2-9.el8_4.ppc64le.rpm krb5-pkinit-debuginfo-1.18.2-9.el8_4.ppc64le.rpm krb5-server-1.18.2-9.el8_4.ppc64le.rpm krb5-server-debuginfo-1.18.2-9.el8_4.ppc64le.rpm krb5-server-ldap-1.18.2-9.el8_4.ppc64le.rpm krb5-server-ldap-debuginfo-1.18.2-9.el8_4.ppc64le.rpm krb5-workstation-1.18.2-9.el8_4.ppc64le.rpm krb5-workstation-debuginfo-1.18.2-9.el8_4.ppc64le.rpm libkadm5-1.18.2-9.el8_4.ppc64le.rpm libkadm5-debuginfo-1.18.2-9.el8_4.ppc64le.rpm
s390x: krb5-debuginfo-1.18.2-9.el8_4.s390x.rpm krb5-debugsource-1.18.2-9.el8_4.s390x.rpm krb5-devel-1.18.2-9.el8_4.s390x.rpm krb5-devel-debuginfo-1.18.2-9.el8_4.s390x.rpm krb5-libs-1.18.2-9.el8_4.s390x.rpm krb5-libs-debuginfo-1.18.2-9.el8_4.s390x.rpm krb5-pkinit-1.18.2-9.el8_4.s390x.rpm krb5-pkinit-debuginfo-1.18.2-9.el8_4.s390x.rpm krb5-server-1.18.2-9.el8_4.s390x.rpm krb5-server-debuginfo-1.18.2-9.el8_4.s390x.rpm krb5-server-ldap-1.18.2-9.el8_4.s390x.rpm krb5-server-ldap-debuginfo-1.18.2-9.el8_4.s390x.rpm krb5-workstation-1.18.2-9.el8_4.s390x.rpm krb5-workstation-debuginfo-1.18.2-9.el8_4.s390x.rpm libkadm5-1.18.2-9.el8_4.s390x.rpm libkadm5-debuginfo-1.18.2-9.el8_4.s390x.rpm
x86_64: krb5-debuginfo-1.18.2-9.el8_4.i686.rpm krb5-debuginfo-1.18.2-9.el8_4.x86_64.rpm krb5-debugsource-1.18.2-9.el8_4.i686.rpm krb5-debugsource-1.18.2-9.el8_4.x86_64.rpm krb5-devel-1.18.2-9.el8_4.i686.rpm krb5-devel-1.18.2-9.el8_4.x86_64.rpm krb5-devel-debuginfo-1.18.2-9.el8_4.i686.rpm krb5-devel-debuginfo-1.18.2-9.el8_4.x86_64.rpm krb5-libs-1.18.2-9.el8_4.i686.rpm krb5-libs-1.18.2-9.el8_4.x86_64.rpm krb5-libs-debuginfo-1.18.2-9.el8_4.i686.rpm krb5-libs-debuginfo-1.18.2-9.el8_4.x86_64.rpm krb5-pkinit-1.18.2-9.el8_4.i686.rpm krb5-pkinit-1.18.2-9.el8_4.x86_64.rpm krb5-pkinit-debuginfo-1.18.2-9.el8_4.i686.rpm krb5-pkinit-debuginfo-1.18.2-9.el8_4.x86_64.rpm krb5-server-1.18.2-9.el8_4.i686.rpm krb5-server-1.18.2-9.el8_4.x86_64.rpm krb5-server-debuginfo-1.18.2-9.el8_4.i686.rpm krb5-server-debuginfo-1.18.2-9.el8_4.x86_64.rpm krb5-server-ldap-1.18.2-9.el8_4.i686.rpm krb5-server-ldap-1.18.2-9.el8_4.x86_64.rpm krb5-server-ldap-debuginfo-1.18.2-9.el8_4.i686.rpm krb5-server-ldap-debuginfo-1.18.2-9.el8_4.x86_64.rpm krb5-workstation-1.18.2-9.el8_4.x86_64.rpm krb5-workstation-debuginfo-1.18.2-9.el8_4.i686.rpm krb5-workstation-debuginfo-1.18.2-9.el8_4.x86_64.rpm libkadm5-1.18.2-9.el8_4.i686.rpm libkadm5-1.18.2-9.el8_4.x86_64.rpm libkadm5-debuginfo-1.18.2-9.el8_4.i686.rpm libkadm5-debuginfo-1.18.2-9.el8_4.x86_64.rpm
These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from https://access.redhat.com/security/team/key/

Severity
Advisory ID: RHSA-2022:8639-01
Product: Red Hat Enterprise Linux
Advisory URL: https://access.redhat.com/errata/RHSA-2022:8639
Issued Date: : 2022-11-28
CVE Names: CVE-2022-42898

Topic

An update for krb5 is now available for Red Hat Enterprise Linux 8.4Extended Update Support.Red Hat Product Security has rated this update as having a security impactof Important. A Common Vulnerability Scoring System (CVSS) base score,which gives a detailed severity rating, is available for each vulnerabilityfrom the CVE link(s) in the References section.

Relevant Releases Architectures

Red Hat Enterprise Linux BaseOS EUS (v.8.4) - aarch64, ppc64le, s390x, x86_64

Bugs Fixed

2140960 - CVE-2022-42898 krb5: integer overflow vulnerabilities in PAC parsing

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.