-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

====================================================================                   Red Hat Security Advisory

Synopsis:          Important: cups-filters security update
Advisory ID:       RHSA-2023:3429-02
Product:           Red Hat Enterprise Linux
Advisory URL:      https://access.redhat.com/errata/RHSA-2023:3429
Issue date:        2023-06-02
CVE Names:         CVE-2023-24805 
====================================================================
1. Summary:

An update for cups-filters is now available for Red Hat Enterprise Linux
8.1 Update Services for SAP Solutions.

Red Hat Product Security has rated this update as having a security impact
of Important. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available for each vulnerability
from the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux AppStream E4S (v. 8.1) - aarch64, ppc64le, s390x, x86_64

3. Description:

The cups-filters package contains back ends, filters, and other software
that was once part of the core Common UNIX Printing System (CUPS)
distribution but is now maintained independently.

Security Fix(es):

* cups-filters: remote code execution in cups-filters, beh CUPS backend
(CVE-2023-24805)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

5. Bugs fixed (https://bugzilla.redhat.com/):

2203051 - CVE-2023-24805 cups-filters: remote code execution in cups-filters, beh CUPS backend

6. Package List:

Red Hat Enterprise Linux AppStream E4S (v. 8.1):

Source:
cups-filters-1.20.0-18.el8_1.1.src.rpm

aarch64:
cups-filters-1.20.0-18.el8_1.1.aarch64.rpm
cups-filters-debuginfo-1.20.0-18.el8_1.1.aarch64.rpm
cups-filters-debugsource-1.20.0-18.el8_1.1.aarch64.rpm
cups-filters-libs-1.20.0-18.el8_1.1.aarch64.rpm
cups-filters-libs-debuginfo-1.20.0-18.el8_1.1.aarch64.rpm

ppc64le:
cups-filters-1.20.0-18.el8_1.1.ppc64le.rpm
cups-filters-debuginfo-1.20.0-18.el8_1.1.ppc64le.rpm
cups-filters-debugsource-1.20.0-18.el8_1.1.ppc64le.rpm
cups-filters-libs-1.20.0-18.el8_1.1.ppc64le.rpm
cups-filters-libs-debuginfo-1.20.0-18.el8_1.1.ppc64le.rpm

s390x:
cups-filters-1.20.0-18.el8_1.1.s390x.rpm
cups-filters-debuginfo-1.20.0-18.el8_1.1.s390x.rpm
cups-filters-debugsource-1.20.0-18.el8_1.1.s390x.rpm
cups-filters-libs-1.20.0-18.el8_1.1.s390x.rpm
cups-filters-libs-debuginfo-1.20.0-18.el8_1.1.s390x.rpm

x86_64:
cups-filters-1.20.0-18.el8_1.1.x86_64.rpm
cups-filters-debuginfo-1.20.0-18.el8_1.1.i686.rpm
cups-filters-debuginfo-1.20.0-18.el8_1.1.x86_64.rpm
cups-filters-debugsource-1.20.0-18.el8_1.1.i686.rpm
cups-filters-debugsource-1.20.0-18.el8_1.1.x86_64.rpm
cups-filters-libs-1.20.0-18.el8_1.1.i686.rpm
cups-filters-libs-1.20.0-18.el8_1.1.x86_64.rpm
cups-filters-libs-debuginfo-1.20.0-18.el8_1.1.i686.rpm
cups-filters-libs-debuginfo-1.20.0-18.el8_1.1.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2023-24805
https://access.redhat.com/security/updates/classification/#important

8. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2023 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIVAwUBZH53jtzjgjWX9erEAQh0vg//UBqwZMmzLAZt1mOBI3HSkj041LcSFG7w
s70FPF3/KUdtxYcZvwVLWt4J4HdUSXIfgh9hY1ZLfOhbYtRmel32GWUAqM6RK1nX
U4ZXwDF+wSF1bxyybzMnCRUFifHM6ACNfqZUxZ8GTy7zG9r8LAN0k76y5DxfmiHg
RJFowO6p4aCQDPqU1X0GxFre9D99YSrhMKeefzF0cmFF1QPpdWPgRIy6pkzJ+cK1
WG1pF6c+/F6RrubW3nyubLFkMnlLe6/KAgG5pub8iuGpUNqC0EF85hOnigA8S6qH
3XzVBAz52WIErT69CHTqv+c/EIZJNME69fTDNFqegwOzCu8sCX2iXmaaaMF21okf
NoJqS5OeizkKMndAwMPAp4JxNg9n+HNDrfLTDsdVkNJi8TBYh4ODzJEgy9WWciwB
mxp5lFtzHDt4K/4HiI74FltUPK3LhtS8c8tRP9f/BCBIIMmdi/Fvhta+RgKinoLP
tW3b+/oO4Lqmat16YzsnjQsCSkowxUYPdKwOtlXN1q9fH2O7G8zeXPB2fewGyyoj
c/qn1sO4iTEiB8CStxStNIqjIjux4O4qNmPbZN9iLwRZRo/1DT/8Gzz1aFRiJdQo
31wetgcMa+kdiYQcwl5J6BXFmJsfIW6FQ3hxgiF0fzcaMKApbz3+sBfSj+BiPAEX
vAPD413QGSM=n2OG
-----END PGP SIGNATURE-----
--
RHSA-announce mailing list
[email protected]
https://listman.redhat.com/mailman/listinfo/rhsa-announce

RedHat: RHSA-2023-3429:01 Important: cups-filters security update

An update for cups-filters is now available for Red Hat Enterprise Linux 8.1 Update Services for SAP Solutions

Summary

The cups-filters package contains back ends, filters, and other software that was once part of the core Common UNIX Printing System (CUPS) distribution but is now maintained independently.
Security Fix(es):
* cups-filters: remote code execution in cups-filters, beh CUPS backend (CVE-2023-24805)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.



Summary


Solution

For details on how to apply this update, which includes the changes described in this advisory, refer to:
https://access.redhat.com/articles/11258

References

https://access.redhat.com/security/cve/CVE-2023-24805 https://access.redhat.com/security/updates/classification/#important

Package List

Red Hat Enterprise Linux AppStream E4S (v. 8.1):
Source: cups-filters-1.20.0-18.el8_1.1.src.rpm
aarch64: cups-filters-1.20.0-18.el8_1.1.aarch64.rpm cups-filters-debuginfo-1.20.0-18.el8_1.1.aarch64.rpm cups-filters-debugsource-1.20.0-18.el8_1.1.aarch64.rpm cups-filters-libs-1.20.0-18.el8_1.1.aarch64.rpm cups-filters-libs-debuginfo-1.20.0-18.el8_1.1.aarch64.rpm
ppc64le: cups-filters-1.20.0-18.el8_1.1.ppc64le.rpm cups-filters-debuginfo-1.20.0-18.el8_1.1.ppc64le.rpm cups-filters-debugsource-1.20.0-18.el8_1.1.ppc64le.rpm cups-filters-libs-1.20.0-18.el8_1.1.ppc64le.rpm cups-filters-libs-debuginfo-1.20.0-18.el8_1.1.ppc64le.rpm
s390x: cups-filters-1.20.0-18.el8_1.1.s390x.rpm cups-filters-debuginfo-1.20.0-18.el8_1.1.s390x.rpm cups-filters-debugsource-1.20.0-18.el8_1.1.s390x.rpm cups-filters-libs-1.20.0-18.el8_1.1.s390x.rpm cups-filters-libs-debuginfo-1.20.0-18.el8_1.1.s390x.rpm
x86_64: cups-filters-1.20.0-18.el8_1.1.x86_64.rpm cups-filters-debuginfo-1.20.0-18.el8_1.1.i686.rpm cups-filters-debuginfo-1.20.0-18.el8_1.1.x86_64.rpm cups-filters-debugsource-1.20.0-18.el8_1.1.i686.rpm cups-filters-debugsource-1.20.0-18.el8_1.1.x86_64.rpm cups-filters-libs-1.20.0-18.el8_1.1.i686.rpm cups-filters-libs-1.20.0-18.el8_1.1.x86_64.rpm cups-filters-libs-debuginfo-1.20.0-18.el8_1.1.i686.rpm cups-filters-libs-debuginfo-1.20.0-18.el8_1.1.x86_64.rpm
These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from https://access.redhat.com/security/team/key/


Severity
Advisory ID: RHSA-2023:3429-02
Product: Red Hat Enterprise Linux
Advisory URL: https://access.redhat.com/errata/RHSA-2023:3429
Issued Date: : 2023-06-02
CVE Names: CVE-2023-24805

Topic

An update for cups-filters is now available for Red Hat Enterprise Linux8.1 Update Services for SAP Solutions.Red Hat Product Security has rated this update as having a security impactof Important. A Common Vulnerability Scoring System (CVSS) base score,which gives a detailed severity rating, is available for each vulnerabilityfrom the CVE link(s) in the References section.


Topic


 

Relevant Releases Architectures

Red Hat Enterprise Linux AppStream E4S (v. 8.1) - aarch64, ppc64le, s390x, x86_64


Bugs Fixed

2203051 - CVE-2023-24805 cups-filters: remote code execution in cups-filters, beh CUPS backend


Feedback