Rocky Linux: RLSA-2021:3142 .NET Core 3.1 security and bugfix upda...
\{'type': 'Security', 'shortCode': 'RL', 'name': 'RLSA-2021:3142', 'synopsis': 'Important: .NET Core 3.1 security and bugfix update', 'severity': 'Important', 'topic': 'An update for .NET Core 3.1 is now available for Rocky Linux 8.\nRocky Linux Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.', 'description': '.NET is a managed-software framework. It implements a subset of the .NET framework APIs and several new APIs, and it includes a CLR implementation.\nNew versions of .NET that address security vulnerabilities are now available. The updated versions are .NET SDK 3.1.118 and .NET Runtime 3.1.18.\nFor more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.', 'solution': None, 'affectedProducts': ['Rocky Linux 8'], 'fixes': ['1990286', '1990295', '1990300'], 'cves': ['Red Hat:::https://access.redhat.com/hydra/rest/securitydata/cve/CVE-2021-26423.json:::CVE-2021-26423', 'Red Hat:::https://access.redhat.com/hydra/rest/securitydata/cve/CVE-2021-34485.json:::CVE-2021-34485', 'Red Hat:::https://access.redhat.com/hydra/rest/securitydata/cve/CVE-2021-34532.json:::CVE-2021-34532'], 'references': [], 'publishedAt': '2021-08-12T20:59:59.370365Z', 'rpms': ['aspnetcore-runtime-3.1-3.1.18-1.el8_4.rocky.1.x86_64.rpm', 'aspnetcore-runtime-3.1-3.1.18-1.el8.rocky.1.x86_64.rpm', 'aspnetcore-runtime-5.0-5.0.9-1.el8_4.rocky.1.x86_64.rpm', 'aspnetcore-targeting-pack-3.1-3.1.18-1.el8_4.rocky.1.x86_64.rpm', 'aspnetcore-targeting-pack-3.1-3.1.18-1.el8.rocky.1.x86_64.rpm', 'aspnetcore-targeting-pack-5.0-5.0.9-1.el8_4.rocky.1.x86_64.rpm', 'dotnet-2.1.525-1.el8_4.rocky.src.rpm', 'dotnet-5.0.206-1.el8_4.rocky.1.x86_64.rpm', 'dotnet3.1-3.1.118-1.el8_4.rocky.1.src.rpm', 'dotnet3.1-3.1.118-1.el8.rocky.1.src.rpm', 'dotnet3.1-debuginfo-3.1.118-1.el8_4.rocky.1.x86_64.rpm', 'dotnet3.1-debuginfo-3.1.118-1.el8.rocky.1.x86_64.rpm', 'dotnet3.1-debugsource-3.1.118-1.el8_4.rocky.1.x86_64.rpm', 'dotnet3.1-debugsource-3.1.118-1.el8.rocky.1.x86_64.rpm', 'dotnet5.0-5.0.206-1.el8_4.rocky.1.src.rpm', 'dotnet5.0-debuginfo-5.0.206-1.el8_4.rocky.1.x86_64.rpm', 'dotnet5.0-debugsource-5.0.206-1.el8_4.rocky.1.x86_64.rpm', 'dotnet-apphost-pack-3.1-3.1.18-1.el8_4.rocky.1.x86_64.rpm', 'dotnet-apphost-pack-3.1-3.1.18-1.el8.rocky.1.x86_64.rpm', 'dotnet-apphost-pack-3.1-debuginfo-3.1.18-1.el8_4.rocky.1.x86_64.rpm', 'dotnet-apphost-pack-3.1-debuginfo-3.1.18-1.el8.rocky.1.x86_64.rpm', 'dotnet-apphost-pack-5.0-5.0.9-1.el8_4.rocky.1.x86_64.rpm', 'dotnet-apphost-pack-5.0-debuginfo-5.0.9-1.el8_4.rocky.1.x86_64.rpm', 'dotnet-debuginfo-2.1.525-1.el8_4.rocky.x86_64.rpm', 'dotnet-debugsource-2.1.525-1.el8_4.rocky.x86_64.rpm', 'dotnet-host-5.0.9-1.el8_4.rocky.1.x86_64.rpm', 'dotnet-host-debuginfo-5.0.9-1.el8_4.rocky.1.x86_64.rpm', 'dotnet-host-fxr-2.1-2.1.29-1.el8_4.rocky.x86_64.rpm', 'dotnet-host-fxr-2.1-debuginfo-2.1.29-1.el8_4.rocky.x86_64.rpm', 'dotnet-hostfxr-3.1-3.1.18-1.el8_4.rocky.1.x86_64.rpm', 'dotnet-hostfxr-3.1-3.1.18-1.el8.rocky.1.x86_64.rpm', 'dotnet-hostfxr-3.1-debuginfo-3.1.18-1.el8_4.rocky.1.x86_64.rpm', 'dotnet-hostfxr-3.1-debuginfo-3.1.18-1.el8.rocky.1.x86_64.rpm', 'dotnet-hostfxr-5.0-5.0.9-1.el8_4.rocky.1.x86_64.rpm', 'dotnet-hostfxr-5.0-debuginfo-5.0.9-1.el8_4.rocky.1.x86_64.rpm', 'dotnet-runtime-2.1-2.1.29-1.el8_4.rocky.x86_64.rpm', 'dotnet-runtime-2.1-debuginfo-2.1.29-1.el8_4.rocky.x86_64.rpm', 'dotnet-runtime-3.1-3.1.18-1.el8_4.rocky.1.x86_64.rpm', 'dotnet-runtime-3.1-3.1.18-1.el8.rocky.1.x86_64.rpm', 'dotnet-runtime-3.1-debuginfo-3.1.18-1.el8_4.rocky.1.x86_64.rpm', 'dotnet-runtime-3.1-debuginfo-3.1.18-1.el8.rocky.1.x86_64.rpm', 'dotnet-runtime-5.0-5.0.9-1.el8_4.rocky.1.x86_64.rpm', 'dotnet-runtime-5.0-debuginfo-5.0.9-1.el8_4.rocky.1.x86_64.rpm', 'dotnet-sdk-2.1-2.1.525-1.el8_4.rocky.x86_64.rpm', 'dotnet-sdk-2.1.5xx-2.1.525-1.el8_4.rocky.x86_64.rpm', 'dotnet-sdk-2.1.5xx-debuginfo-2.1.525-1.el8_4.rocky.x86_64.rpm', 'dotnet-sdk-3.1-3.1.118-1.el8_4.rocky.1.x86_64.rpm', 'dotnet-sdk-3.1-3.1.118-1.el8.rocky.1.x86_64.rpm', 'dotnet-sdk-3.1-debuginfo-3.1.118-1.el8_4.rocky.1.x86_64.rpm', 'dotnet-sdk-3.1-debuginfo-3.1.118-1.el8.rocky.1.x86_64.rpm', 'dotnet-sdk-5.0-5.0.206-1.el8_4.rocky.1.x86_64.rpm', 'dotnet-sdk-5.0-debuginfo-5.0.206-1.el8_4.rocky.1.x86_64.rpm', 'dotnet-targeting-pack-3.1-3.1.18-1.el8_4.rocky.1.x86_64.rpm', 'dotnet-targeting-pack-3.1-3.1.18-1.el8.rocky.1.x86_64.rpm', 'dotnet-targeting-pack-5.0-5.0.9-1.el8_4.rocky.1.x86_64.rpm', 'dotnet-templates-3.1-3.1.118-1.el8_4.rocky.1.x86_64.rpm', 'dotnet-templates-3.1-3.1.118-1.el8.rocky.1.x86_64.rpm', 'dotnet-templates-5.0-5.0.206-1.el8_4.rocky.1.x86_64.rpm', 'netstandard-targeting-pack-2.1-5.0.206-1.el8_4.rocky.1.x86_64.rpm']}\

Rocky Linux: RLSA-2021:3142 .NET Core 3.1 security and bugfix update

September 2, 2022
An update for

Summary

An update for .NET Core 3.1 is now available for Rocky Linux 8. Rocky Linux Product Security has rated this update as having a security impact of Important. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.


.NET is a managed-software framework. It implements a subset of the .NET framework APIs and several new APIs, and it includes a CLR implementation. New versions of .NET that address security vulnerabilities are now available. The updated versions are .NET SDK 3.1.118 and .NET Runtime 3.1.18. For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

RPMs

aspnetcore-runtime-3.1-3.1.18-1.el8_4.rocky.1.x86_64.rpm
aspnetcore-runtime-3.1-3.1.18-1.el8.rocky.1.x86_64.rpm
aspnetcore-runtime-5.0-5.0.9-1.el8_4.rocky.1.x86_64.rpm
aspnetcore-targeting-pack-3.1-3.1.18-1.el8_4.rocky.1.x86_64.rpm
aspnetcore-targeting-pack-3.1-3.1.18-1.el8.rocky.1.x86_64.rpm
aspnetcore-targeting-pack-5.0-5.0.9-1.el8_4.rocky.1.x86_64.rpm
dotnet-2.1.525-1.el8_4.rocky.src.rpm
dotnet-5.0.206-1.el8_4.rocky.1.x86_64.rpm
dotnet3.1-3.1.118-1.el8_4.rocky.1.src.rpm
dotnet3.1-3.1.118-1.el8.rocky.1.src.rpm
dotnet3.1-debuginfo-3.1.118-1.el8_4.rocky.1.x86_64.rpm
dotnet3.1-debuginfo-3.1.118-1.el8.rocky.1.x86_64.rpm
dotnet3.1-debugsource-3.1.118-1.el8_4.rocky.1.x86_64.rpm
dotnet3.1-debugsource-3.1.118-1.el8.rocky.1.x86_64.rpm
dotnet5.0-5.0.206-1.el8_4.rocky.1.src.rpm
dotnet5.0-debuginfo-5.0.206-1.el8_4.rocky.1.x86_64.rpm
dotnet5.0-debugsource-5.0.206-1.el8_4.rocky.1.x86_64.rpm
dotnet-apphost-pack-3.1-3.1.18-1.el8_4.rocky.1.x86_64.rpm
dotnet-apphost-pack-3.1-3.1.18-1.el8.rocky.1.x86_64.rpm
dotnet-apphost-pack-3.1-debuginfo-3.1.18-1.el8_4.rocky.1.x86_64.rpm
dotnet-apphost-pack-3.1-debuginfo-3.1.18-1.el8.rocky.1.x86_64.rpm
dotnet-apphost-pack-5.0-5.0.9-1.el8_4.rocky.1.x86_64.rpm
dotnet-apphost-pack-5.0-debuginfo-5.0.9-1.el8_4.rocky.1.x86_64.rpm
dotnet-debuginfo-2.1.525-1.el8_4.rocky.x86_64.rpm
dotnet-debugsource-2.1.525-1.el8_4.rocky.x86_64.rpm
dotnet-host-5.0.9-1.el8_4.rocky.1.x86_64.rpm
dotnet-host-debuginfo-5.0.9-1.el8_4.rocky.1.x86_64.rpm
dotnet-host-fxr-2.1-2.1.29-1.el8_4.rocky.x86_64.rpm
dotnet-host-fxr-2.1-debuginfo-2.1.29-1.el8_4.rocky.x86_64.rpm
dotnet-hostfxr-3.1-3.1.18-1.el8_4.rocky.1.x86_64.rpm
dotnet-hostfxr-3.1-3.1.18-1.el8.rocky.1.x86_64.rpm
dotnet-hostfxr-3.1-debuginfo-3.1.18-1.el8_4.rocky.1.x86_64.rpm
dotnet-hostfxr-3.1-debuginfo-3.1.18-1.el8.rocky.1.x86_64.rpm
dotnet-hostfxr-5.0-5.0.9-1.el8_4.rocky.1.x86_64.rpm
dotnet-hostfxr-5.0-debuginfo-5.0.9-1.el8_4.rocky.1.x86_64.rpm
dotnet-runtime-2.1-2.1.29-1.el8_4.rocky.x86_64.rpm
dotnet-runtime-2.1-debuginfo-2.1.29-1.el8_4.rocky.x86_64.rpm
dotnet-runtime-3.1-3.1.18-1.el8_4.rocky.1.x86_64.rpm
dotnet-runtime-3.1-3.1.18-1.el8.rocky.1.x86_64.rpm
dotnet-runtime-3.1-debuginfo-3.1.18-1.el8_4.rocky.1.x86_64.rpm
dotnet-runtime-3.1-debuginfo-3.1.18-1.el8.rocky.1.x86_64.rpm
dotnet-runtime-5.0-5.0.9-1.el8_4.rocky.1.x86_64.rpm
dotnet-runtime-5.0-debuginfo-5.0.9-1.el8_4.rocky.1.x86_64.rpm
dotnet-sdk-2.1-2.1.525-1.el8_4.rocky.x86_64.rpm
dotnet-sdk-2.1.5xx-2.1.525-1.el8_4.rocky.x86_64.rpm
dotnet-sdk-2.1.5xx-debuginfo-2.1.525-1.el8_4.rocky.x86_64.rpm
dotnet-sdk-3.1-3.1.118-1.el8_4.rocky.1.x86_64.rpm
dotnet-sdk-3.1-3.1.118-1.el8.rocky.1.x86_64.rpm
dotnet-sdk-3.1-debuginfo-3.1.118-1.el8_4.rocky.1.x86_64.rpm
dotnet-sdk-3.1-debuginfo-3.1.118-1.el8.rocky.1.x86_64.rpm
dotnet-sdk-5.0-5.0.206-1.el8_4.rocky.1.x86_64.rpm
dotnet-sdk-5.0-debuginfo-5.0.206-1.el8_4.rocky.1.x86_64.rpm
dotnet-targeting-pack-3.1-3.1.18-1.el8_4.rocky.1.x86_64.rpm
dotnet-targeting-pack-3.1-3.1.18-1.el8.rocky.1.x86_64.rpm
dotnet-targeting-pack-5.0-5.0.9-1.el8_4.rocky.1.x86_64.rpm
dotnet-templates-3.1-3.1.118-1.el8_4.rocky.1.x86_64.rpm
dotnet-templates-3.1-3.1.118-1.el8.rocky.1.x86_64.rpm
dotnet-templates-5.0-5.0.206-1.el8_4.rocky.1.x86_64.rpm
netstandard-targeting-pack-2.1-5.0.206-1.el8_4.rocky.1.x86_64.rpm

References

Severity
Name: RLSA-2021:3142
Affected Products: Rocky Linux 8

Fixes

https://bugzilla.redhat.com/show_bug.cgi?id=1990286

https://bugzilla.redhat.com/show_bug.cgi?id=1990295

https://bugzilla.redhat.com/show_bug.cgi?id=1990300

CVES

https://access.redhat.com/hydra/rest/securitydata/cve/CVE-2021-26423.json

https://access.redhat.com/hydra/rest/securitydata/cve/CVE-2021-34485.json

https://access.redhat.com/hydra/rest/securitydata/cve/CVE-2021-34532.json

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.