SciLinux: SLSA-2021-1512-1 Important: postgresql on SL7.x x86_64 |...
Synopsis:          Important: postgresql security update
Advisory ID:       SLSA-2021:1512-1
Issue Date:        2021-05-06
CVE Numbers:       CVE-2019-10208
                   CVE-2020-25694
                   CVE-2020-25695
--

Security Fix(es):

* postgresql: Reconnection can downgrade connection security settings
(CVE-2020-25694)

* postgresql: Multiple features escape "security restricted operation"
sandbox (CVE-2020-25695)

* postgresql: TYPE in pg_temp executes arbitrary SQL during SECURITY
DEFINER execution (CVE-2019-10208)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE

---
SL7
 x86_64
 - postgresql-9.2.24-6.el7_9.i686.rpm
 - postgresql-9.2.24-6.el7_9.x86_64.rpm
 - postgresql-contrib-9.2.24-6.el7_9.x86_64.rpm
 - postgresql-debuginfo-9.2.24-6.el7_9.i686.rpm
 - postgresql-debuginfo-9.2.24-6.el7_9.x86_64.rpm
 - postgresql-devel-9.2.24-6.el7_9.i686.rpm
 - postgresql-devel-9.2.24-6.el7_9.x86_64.rpm
 - postgresql-docs-9.2.24-6.el7_9.x86_64.rpm
 - postgresql-libs-9.2.24-6.el7_9.i686.rpm
 - postgresql-libs-9.2.24-6.el7_9.x86_64.rpm
 - postgresql-plperl-9.2.24-6.el7_9.x86_64.rpm
 - postgresql-plpython-9.2.24-6.el7_9.x86_64.rpm
 - postgresql-pltcl-9.2.24-6.el7_9.x86_64.rpm
 - postgresql-server-9.2.24-6.el7_9.x86_64.rpm
 - postgresql-static-9.2.24-6.el7_9.i686.rpm
 - postgresql-static-9.2.24-6.el7_9.x86_64.rpm
 - postgresql-test-9.2.24-6.el7_9.x86_64.rpm
 - postgresql-upgrade-9.2.24-6.el7_9.x86_64.rpm
--

- Scientific Linux Development Team

SciLinux: SLSA-2021-1512-1 Important: postgresql on SL7.x x86_64

Summary

Important: postgresql security update



Security Fixes

* postgresql: Reconnection can downgrade connection security settings (CVE-2020-25694)
* postgresql: Multiple features escape "security restricted operation" sandbox (CVE-2020-25695)
* postgresql: TYPE in pg_temp executes arbitrary SQL during SECURITY DEFINER execution (CVE-2019-10208)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE
SL7 x86_64 - postgresql-9.2.24-6.el7_9.i686.rpm - postgresql-9.2.24-6.el7_9.x86_64.rpm - postgresql-contrib-9.2.24-6.el7_9.x86_64.rpm - postgresql-debuginfo-9.2.24-6.el7_9.i686.rpm - postgresql-debuginfo-9.2.24-6.el7_9.x86_64.rpm - postgresql-devel-9.2.24-6.el7_9.i686.rpm - postgresql-devel-9.2.24-6.el7_9.x86_64.rpm - postgresql-docs-9.2.24-6.el7_9.x86_64.rpm - postgresql-libs-9.2.24-6.el7_9.i686.rpm - postgresql-libs-9.2.24-6.el7_9.x86_64.rpm - postgresql-plperl-9.2.24-6.el7_9.x86_64.rpm - postgresql-plpython-9.2.24-6.el7_9.x86_64.rpm - postgresql-pltcl-9.2.24-6.el7_9.x86_64.rpm - postgresql-server-9.2.24-6.el7_9.x86_64.rpm - postgresql-static-9.2.24-6.el7_9.i686.rpm - postgresql-static-9.2.24-6.el7_9.x86_64.rpm - postgresql-test-9.2.24-6.el7_9.x86_64.rpm - postgresql-upgrade-9.2.24-6.el7_9.x86_64.rpm
- Scientific Linux Development Team

Severity
Advisory ID: SLSA-2021:1512-1
Issued Date: : 2021-05-06
CVE Numbers: CVE-2019-10208
CVE-2020-25694
CVE-2020-25695

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.