SciLinux: SLSA-2021-2328-1 Important: qt5-qtimageformats on SL7.x x...
Synopsis:          Important: qt5-qtimageformats security update
Advisory ID:       SLSA-2021:2328-1
Issue Date:        2021-06-09
CVE Numbers:       CVE-2020-36328
                   CVE-2020-36329
                   CVE-2018-25011
                   CVE-2018-25014
--

Security Fix(es):

* libwebp: heap-based buffer overflow in PutLE16() (CVE-2018-25011)

* libwebp: use of uninitialized value in ReadSymbol() (CVE-2018-25014)

* libwebp: heap-based buffer overflow in WebPDecode*Into functions
(CVE-2020-36328)

* libwebp: use-after-free in EmitFancyRGB() in dec/io_dec.c
(CVE-2020-36329)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE

---
SL7
x86_64

qt5-qtimageformats-5.9.7-2.el7_9.i686.rpm
qt5-qtimageformats-5.9.7-2.el7_9.x86_64.rpm
qt5-qtimageformats-debuginfo-5.9.7-2.el7_9.i686.rpm
qt5-qtimageformats-debuginfo-5.9.7-2.el7_9.x86_64.rpm

noarch
qt5-qtimageformats-doc-5.9.7-2.el7_9.noarch.rpm
--

- Scientific Linux Development Team

SciLinux: SLSA-2021-2328-1 Important: qt5-qtimageformats on SL7.x x86_64

Summary

Important: qt5-qtimageformats security update



Security Fixes

* libwebp: heap-based buffer overflow in PutLE16() (CVE-2018-25011)
* libwebp: use of uninitialized value in ReadSymbol() (CVE-2018-25014)
* libwebp: heap-based buffer overflow in WebPDecode*Into functions (CVE-2020-36328)
* libwebp: use-after-free in EmitFancyRGB() in dec/io_dec.c (CVE-2020-36329)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE
SL7 x86_64
qt5-qtimageformats-5.9.7-2.el7_9.i686.rpm qt5-qtimageformats-5.9.7-2.el7_9.x86_64.rpm qt5-qtimageformats-debuginfo-5.9.7-2.el7_9.i686.rpm qt5-qtimageformats-debuginfo-5.9.7-2.el7_9.x86_64.rpm
noarch qt5-qtimageformats-doc-5.9.7-2.el7_9.noarch.rpm
- Scientific Linux Development Team

Severity
Advisory ID: SLSA-2021:2328-1
Issued Date: : 2021-06-09
CVE Numbers: CVE-2020-36328
CVE-2020-36329
CVE-2018-25011

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.