SciLinux: SLSA-2022-4870-1 Important: firefox on SL7.x x86_64 | Lin...
Synopsis:          Important: firefox security update
Advisory ID:       SLSA-2022:4870-1
Issue Date:        2022-06-02
CVE Numbers:       CVE-2022-31736
                   CVE-2022-31737
                   CVE-2022-31738
                   CVE-2022-31740
                   CVE-2022-31741
                   CVE-2022-31742
                   CVE-2022-31747
--

This update upgrades Firefox to version 91.10.0 ESR.

Security Fix(es):

* Mozilla: Cross-Origin resource's length leaked (CVE-2022-31736)

* Mozilla: Heap buffer overflow in WebGL (CVE-2022-31737)

* Mozilla: Browser window spoof using fullscreen mode (CVE-2022-31738)

* Mozilla: Register allocation problem in WASM on arm64 (CVE-2022-31740)

* Mozilla: Uninitialized variable leads to invalid memory read
(CVE-2022-31741)

* Mozilla: Memory safety bugs fixed in Firefox 101 and Firefox ESR 91.10
(CVE-2022-31747)

* Mozilla: Querying a WebAuthn token with a large number of
allowCredential  entries may have leaked cross-origin information
(CVE-2022-31742)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
--

SL7
  x86_64
    firefox-91.10.0-1.el7_9.x86_64.rpm
    firefox-debuginfo-91.10.0-1.el7_9.x86_64.rpm
    firefox-91.10.0-1.el7_9.i686.rpm

- Scientific Linux Development Team

SciLinux: SLSA-2022-4870-1 Important: firefox on SL7.x x86_64

This update upgrades Firefox to version 91.10.0 ESR

Summary

Important: firefox security update



Security Fixes

* Mozilla: Cross-Origin resource's length leaked (CVE-2022-31736)
* Mozilla: Heap buffer overflow in WebGL (CVE-2022-31737)
* Mozilla: Browser window spoof using fullscreen mode (CVE-2022-31738)
* Mozilla: Register allocation problem in WASM on arm64 (CVE-2022-31740)
* Mozilla: Uninitialized variable leads to invalid memory read (CVE-2022-31741)
* Mozilla: Memory safety bugs fixed in Firefox 101 and Firefox ESR 91.10 (CVE-2022-31747)
* Mozilla: Querying a WebAuthn token with a large number of allowCredential entries may have leaked cross-origin information (CVE-2022-31742)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE
SL7 x86_64 firefox-91.10.0-1.el7_9.x86_64.rpm firefox-debuginfo-91.10.0-1.el7_9.x86_64.rpm firefox-91.10.0-1.el7_9.i686.rpm
- Scientific Linux Development Team

Severity
Advisory ID: SLSA-2022:4870-1
Issued Date: : 2022-06-02
CVE Numbers: CVE-2022-31736
CVE-2022-31737
CVE-2022-31738

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.