SciLinux: SLSA-2022-5687-1 Important: java-11-openjdk on SL7.x x86_...
Synopsis:          Important: java-11-openjdk security, bug fix, and enhancement update
Advisory ID:       SLSA-2022:5687-1
Issue Date:        2022-08-01
CVE Numbers:       CVE-2022-21540
                   CVE-2022-21541
                   CVE-2022-34169
--

The following packages have been upgraded to a later upstream version:
java-11-openjdk (11.0.16.0.8).

Security Fix(es):

* OpenJDK: integer truncation issue in Xalan-J (JAXP, 8285407)
(CVE-2022-34169)

* OpenJDK: class compilation issue (Hotspot, 8281859) (CVE-2022-21540)

* OpenJDK: improper restriction of MethodHandle.invokeBasic() (Hotspot,
8281866) (CVE-2022-21541)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
--

SL7
  x86_64
    java-11-openjdk-11.0.16.0.8-1.el7_9.i686.rpm
    java-11-openjdk-11.0.16.0.8-1.el7_9.x86_64.rpm
    java-11-openjdk-debuginfo-11.0.16.0.8-1.el7_9.i686.rpm
    java-11-openjdk-debuginfo-11.0.16.0.8-1.el7_9.x86_64.rpm
    java-11-openjdk-headless-11.0.16.0.8-1.el7_9.i686.rpm
    java-11-openjdk-headless-11.0.16.0.8-1.el7_9.x86_64.rpm
    java-11-openjdk-demo-11.0.16.0.8-1.el7_9.i686.rpm
    java-11-openjdk-demo-11.0.16.0.8-1.el7_9.x86_64.rpm
    java-11-openjdk-devel-11.0.16.0.8-1.el7_9.i686.rpm
    java-11-openjdk-devel-11.0.16.0.8-1.el7_9.x86_64.rpm
    java-11-openjdk-javadoc-11.0.16.0.8-1.el7_9.i686.rpm
    java-11-openjdk-javadoc-11.0.16.0.8-1.el7_9.x86_64.rpm
    java-11-openjdk-javadoc-zip-11.0.16.0.8-1.el7_9.i686.rpm
    java-11-openjdk-javadoc-zip-11.0.16.0.8-1.el7_9.x86_64.rpm
    java-11-openjdk-jmods-11.0.16.0.8-1.el7_9.i686.rpm
    java-11-openjdk-jmods-11.0.16.0.8-1.el7_9.x86_64.rpm
    java-11-openjdk-src-11.0.16.0.8-1.el7_9.i686.rpm
    java-11-openjdk-src-11.0.16.0.8-1.el7_9.x86_64.rpm
    java-11-openjdk-static-libs-11.0.16.0.8-1.el7_9.i686.rpm
    java-11-openjdk-static-libs-11.0.16.0.8-1.el7_9.x86_64.rpm

- Scientific Linux Development Team

SciLinux: SLSA-2022-5687-1 Important: java-11-openjdk on SL7.x x86_64

Summary

Important: java-11-openjdk security, bug fix, and enhancement update



Security Fixes

* OpenJDK: integer truncation issue in Xalan-J (JAXP, 8285407) (CVE-2022-34169)
* OpenJDK: class compilation issue (Hotspot, 8281859) (CVE-2022-21540)
* OpenJDK: improper restriction of MethodHandle.invokeBasic() (Hotspot, 8281866) (CVE-2022-21541)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE
SL7 x86_64 java-11-openjdk-11.0.16.0.8-1.el7_9.i686.rpm java-11-openjdk-11.0.16.0.8-1.el7_9.x86_64.rpm java-11-openjdk-debuginfo-11.0.16.0.8-1.el7_9.i686.rpm java-11-openjdk-debuginfo-11.0.16.0.8-1.el7_9.x86_64.rpm java-11-openjdk-headless-11.0.16.0.8-1.el7_9.i686.rpm java-11-openjdk-headless-11.0.16.0.8-1.el7_9.x86_64.rpm java-11-openjdk-demo-11.0.16.0.8-1.el7_9.i686.rpm java-11-openjdk-demo-11.0.16.0.8-1.el7_9.x86_64.rpm java-11-openjdk-devel-11.0.16.0.8-1.el7_9.i686.rpm java-11-openjdk-devel-11.0.16.0.8-1.el7_9.x86_64.rpm java-11-openjdk-javadoc-11.0.16.0.8-1.el7_9.i686.rpm java-11-openjdk-javadoc-11.0.16.0.8-1.el7_9.x86_64.rpm java-11-openjdk-javadoc-zip-11.0.16.0.8-1.el7_9.i686.rpm java-11-openjdk-javadoc-zip-11.0.16.0.8-1.el7_9.x86_64.rpm java-11-openjdk-jmods-11.0.16.0.8-1.el7_9.i686.rpm java-11-openjdk-jmods-11.0.16.0.8-1.el7_9.x86_64.rpm java-11-openjdk-src-11.0.16.0.8-1.el7_9.i686.rpm java-11-openjdk-src-11.0.16.0.8-1.el7_9.x86_64.rpm java-11-openjdk-static-libs-11.0.16.0.8-1.el7_9.i686.rpm java-11-openjdk-static-libs-11.0.16.0.8-1.el7_9.x86_64.rpm
- Scientific Linux Development Team

Severity
Advisory ID: SLSA-2022:5687-1
Issued Date: : 2022-08-01
CVE Numbers: CVE-2022-21540
CVE-2022-21541
CVE-2022-34169

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.