SciLinux: SLSA-2022-8491-1 Important: xorg-x11-server on SL7.x x86_...
Synopsis:          Important: xorg-x11-server security update
Advisory ID:       SLSA-2022:8491-1
Issue Date:        2022-11-16
CVE Numbers:       CVE-2022-3550
                   CVE-2022-3551
--

Security Fix(es):

* xorg-x11-server: buffer overflow in _GetCountedString() in xkb/xkb.c
(CVE-2022-3550)

* xorg-x11-server: memory leak in ProcXkbGetKbdByName() in xkb/xkb.c
(CVE-2022-3551)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
--

SL7
  x86_64
    xorg-x11-server-Xephyr-1.20.4-19.el7_9.x86_64.rpm
    xorg-x11-server-Xorg-1.20.4-19.el7_9.x86_64.rpm
    xorg-x11-server-common-1.20.4-19.el7_9.x86_64.rpm
    xorg-x11-server-debuginfo-1.20.4-19.el7_9.x86_64.rpm
    xorg-x11-server-Xdmx-1.20.4-19.el7_9.x86_64.rpm
    xorg-x11-server-Xnest-1.20.4-19.el7_9.x86_64.rpm
    xorg-x11-server-Xvfb-1.20.4-19.el7_9.x86_64.rpm
    xorg-x11-server-Xwayland-1.20.4-19.el7_9.x86_64.rpm
    xorg-x11-server-debuginfo-1.20.4-19.el7_9.i686.rpm
    xorg-x11-server-devel-1.20.4-19.el7_9.i686.rpm
    xorg-x11-server-devel-1.20.4-19.el7_9.x86_64.rpm
  noarch
    xorg-x11-server-source-1.20.4-19.el7_9.noarch.rpm

- Scientific Linux Development Team

SciLinux: SLSA-2022-8491-1 Important: xorg-x11-server on SL7.x x86_64

Summary

Important: xorg-x11-server security update



Security Fixes

* xorg-x11-server: buffer overflow in _GetCountedString() in xkb/xkb.c (CVE-2022-3550)
* xorg-x11-server: memory leak in ProcXkbGetKbdByName() in xkb/xkb.c (CVE-2022-3551)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE
SL7 x86_64 xorg-x11-server-Xephyr-1.20.4-19.el7_9.x86_64.rpm xorg-x11-server-Xorg-1.20.4-19.el7_9.x86_64.rpm xorg-x11-server-common-1.20.4-19.el7_9.x86_64.rpm xorg-x11-server-debuginfo-1.20.4-19.el7_9.x86_64.rpm xorg-x11-server-Xdmx-1.20.4-19.el7_9.x86_64.rpm xorg-x11-server-Xnest-1.20.4-19.el7_9.x86_64.rpm xorg-x11-server-Xvfb-1.20.4-19.el7_9.x86_64.rpm xorg-x11-server-Xwayland-1.20.4-19.el7_9.x86_64.rpm xorg-x11-server-debuginfo-1.20.4-19.el7_9.i686.rpm xorg-x11-server-devel-1.20.4-19.el7_9.i686.rpm xorg-x11-server-devel-1.20.4-19.el7_9.x86_64.rpm noarch xorg-x11-server-source-1.20.4-19.el7_9.noarch.rpm
- Scientific Linux Development Team

Severity
Advisory ID: SLSA-2022:8491-1
Issued Date: : 2022-11-16
CVE Numbers: CVE-2022-3550
CVE-2022-3551

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.