SUSE: 2019:2802-1 moderate: python3

    Date 29 Oct 2019
    396
    Posted By LinuxSecurity Advisories
    An update that solves two vulnerabilities and has three fixes is now available.
    
       SUSE Security Update: Security update for python3
    ______________________________________________________________________________
    
    Announcement ID:    SUSE-SU-2019:2802-1
    Rating:             moderate
    References:         #1149121 #1149792 #1149955 #1151490 #1153238 
                        
    Cross-References:   CVE-2019-16056 CVE-2019-16935
    Affected Products:
                        SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1
                        SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
                        SUSE Linux Enterprise Module for Development Tools 15-SP1
                        SUSE Linux Enterprise Module for Development Tools 15
                        SUSE Linux Enterprise Module for Basesystem 15-SP1
                        SUSE Linux Enterprise Module for Basesystem 15
    ______________________________________________________________________________
    
       An update that solves two vulnerabilities and has three
       fixes is now available.
    
    Description:
    
       This update for python3 to 3.6.9 fixes the following issues:
    
       Security issues fixed:
    
       - CVE-2019-16056: Fixed a parser issue in the email module. (bsc#1149955)
       - CVE-2019-16935: Fixed a reflected XSS in python/Lib/DocXMLRPCServer.py
         (bsc#1153238).
    
       Non-security issues fixed:
    
       - Fixed regression of OpenSSL 1.1.1b-1 in EVP_PBE_scrypt() with salt=NULL.
         (bsc#1151490)
       - Improved locale handling by implementing PEP 538.
    
    
    Patch Instructions:
    
       To install this SUSE Security Update use the SUSE recommended installation methods
       like YaST online_update or "zypper patch".
    
       Alternatively you can run the command listed for your product:
    
       - SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1:
    
          zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-2802=1
    
       - SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:
    
          zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2019-2802=1
    
       - SUSE Linux Enterprise Module for Development Tools 15-SP1:
    
          zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP1-2019-2802=1
    
       - SUSE Linux Enterprise Module for Development Tools 15:
    
          zypper in -t patch SUSE-SLE-Module-Development-Tools-15-2019-2802=1
    
       - SUSE Linux Enterprise Module for Basesystem 15-SP1:
    
          zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP1-2019-2802=1
    
       - SUSE Linux Enterprise Module for Basesystem 15:
    
          zypper in -t patch SUSE-SLE-Module-Basesystem-15-2019-2802=1
    
    
    
    Package List:
    
       - SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (aarch64 ppc64le s390x x86_64):
    
          python3-base-debuginfo-3.6.9-3.39.1
          python3-base-debugsource-3.6.9-3.39.1
          python3-testsuite-3.6.9-3.39.1
          python3-testsuite-debuginfo-3.6.9-3.39.1
    
       - SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (noarch):
    
          python3-doc-3.6.9-3.39.1
    
       - SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (x86_64):
    
          libpython3_6m1_0-32bit-3.6.9-3.39.1
          libpython3_6m1_0-32bit-debuginfo-3.6.9-3.39.1
          python3-32bit-3.6.9-3.39.1
          python3-32bit-debuginfo-3.6.9-3.39.1
          python3-base-32bit-3.6.9-3.39.1
          python3-base-32bit-debuginfo-3.6.9-3.39.1
          python3-debugsource-3.6.9-3.39.1
    
       - SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (aarch64 ppc64le s390x x86_64):
    
          python3-base-debuginfo-3.6.9-3.39.1
          python3-base-debugsource-3.6.9-3.39.1
          python3-testsuite-3.6.9-3.39.1
          python3-testsuite-debuginfo-3.6.9-3.39.1
    
       - SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (x86_64):
    
          libpython3_6m1_0-32bit-3.6.9-3.39.1
          python3-32bit-3.6.9-3.39.1
          python3-base-32bit-3.6.9-3.39.1
    
       - SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (noarch):
    
          python3-doc-3.6.9-3.39.1
    
       - SUSE Linux Enterprise Module for Development Tools 15-SP1 (aarch64 ppc64le s390x x86_64):
    
          python3-base-debuginfo-3.6.9-3.39.1
          python3-base-debugsource-3.6.9-3.39.1
          python3-tools-3.6.9-3.39.1
    
       - SUSE Linux Enterprise Module for Development Tools 15 (aarch64 ppc64le s390x x86_64):
    
          python3-base-debuginfo-3.6.9-3.39.1
          python3-base-debugsource-3.6.9-3.39.1
          python3-tools-3.6.9-3.39.1
    
       - SUSE Linux Enterprise Module for Basesystem 15-SP1 (aarch64 ppc64le s390x x86_64):
    
          libpython3_6m1_0-3.6.9-3.39.1
          libpython3_6m1_0-debuginfo-3.6.9-3.39.1
          python3-3.6.9-3.39.1
          python3-base-3.6.9-3.39.1
          python3-base-debuginfo-3.6.9-3.39.1
          python3-base-debugsource-3.6.9-3.39.1
          python3-curses-3.6.9-3.39.1
          python3-curses-debuginfo-3.6.9-3.39.1
          python3-dbm-3.6.9-3.39.1
          python3-dbm-debuginfo-3.6.9-3.39.1
          python3-debuginfo-3.6.9-3.39.1
          python3-debugsource-3.6.9-3.39.1
          python3-devel-3.6.9-3.39.1
          python3-devel-debuginfo-3.6.9-3.39.1
          python3-idle-3.6.9-3.39.1
          python3-tk-3.6.9-3.39.1
          python3-tk-debuginfo-3.6.9-3.39.1
    
       - SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x x86_64):
    
          libpython3_6m1_0-3.6.9-3.39.1
          libpython3_6m1_0-debuginfo-3.6.9-3.39.1
          python3-3.6.9-3.39.1
          python3-base-3.6.9-3.39.1
          python3-base-debuginfo-3.6.9-3.39.1
          python3-base-debugsource-3.6.9-3.39.1
          python3-curses-3.6.9-3.39.1
          python3-curses-debuginfo-3.6.9-3.39.1
          python3-dbm-3.6.9-3.39.1
          python3-dbm-debuginfo-3.6.9-3.39.1
          python3-debuginfo-3.6.9-3.39.1
          python3-debugsource-3.6.9-3.39.1
          python3-devel-3.6.9-3.39.1
          python3-devel-debuginfo-3.6.9-3.39.1
          python3-idle-3.6.9-3.39.1
          python3-tk-3.6.9-3.39.1
          python3-tk-debuginfo-3.6.9-3.39.1
    
    
    References:
    
       https://www.suse.com/security/cve/CVE-2019-16056.html
       https://www.suse.com/security/cve/CVE-2019-16935.html
       https://bugzilla.suse.com/1149121
       https://bugzilla.suse.com/1149792
       https://bugzilla.suse.com/1149955
       https://bugzilla.suse.com/1151490
       https://bugzilla.suse.com/1153238
    
    _______________________________________________
    sle-security-updates mailing list
    This email address is being protected from spambots. You need JavaScript enabled to view it.
    https://lists.suse.com/mailman/listinfo/sle-security-updates
    

    LinuxSecurity Poll

    Do you feel that the Lawful Access to Encrypted Data Act, which aims to force encryption backdoors, is a threat to US citizens' privacy?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/30-do-you-feel-that-the-lawful-access-to-encrypted-data-act-which-aims-to-force-encryption-backdoors-is-a-threat-to-privacy?task=poll.vote&format=json
    30
    radio
    [{"id":"106","title":"Yes - I am a privacy advocate and I am strongly opposed to this bill.","votes":"7","type":"x","order":"1","pct":100,"resources":[]},{"id":"107","title":"I'm undecided - it has its pros and cons.","votes":"0","type":"x","order":"2","pct":0,"resources":[]},{"id":"108","title":"No - I support this bill and feel that it will help protect against crime and threats to our national security. ","votes":"0","type":"x","order":"3","pct":0,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350
    bottom 200

    Advisories

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.