SUSE Security Update: Security update for nodejs8
______________________________________________________________________________

Announcement ID:    SUSE-SU-2020:2870-1
Rating:             moderate
References:         #1172686 #1173937 
Cross-References:   CVE-2020-15095
Affected Products:
                    SUSE Linux Enterprise Module for Web Scripting 15-SP1
______________________________________________________________________________

   An update that solves one vulnerability and has one errata
   is now available.

Description:

   This update for nodejs8 fixes the following issues:

   - CVE-2020-15095: Fixed information leak through log files (bsc#1173937).
   - Explicitly add -fno-strict-aliasing to CFLAGS to fix compilation
     on Aarch64 with gcc10 (bsc#1172686).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Module for Web Scripting 15-SP1:

      zypper in -t patch SUSE-SLE-Module-Web-Scripting-15-SP1-2020-2870=1



Package List:

   - SUSE Linux Enterprise Module for Web Scripting 15-SP1 (aarch64 ppc64le s390x x86_64):

      nodejs8-8.17.0-3.38.1
      nodejs8-debuginfo-8.17.0-3.38.1
      nodejs8-debugsource-8.17.0-3.38.1
      nodejs8-devel-8.17.0-3.38.1
      npm8-8.17.0-3.38.1

   - SUSE Linux Enterprise Module for Web Scripting 15-SP1 (noarch):

      nodejs8-docs-8.17.0-3.38.1


References:

   https://www.suse.com/security/cve/CVE-2020-15095.html
   https://bugzilla.suse.com/1172686
   https://bugzilla.suse.com/1173937

_______________________________________________
sle-security-updates mailing list
sle-security-updates@lists.suse.com
http://lists.suse.com/mailman/listinfo/sle-security-updates

SUSE: 2020:2870-1 moderate: nodejs8

October 6, 2020
An update that solves one vulnerability and has one errata is now available

Summary

This update for nodejs8 fixes the following issues: - CVE-2020-15095: Fixed information leak through log files (bsc#1173937). - Explicitly add -fno-strict-aliasing to CFLAGS to fix compilation on Aarch64 with gcc10 (bsc#1172686). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - SUSE Linux Enterprise Module for Web Scripting 15-SP1: zypper in -t patch SUSE-SLE-Module-Web-Scripting-15-SP1-2020-2870=1 Package List: - SUSE Linux Enterprise Module for Web Scripting 15-SP1 (aarch64 ppc64le s390x x86_64): nodejs8-8.17.0-3.38.1 nodejs8-debuginfo-8.17.0-3.38.1 nodejs8-debugsource-8.17.0-3.38.1 nodejs8-devel-8.17.0-3.38.1 npm8-8.17.0-3.38.1 - SUSE Linux Enterprise Module for Web Scripting 15-SP1 (noarch): nodejs8-docs-8.17.0-3.38.1

References

#1172686 #1173937

Cross- CVE-2020-15095

Affected Products:

SUSE Linux Enterprise Module for Web Scripting 15-SP1

https://www.suse.com/security/cve/CVE-2020-15095.html

https://bugzilla.suse.com/1172686

https://bugzilla.suse.com/1173937

Severity
Announcement ID: SUSE-SU-2020:2870-1
Rating: moderate

Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo