SUSE Security Update: Security update for ImageMagick
______________________________________________________________________________

Announcement ID:    SUSE-SU-2020:3164-1
Rating:             moderate
References:         #1106272 #1178067 
Cross-References:   CVE-2020-27560
Affected Products:
                    SUSE Linux Enterprise Module for Development Tools 15-SP2
                    SUSE Linux Enterprise Module for Desktop Applications 15-SP2
______________________________________________________________________________

   An update that solves one vulnerability and has one errata
   is now available.

Description:

   This update for ImageMagick fixes the following issues:

   - CVE-2020-27560: Fixed potential denial of service in OptimizeLayerFrames
     function in MagickCore/layer.c (bsc#1178067).
   - Fixed greyish image produced by incorrect colorspace (bsc#1106272).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Module for Development Tools 15-SP2:

      zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP2-2020-3164=1

   - SUSE Linux Enterprise Module for Desktop Applications 15-SP2:

      zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-SP2-2020-3164=1



Package List:

   - SUSE Linux Enterprise Module for Development Tools 15-SP2 (aarch64 ppc64le s390x x86_64):

      ImageMagick-debuginfo-7.0.7.34-10.3.1
      ImageMagick-debugsource-7.0.7.34-10.3.1
      perl-PerlMagick-7.0.7.34-10.3.1
      perl-PerlMagick-debuginfo-7.0.7.34-10.3.1

   - SUSE Linux Enterprise Module for Desktop Applications 15-SP2 (aarch64 ppc64le s390x x86_64):

      ImageMagick-7.0.7.34-10.3.1
      ImageMagick-config-7-SUSE-7.0.7.34-10.3.1
      ImageMagick-debuginfo-7.0.7.34-10.3.1
      ImageMagick-debugsource-7.0.7.34-10.3.1
      ImageMagick-devel-7.0.7.34-10.3.1
      libMagick++-7_Q16HDRI4-7.0.7.34-10.3.1
      libMagick++-7_Q16HDRI4-debuginfo-7.0.7.34-10.3.1
      libMagick++-devel-7.0.7.34-10.3.1
      libMagickCore-7_Q16HDRI6-7.0.7.34-10.3.1
      libMagickCore-7_Q16HDRI6-debuginfo-7.0.7.34-10.3.1
      libMagickWand-7_Q16HDRI6-7.0.7.34-10.3.1
      libMagickWand-7_Q16HDRI6-debuginfo-7.0.7.34-10.3.1


References:

   https://www.suse.com/security/cve/CVE-2020-27560.html
   https://bugzilla.suse.com/1106272
   https://bugzilla.suse.com/1178067