Discover Government News


   SUSE Security Update: Security update for postgresql10
______________________________________________________________________________

Announcement ID:    SUSE-SU-2020:3455-1
Rating:             important
References:         #1178666 #1178667 #1178668 
Cross-References:   CVE-2020-25694 CVE-2020-25695 CVE-2020-25696
                   
Affected Products:
                    SUSE Linux Enterprise Server for SAP 15
                    SUSE Linux Enterprise Server 15-LTSS
                    SUSE Linux Enterprise High Performance Computing 15-LTSS
                    SUSE Linux Enterprise High Performance Computing 15-ESPOS
______________________________________________________________________________

   An update that fixes three vulnerabilities is now available.

Description:

   This update for postgresql10 fixes the following issues:

   - Upgrade to version 10.15:
     * CVE-2020-25695, bsc#1178666: Block DECLARE CURSOR ... WITH HOLD and
       firing of deferred triggers within index expressions and materialized
       view queries.
     * CVE-2020-25694, bsc#1178667: a) Fix usage of complex connection-string
       parameters in pg_dump, pg_restore, clusterdb, reindexdb, and vacuumdb.
       b) When psql's \connect command re-uses connection parameters, ensure
       that all non-overridden parameters from a previous connection string
       are re-used.
     * CVE-2020-25696, bsc#1178668: Prevent psql's \gset command from
       modifying specially-treated variables.
     * Fix recently-added timetz test case so it works when the USA is not
       observing daylight savings time.
     * https://www.postgresql.org/about/news/postgresql-131-125-1110-1015-9620-and-9524-released-2111/
     * https://www.postgresql.org/docs/10/release-10-15.html


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Server for SAP 15:

      zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-2020-3455=1

   - SUSE Linux Enterprise Server 15-LTSS:

      zypper in -t patch SUSE-SLE-Product-SLES-15-2020-3455=1

   - SUSE Linux Enterprise High Performance Computing 15-LTSS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-2020-3455=1

   - SUSE Linux Enterprise High Performance Computing 15-ESPOS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-2020-3455=1



Package List:

   - SUSE Linux Enterprise Server for SAP 15 (ppc64le x86_64):

      libecpg6-10.15-4.28.1
      libecpg6-debuginfo-10.15-4.28.1
      libpq5-10.15-4.28.1
      libpq5-debuginfo-10.15-4.28.1
      postgresql10-10.15-4.28.1
      postgresql10-contrib-10.15-4.28.1
      postgresql10-contrib-debuginfo-10.15-4.28.1
      postgresql10-debuginfo-10.15-4.28.1
      postgresql10-debugsource-10.15-4.28.1
      postgresql10-devel-10.15-4.28.1
      postgresql10-devel-debuginfo-10.15-4.28.1
      postgresql10-plperl-10.15-4.28.1
      postgresql10-plperl-debuginfo-10.15-4.28.1
      postgresql10-plpython-10.15-4.28.1
      postgresql10-plpython-debuginfo-10.15-4.28.1
      postgresql10-pltcl-10.15-4.28.1
      postgresql10-pltcl-debuginfo-10.15-4.28.1
      postgresql10-server-10.15-4.28.1
      postgresql10-server-debuginfo-10.15-4.28.1

   - SUSE Linux Enterprise Server for SAP 15 (noarch):

      postgresql10-docs-10.15-4.28.1

   - SUSE Linux Enterprise Server for SAP 15 (x86_64):

      libpq5-32bit-10.15-4.28.1
      libpq5-32bit-debuginfo-10.15-4.28.1

   - SUSE Linux Enterprise Server 15-LTSS (aarch64 s390x):

      libecpg6-10.15-4.28.1
      libecpg6-debuginfo-10.15-4.28.1
      libpq5-10.15-4.28.1
      libpq5-debuginfo-10.15-4.28.1
      postgresql10-10.15-4.28.1
      postgresql10-contrib-10.15-4.28.1
      postgresql10-contrib-debuginfo-10.15-4.28.1
      postgresql10-debuginfo-10.15-4.28.1
      postgresql10-debugsource-10.15-4.28.1
      postgresql10-devel-10.15-4.28.1
      postgresql10-devel-debuginfo-10.15-4.28.1
      postgresql10-plperl-10.15-4.28.1
      postgresql10-plperl-debuginfo-10.15-4.28.1
      postgresql10-plpython-10.15-4.28.1
      postgresql10-plpython-debuginfo-10.15-4.28.1
      postgresql10-pltcl-10.15-4.28.1
      postgresql10-pltcl-debuginfo-10.15-4.28.1
      postgresql10-server-10.15-4.28.1
      postgresql10-server-debuginfo-10.15-4.28.1

   - SUSE Linux Enterprise Server 15-LTSS (noarch):

      postgresql10-docs-10.15-4.28.1

   - SUSE Linux Enterprise High Performance Computing 15-LTSS (aarch64 x86_64):

      libecpg6-10.15-4.28.1
      libecpg6-debuginfo-10.15-4.28.1
      libpq5-10.15-4.28.1
      libpq5-debuginfo-10.15-4.28.1
      postgresql10-10.15-4.28.1
      postgresql10-contrib-10.15-4.28.1
      postgresql10-contrib-debuginfo-10.15-4.28.1
      postgresql10-debuginfo-10.15-4.28.1
      postgresql10-debugsource-10.15-4.28.1
      postgresql10-devel-10.15-4.28.1
      postgresql10-devel-debuginfo-10.15-4.28.1
      postgresql10-plperl-10.15-4.28.1
      postgresql10-plperl-debuginfo-10.15-4.28.1
      postgresql10-plpython-10.15-4.28.1
      postgresql10-plpython-debuginfo-10.15-4.28.1
      postgresql10-pltcl-10.15-4.28.1
      postgresql10-pltcl-debuginfo-10.15-4.28.1
      postgresql10-server-10.15-4.28.1
      postgresql10-server-debuginfo-10.15-4.28.1

   - SUSE Linux Enterprise High Performance Computing 15-LTSS (x86_64):

      libpq5-32bit-10.15-4.28.1
      libpq5-32bit-debuginfo-10.15-4.28.1

   - SUSE Linux Enterprise High Performance Computing 15-LTSS (noarch):

      postgresql10-docs-10.15-4.28.1

   - SUSE Linux Enterprise High Performance Computing 15-ESPOS (aarch64 x86_64):

      libecpg6-10.15-4.28.1
      libecpg6-debuginfo-10.15-4.28.1
      libpq5-10.15-4.28.1
      libpq5-debuginfo-10.15-4.28.1
      postgresql10-10.15-4.28.1
      postgresql10-contrib-10.15-4.28.1
      postgresql10-contrib-debuginfo-10.15-4.28.1
      postgresql10-debuginfo-10.15-4.28.1
      postgresql10-debugsource-10.15-4.28.1
      postgresql10-devel-10.15-4.28.1
      postgresql10-devel-debuginfo-10.15-4.28.1
      postgresql10-plperl-10.15-4.28.1
      postgresql10-plperl-debuginfo-10.15-4.28.1
      postgresql10-plpython-10.15-4.28.1
      postgresql10-plpython-debuginfo-10.15-4.28.1
      postgresql10-pltcl-10.15-4.28.1
      postgresql10-pltcl-debuginfo-10.15-4.28.1
      postgresql10-server-10.15-4.28.1
      postgresql10-server-debuginfo-10.15-4.28.1

   - SUSE Linux Enterprise High Performance Computing 15-ESPOS (x86_64):

      libpq5-32bit-10.15-4.28.1
      libpq5-32bit-debuginfo-10.15-4.28.1

   - SUSE Linux Enterprise High Performance Computing 15-ESPOS (noarch):

      postgresql10-docs-10.15-4.28.1


References:

   https://www.suse.com/security/cve/CVE-2020-25694.html
   https://www.suse.com/security/cve/CVE-2020-25695.html
   https://www.suse.com/security/cve/CVE-2020-25696.html
   https://bugzilla.suse.com/1178666
   https://bugzilla.suse.com/1178667
   https://bugzilla.suse.com/1178668

SUSE: 2020:3455-1 important: postgresql10

November 20, 2020
An update that fixes three vulnerabilities is now available

Summary

This update for postgresql10 fixes the following issues: - Upgrade to version 10.15: * CVE-2020-25695, bsc#1178666: Block DECLARE CURSOR ... WITH HOLD and firing of deferred triggers within index expressions and materialized view queries. * CVE-2020-25694, bsc#1178667: a) Fix usage of complex connection-string parameters in pg_dump, pg_restore, clusterdb, reindexdb, and vacuumdb. b) When psql's \connect command re-uses connection parameters, ensure that all non-overridden parameters from a previous connection string are re-used. * CVE-2020-25696, bsc#1178668: Prevent psql's \gset command from modifying specially-treated variables. * Fix recently-added timetz test case so it works when the USA is not observing daylight savings time. * https://www.postgresql.org/about/news/postgresql-131-125-1110-1015-9620-and-9524-released-2111/ * https://www.postgresql.org/docs/10/release-10-15.html Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - SUSE Linux Enterprise Server for SAP 15: zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-2020-3455=1 - SUSE Linux Enterprise Server 15-LTSS: zypper in -t patch SUSE-SLE-Product-SLES-15-2020-3455=1 - SUSE Linux Enterprise High Performance Computing 15-LTSS: zypper in -t patch SUSE-SLE-Product-HPC-15-2020-3455=1 - SUSE Linux Enterprise High Performance Computing 15-ESPOS: zypper in -t patch SUSE-SLE-Product-HPC-15-2020-3455=1 Package List: - SUSE Linux Enterprise Server for SAP 15 (ppc64le x86_64): libecpg6-10.15-4.28.1 libecpg6-debuginfo-10.15-4.28.1 libpq5-10.15-4.28.1 libpq5-debuginfo-10.15-4.28.1 postgresql10-10.15-4.28.1 postgresql10-contrib-10.15-4.28.1 postgresql10-contrib-debuginfo-10.15-4.28.1 postgresql10-debuginfo-10.15-4.28.1 postgresql10-debugsource-10.15-4.28.1 postgresql10-devel-10.15-4.28.1 postgresql10-devel-debuginfo-10.15-4.28.1 postgresql10-plperl-10.15-4.28.1 postgresql10-plperl-debuginfo-10.15-4.28.1 postgresql10-plpython-10.15-4.28.1 postgresql10-plpython-debuginfo-10.15-4.28.1 postgresql10-pltcl-10.15-4.28.1 postgresql10-pltcl-debuginfo-10.15-4.28.1 postgresql10-server-10.15-4.28.1 postgresql10-server-debuginfo-10.15-4.28.1 - SUSE Linux Enterprise Server for SAP 15 (noarch): postgresql10-docs-10.15-4.28.1 - SUSE Linux Enterprise Server for SAP 15 (x86_64): libpq5-32bit-10.15-4.28.1 libpq5-32bit-debuginfo-10.15-4.28.1 - SUSE Linux Enterprise Server 15-LTSS (aarch64 s390x): libecpg6-10.15-4.28.1 libecpg6-debuginfo-10.15-4.28.1 libpq5-10.15-4.28.1 libpq5-debuginfo-10.15-4.28.1 postgresql10-10.15-4.28.1 postgresql10-contrib-10.15-4.28.1 postgresql10-contrib-debuginfo-10.15-4.28.1 postgresql10-debuginfo-10.15-4.28.1 postgresql10-debugsource-10.15-4.28.1 postgresql10-devel-10.15-4.28.1 postgresql10-devel-debuginfo-10.15-4.28.1 postgresql10-plperl-10.15-4.28.1 postgresql10-plperl-debuginfo-10.15-4.28.1 postgresql10-plpython-10.15-4.28.1 postgresql10-plpython-debuginfo-10.15-4.28.1 postgresql10-pltcl-10.15-4.28.1 postgresql10-pltcl-debuginfo-10.15-4.28.1 postgresql10-server-10.15-4.28.1 postgresql10-server-debuginfo-10.15-4.28.1 - SUSE Linux Enterprise Server 15-LTSS (noarch): postgresql10-docs-10.15-4.28.1 - SUSE Linux Enterprise High Performance Computing 15-LTSS (aarch64 x86_64): libecpg6-10.15-4.28.1 libecpg6-debuginfo-10.15-4.28.1 libpq5-10.15-4.28.1 libpq5-debuginfo-10.15-4.28.1 postgresql10-10.15-4.28.1 postgresql10-contrib-10.15-4.28.1 postgresql10-contrib-debuginfo-10.15-4.28.1 postgresql10-debuginfo-10.15-4.28.1 postgresql10-debugsource-10.15-4.28.1 postgresql10-devel-10.15-4.28.1 postgresql10-devel-debuginfo-10.15-4.28.1 postgresql10-plperl-10.15-4.28.1 postgresql10-plperl-debuginfo-10.15-4.28.1 postgresql10-plpython-10.15-4.28.1 postgresql10-plpython-debuginfo-10.15-4.28.1 postgresql10-pltcl-10.15-4.28.1 postgresql10-pltcl-debuginfo-10.15-4.28.1 postgresql10-server-10.15-4.28.1 postgresql10-server-debuginfo-10.15-4.28.1 - SUSE Linux Enterprise High Performance Computing 15-LTSS (x86_64): libpq5-32bit-10.15-4.28.1 libpq5-32bit-debuginfo-10.15-4.28.1 - SUSE Linux Enterprise High Performance Computing 15-LTSS (noarch): postgresql10-docs-10.15-4.28.1 - SUSE Linux Enterprise High Performance Computing 15-ESPOS (aarch64 x86_64): libecpg6-10.15-4.28.1 libecpg6-debuginfo-10.15-4.28.1 libpq5-10.15-4.28.1 libpq5-debuginfo-10.15-4.28.1 postgresql10-10.15-4.28.1 postgresql10-contrib-10.15-4.28.1 postgresql10-contrib-debuginfo-10.15-4.28.1 postgresql10-debuginfo-10.15-4.28.1 postgresql10-debugsource-10.15-4.28.1 postgresql10-devel-10.15-4.28.1 postgresql10-devel-debuginfo-10.15-4.28.1 postgresql10-plperl-10.15-4.28.1 postgresql10-plperl-debuginfo-10.15-4.28.1 postgresql10-plpython-10.15-4.28.1 postgresql10-plpython-debuginfo-10.15-4.28.1 postgresql10-pltcl-10.15-4.28.1 postgresql10-pltcl-debuginfo-10.15-4.28.1 postgresql10-server-10.15-4.28.1 postgresql10-server-debuginfo-10.15-4.28.1 - SUSE Linux Enterprise High Performance Computing 15-ESPOS (x86_64): libpq5-32bit-10.15-4.28.1 libpq5-32bit-debuginfo-10.15-4.28.1 - SUSE Linux Enterprise High Performance Computing 15-ESPOS (noarch): postgresql10-docs-10.15-4.28.1

References

#1178666 #1178667 #1178668

Cross- CVE-2020-25694 CVE-2020-25695 CVE-2020-25696

Affected Products:

SUSE Linux Enterprise Server for SAP 15

SUSE Linux Enterprise Server 15-LTSS

SUSE Linux Enterprise High Performance Computing 15-LTSS

SUSE Linux Enterprise High Performance Computing 15-ESPOS

https://www.suse.com/security/cve/CVE-2020-25694.html

https://www.suse.com/security/cve/CVE-2020-25695.html

https://www.suse.com/security/cve/CVE-2020-25696.html

https://bugzilla.suse.com/1178666

https://bugzilla.suse.com/1178667

https://bugzilla.suse.com/1178668

Severity
Announcement ID: SUSE-SU-2020:3455-1
Rating: important

Related News