SUSE Security Update: Security update for xen
______________________________________________________________________________

Announcement ID:    SUSE-SU-2020:3627-1
Rating:             important
References:         #1177409 #1177412 #1177413 #1177414 #1178591 
                    #1178963 
Cross-References:   CVE-2020-27670 CVE-2020-27671 CVE-2020-27672
                    CVE-2020-27674 CVE-2020-28368
Affected Products:
                    SUSE Linux Enterprise Server for SAP 15
                    SUSE Linux Enterprise High Performance Computing 15-LTSS
                    SUSE Linux Enterprise High Performance Computing 15-ESPOS
______________________________________________________________________________

   An update that solves 5 vulnerabilities and has one errata
   is now available.

Description:

   This update for xen fixes the following issues:

   - bsc#1178963 - VUL-0: xen: stack corruption from XSA-346 change (XSA-355)


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Server for SAP 15:

      zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-2020-3627=1

   - SUSE Linux Enterprise High Performance Computing 15-LTSS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-2020-3627=1

   - SUSE Linux Enterprise High Performance Computing 15-ESPOS:

      zypper in -t patch SUSE-SLE-Product-HPC-15-2020-3627=1



Package List:

   - SUSE Linux Enterprise Server for SAP 15 (x86_64):

      xen-4.10.4_22-3.50.1
      xen-debugsource-4.10.4_22-3.50.1
      xen-devel-4.10.4_22-3.50.1
      xen-libs-4.10.4_22-3.50.1
      xen-libs-debuginfo-4.10.4_22-3.50.1
      xen-tools-4.10.4_22-3.50.1
      xen-tools-debuginfo-4.10.4_22-3.50.1
      xen-tools-domU-4.10.4_22-3.50.1
      xen-tools-domU-debuginfo-4.10.4_22-3.50.1

   - SUSE Linux Enterprise High Performance Computing 15-LTSS (x86_64):

      xen-4.10.4_22-3.50.1
      xen-debugsource-4.10.4_22-3.50.1
      xen-devel-4.10.4_22-3.50.1
      xen-libs-4.10.4_22-3.50.1
      xen-libs-debuginfo-4.10.4_22-3.50.1
      xen-tools-4.10.4_22-3.50.1
      xen-tools-debuginfo-4.10.4_22-3.50.1
      xen-tools-domU-4.10.4_22-3.50.1
      xen-tools-domU-debuginfo-4.10.4_22-3.50.1

   - SUSE Linux Enterprise High Performance Computing 15-ESPOS (x86_64):

      xen-4.10.4_22-3.50.1
      xen-debugsource-4.10.4_22-3.50.1
      xen-devel-4.10.4_22-3.50.1
      xen-libs-4.10.4_22-3.50.1
      xen-libs-debuginfo-4.10.4_22-3.50.1
      xen-tools-4.10.4_22-3.50.1
      xen-tools-debuginfo-4.10.4_22-3.50.1
      xen-tools-domU-4.10.4_22-3.50.1
      xen-tools-domU-debuginfo-4.10.4_22-3.50.1


References:

   https://www.suse.com/security/cve/CVE-2020-27670.html
   https://www.suse.com/security/cve/CVE-2020-27671.html
   https://www.suse.com/security/cve/CVE-2020-27672.html
   https://www.suse.com/security/cve/CVE-2020-27674.html
   https://www.suse.com/security/cve/CVE-2020-28368.html
   https://bugzilla.suse.com/1177409
   https://bugzilla.suse.com/1177412
   https://bugzilla.suse.com/1177413
   https://bugzilla.suse.com/1177414
   https://bugzilla.suse.com/1178591
   https://bugzilla.suse.com/1178963