SUSE Container Update Advisory: suse/sles12sp5
-----------------------------------------------------------------
Container Advisory ID : SUSE-CU-2021:391-1
Container Tags        : suse/sles12sp5:6.5.241 , suse/sles12sp5:latest
Container Release     : 6.5.241
Severity              : moderate
Type                  : security
References            : 1186489 1187153 1187273 1188623 1190373 1190374 CVE-2021-22946
                        CVE-2021-22947 CVE-2021-33574 
-----------------------------------------------------------------

The container suse/sles12sp5 was updated. The following patches have been included in this update:

-----------------------------------------------------------------
Advisory ID: SUSE-SU-2021:3290-1
Released:    Wed Oct  6 16:44:45 2021
Summary:     Security update for glibc
Type:        security
Severity:    moderate
References:  1186489,CVE-2021-33574
This update for glibc fixes the following issues:

- CVE-2021-33574: Fixed a use-after-free possibility in mq_notify() (bsc#1186489)

-----------------------------------------------------------------
Advisory ID: SUSE-RU-2021:3329-1
Released:    Mon Oct 11 15:31:42 2021
Summary:     Recommended update for gcc11
Type:        recommended
Severity:    moderate
References:  1187153,1187273,1188623
This update for gcc11 fixes the following issues:

The additional GNU compiler collection GCC 11 is provided in the Toolchain
module, and updated compiler base libraries (libgcc_s1, libstdc++6 and
others) are being provided in the regular SUSE Linux Enterprise Server
repositories.

Changes done in GCC11 are documented on:

	https://gcc.gnu.org/gcc-11/changes.html

This update ships the C, C++, Objective C, D, Fortran, GO, and ADA compiler.

To select these compilers install the packages:

- gcc11
- gcc-c++11
- and others with 11 prefix.

to select them for building:

- CC='gcc-11'
- CXX='g++-11'


-----------------------------------------------------------------
Advisory ID: SUSE-SU-2021:3332-1
Released:    Mon Oct 11 17:02:35 2021
Summary:     Security update for curl
Type:        security
Severity:    moderate
References:  1190373,1190374,CVE-2021-22946,CVE-2021-22947
This update for curl fixes the following issues:


- CVE-2021-22947: Fixed STARTTLS protocol injection via MITM (bsc#1190374).
- CVE-2021-22946: Fixed protocol downgrade required TLS bypassed (bsc#1190373).