SUSE Security Update: Security update for lapack
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:0915-1
Rating:             moderate
References:         #1193562 
Cross-References:   CVE-2021-4048
CVSS scores:
                    CVE-2021-4048 (NVD) : 9.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
                    CVE-2021-4048 (SUSE): 4.7 CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:H

Affected Products:
                    SUSE Linux Enterprise Desktop 15-SP3
                    SUSE Linux Enterprise High Performance Computing 15-SP3
                    SUSE Linux Enterprise Module for Basesystem 15-SP3
                    SUSE Linux Enterprise Module for Development Tools 15-SP3
                    SUSE Linux Enterprise Realtime Extension 15-SP2
                    SUSE Linux Enterprise Server 15-SP3
                    SUSE Linux Enterprise Server for SAP Applications 15-SP3
                    SUSE Manager Proxy 4.2
                    SUSE Manager Server 4.2
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for lapack fixes the following issues:

   - CVE-2021-4048: Fixed an out of bounds read when user input was not
     validated properly (bsc#1193562).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Realtime Extension 15-SP2:

      zypper in -t patch SUSE-SLE-Product-RT-15-SP2-2022-915=1

   - SUSE Linux Enterprise Module for Development Tools 15-SP3:

      zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP3-2022-915=1

   - SUSE Linux Enterprise Module for Basesystem 15-SP3:

      zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP3-2022-915=1



Package List:

   - SUSE Linux Enterprise Realtime Extension 15-SP2 (x86_64):

      blas-devel-3.5.0-4.6.1
      lapack-debugsource-3.5.0-4.6.1
      lapack-devel-3.5.0-4.6.1
      libblas3-3.5.0-4.6.1
      libblas3-debuginfo-3.5.0-4.6.1
      liblapack3-3.5.0-4.6.1
      liblapack3-debuginfo-3.5.0-4.6.1
      liblapacke3-3.5.0-4.6.1
      liblapacke3-debuginfo-3.5.0-4.6.1

   - SUSE Linux Enterprise Module for Development Tools 15-SP3 (aarch64 ppc64le s390x x86_64):

      lapack-debugsource-3.5.0-4.6.1
      liblapacke3-3.5.0-4.6.1
      liblapacke3-debuginfo-3.5.0-4.6.1

   - SUSE Linux Enterprise Module for Basesystem 15-SP3 (aarch64 ppc64le s390x x86_64):

      blas-devel-3.5.0-4.6.1
      lapack-debugsource-3.5.0-4.6.1
      lapack-devel-3.5.0-4.6.1
      libblas3-3.5.0-4.6.1
      libblas3-debuginfo-3.5.0-4.6.1
      liblapack3-3.5.0-4.6.1
      liblapack3-debuginfo-3.5.0-4.6.1


References:

   https://www.suse.com/security/cve/CVE-2021-4048.html
   https://bugzilla.suse.com/1193562