SUSE Container Update Advisory: bci/nodejs
-----------------------------------------------------------------
Container Advisory ID : SUSE-CU-2022:1146-1
Container Tags        : bci/node:12 , bci/node:12-16.37 , bci/nodejs:12 , bci/nodejs:12-16.37
Container Release     : 16.37
Severity              : important
Type                  : security
References            : 1196490 1199132 CVE-2022-23308 CVE-2022-29824 
-----------------------------------------------------------------

The container bci/nodejs was updated. The following patches have been included in this update:

-----------------------------------------------------------------
Advisory ID: SUSE-SU-2022:1750-1
Released:    Thu May 19 15:28:20 2022
Summary:     Security update for libxml2
Type:        security
Severity:    important
References:  1196490,1199132,CVE-2022-23308,CVE-2022-29824
This update for libxml2 fixes the following issues:

- CVE-2022-23308: Fixed a use-after-free of ID and IDREF attributes (bsc#1196490).
- CVE-2022-29824: Fixed integer overflow that could have led to an out-of-bounds write in buf.c (xmlBuf*) and tree.c (xmlBuffer*) (bsc#1199132).


The following package changes have been done:

- libxml2-2-2.9.7-150000.3.46.1 updated
- container:sles15-image-15.0.0-17.17.1 updated