Discover Government News


   SUSE Security Update: Security update for GraphicsMagick
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:1274-1
Rating:             important
References:         #1198351 
Cross-References:   CVE-2022-1270
CVSS scores:
                    CVE-2022-1270 (SUSE): 7.3 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L

Affected Products:
                    openSUSE Leap 15.3
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for GraphicsMagick fixes the following issues:

   - CVE-2022-1270: Fixed a heap buffer overflow when parsing MIFF
     (bsc#1198351).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-1274=1

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2022-1274=1



Package List:

   - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

      GraphicsMagick-1.3.35-150300.3.3.1
      GraphicsMagick-debuginfo-1.3.35-150300.3.3.1
      GraphicsMagick-debugsource-1.3.35-150300.3.3.1
      GraphicsMagick-devel-1.3.35-150300.3.3.1
      libGraphicsMagick++-Q16-12-1.3.35-150300.3.3.1
      libGraphicsMagick++-Q16-12-debuginfo-1.3.35-150300.3.3.1
      libGraphicsMagick++-devel-1.3.35-150300.3.3.1
      libGraphicsMagick-Q16-3-1.3.35-150300.3.3.1
      libGraphicsMagick-Q16-3-debuginfo-1.3.35-150300.3.3.1
      libGraphicsMagick3-config-1.3.35-150300.3.3.1
      libGraphicsMagickWand-Q16-2-1.3.35-150300.3.3.1
      libGraphicsMagickWand-Q16-2-debuginfo-1.3.35-150300.3.3.1
      perl-GraphicsMagick-1.3.35-150300.3.3.1
      perl-GraphicsMagick-debuginfo-1.3.35-150300.3.3.1

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      GraphicsMagick-1.3.35-150300.3.3.1
      GraphicsMagick-debuginfo-1.3.35-150300.3.3.1
      GraphicsMagick-debugsource-1.3.35-150300.3.3.1
      GraphicsMagick-devel-1.3.35-150300.3.3.1
      libGraphicsMagick++-Q16-12-1.3.35-150300.3.3.1
      libGraphicsMagick++-Q16-12-debuginfo-1.3.35-150300.3.3.1
      libGraphicsMagick++-devel-1.3.35-150300.3.3.1
      libGraphicsMagick-Q16-3-1.3.35-150300.3.3.1
      libGraphicsMagick-Q16-3-debuginfo-1.3.35-150300.3.3.1
      libGraphicsMagick3-config-1.3.35-150300.3.3.1
      libGraphicsMagickWand-Q16-2-1.3.35-150300.3.3.1
      libGraphicsMagickWand-Q16-2-debuginfo-1.3.35-150300.3.3.1
      perl-GraphicsMagick-1.3.35-150300.3.3.1
      perl-GraphicsMagick-debuginfo-1.3.35-150300.3.3.1


References:

   https://www.suse.com/security/cve/CVE-2022-1270.html
   https://bugzilla.suse.com/1198351

SUSE: 2022:1274-1 important: GraphicsMagick

April 20, 2022
An update that fixes one vulnerability is now available

Summary

This update for GraphicsMagick fixes the following issues: - CVE-2022-1270: Fixed a heap buffer overflow when parsing MIFF (bsc#1198351). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.4: zypper in -t patch openSUSE-SLE-15.4-2022-1274=1 - openSUSE Leap 15.3: zypper in -t patch openSUSE-SLE-15.3-2022-1274=1 Package List: - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64): GraphicsMagick-1.3.35-150300.3.3.1 GraphicsMagick-debuginfo-1.3.35-150300.3.3.1 GraphicsMagick-debugsource-1.3.35-150300.3.3.1 GraphicsMagick-devel-1.3.35-150300.3.3.1 libGraphicsMagick++-Q16-12-1.3.35-150300.3.3.1 libGraphicsMagick++-Q16-12-debuginfo-1.3.35-150300.3.3.1 libGraphicsMagick++-devel-1.3.35-150300.3.3.1 libGraphicsMagick-Q16-3-1.3.35-150300.3.3.1 libGraphicsMagick-Q16-3-debuginfo-1.3.35-150300.3.3.1 libGraphicsMagick3-config-1.3.35-150300.3.3.1 libGraphicsMagickWand-Q16-2-1.3.35-150300.3.3.1 libGraphicsMagickWand-Q16-2-debuginfo-1.3.35-150300.3.3.1 perl-GraphicsMagick-1.3.35-150300.3.3.1 perl-GraphicsMagick-debuginfo-1.3.35-150300.3.3.1 - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64): GraphicsMagick-1.3.35-150300.3.3.1 GraphicsMagick-debuginfo-1.3.35-150300.3.3.1 GraphicsMagick-debugsource-1.3.35-150300.3.3.1 GraphicsMagick-devel-1.3.35-150300.3.3.1 libGraphicsMagick++-Q16-12-1.3.35-150300.3.3.1 libGraphicsMagick++-Q16-12-debuginfo-1.3.35-150300.3.3.1 libGraphicsMagick++-devel-1.3.35-150300.3.3.1 libGraphicsMagick-Q16-3-1.3.35-150300.3.3.1 libGraphicsMagick-Q16-3-debuginfo-1.3.35-150300.3.3.1 libGraphicsMagick3-config-1.3.35-150300.3.3.1 libGraphicsMagickWand-Q16-2-1.3.35-150300.3.3.1 libGraphicsMagickWand-Q16-2-debuginfo-1.3.35-150300.3.3.1 perl-GraphicsMagick-1.3.35-150300.3.3.1 perl-GraphicsMagick-debuginfo-1.3.35-150300.3.3.1

References

#1198351

Cross- CVE-2022-1270

CVSS scores:

CVE-2022-1270 (SUSE): 7.3 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L

Affected Products:

openSUSE Leap 15.3

openSUSE Leap 15.4

https://www.suse.com/security/cve/CVE-2022-1270.html

https://bugzilla.suse.com/1198351

Severity
Announcement ID: SUSE-SU-2022:1274-1
Rating: important

Related News