SUSE: 2022:1541-1 important: pgadmin4 | LinuxSecurity.com

   SUSE Security Update: Security update for pgadmin4
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:1541-1
Rating:             important
References:         #1197143 
Cross-References:   CVE-2022-0959
CVSS scores:
                    CVE-2022-0959 (NVD) : 6.5 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
                    CVE-2022-0959 (SUSE): 7.4 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:N

Affected Products:
                    SUSE Linux Enterprise High Performance Computing 15-SP3
                    SUSE Linux Enterprise High Performance Computing 15-SP4
                    SUSE Linux Enterprise Module for Server Applications 15-SP3
                    SUSE Linux Enterprise Module for Server Applications 15-SP4
                    SUSE Linux Enterprise Server 15-SP3
                    SUSE Linux Enterprise Server 15-SP4
                    SUSE Linux Enterprise Server for SAP Applications 15-SP3
                    SUSE Linux Enterprise Server for SAP Applications 15-SP4
                    SUSE Manager Proxy 4.2
                    SUSE Manager Server 4.2
                    openSUSE Leap 15.3
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for pgadmin4 fixes the following issues:

   - CVE-2022-0959: Fixed an unrestricted file upload (bsc#1197143).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-1541=1

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2022-1541=1

   - SUSE Linux Enterprise Module for Server Applications 15-SP4:

      zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP4-2022-1541=1

   - SUSE Linux Enterprise Module for Server Applications 15-SP3:

      zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP3-2022-1541=1



Package List:

   - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

      pgadmin4-4.30-150300.3.3.1
      pgadmin4-debuginfo-4.30-150300.3.3.1

   - openSUSE Leap 15.4 (noarch):

      pgadmin4-doc-4.30-150300.3.3.1
      pgadmin4-web-4.30-150300.3.3.1
      pgadmin4-web-uwsgi-4.30-150300.3.3.1

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      pgadmin4-4.30-150300.3.3.1
      pgadmin4-debuginfo-4.30-150300.3.3.1

   - openSUSE Leap 15.3 (noarch):

      pgadmin4-doc-4.30-150300.3.3.1
      pgadmin4-web-4.30-150300.3.3.1
      pgadmin4-web-uwsgi-4.30-150300.3.3.1

   - SUSE Linux Enterprise Module for Server Applications 15-SP4 (aarch64 ppc64le s390x x86_64):

      pgadmin4-4.30-150300.3.3.1
      pgadmin4-debuginfo-4.30-150300.3.3.1

   - SUSE Linux Enterprise Module for Server Applications 15-SP4 (noarch):

      pgadmin4-doc-4.30-150300.3.3.1
      pgadmin4-web-4.30-150300.3.3.1

   - SUSE Linux Enterprise Module for Server Applications 15-SP3 (aarch64 ppc64le s390x x86_64):

      pgadmin4-4.30-150300.3.3.1
      pgadmin4-debuginfo-4.30-150300.3.3.1

   - SUSE Linux Enterprise Module for Server Applications 15-SP3 (noarch):

      pgadmin4-doc-4.30-150300.3.3.1
      pgadmin4-web-4.30-150300.3.3.1


References:

   https://www.suse.com/security/cve/CVE-2022-0959.html
   https://bugzilla.suse.com/1197143

SUSE: 2022:1541-1 important: pgadmin4

May 4, 2022
An update that fixes one vulnerability is now available

Summary

This update for pgadmin4 fixes the following issues: - CVE-2022-0959: Fixed an unrestricted file upload (bsc#1197143). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.4: zypper in -t patch openSUSE-SLE-15.4-2022-1541=1 - openSUSE Leap 15.3: zypper in -t patch openSUSE-SLE-15.3-2022-1541=1 - SUSE Linux Enterprise Module for Server Applications 15-SP4: zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP4-2022-1541=1 - SUSE Linux Enterprise Module for Server Applications 15-SP3: zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP3-2022-1541=1 Package List: - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64): pgadmin4-4.30-150300.3.3.1 pgadmin4-debuginfo-4.30-150300.3.3.1 - openSUSE Leap 15.4 (noarch): pgadmin4-doc-4.30-150300.3.3.1 pgadmin4-web-4.30-150300.3.3.1 pgadmin4-web-uwsgi-4.30-150300.3.3.1 - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64): pgadmin4-4.30-150300.3.3.1 pgadmin4-debuginfo-4.30-150300.3.3.1 - openSUSE Leap 15.3 (noarch): pgadmin4-doc-4.30-150300.3.3.1 pgadmin4-web-4.30-150300.3.3.1 pgadmin4-web-uwsgi-4.30-150300.3.3.1 - SUSE Linux Enterprise Module for Server Applications 15-SP4 (aarch64 ppc64le s390x x86_64): pgadmin4-4.30-150300.3.3.1 pgadmin4-debuginfo-4.30-150300.3.3.1 - SUSE Linux Enterprise Module for Server Applications 15-SP4 (noarch): pgadmin4-doc-4.30-150300.3.3.1 pgadmin4-web-4.30-150300.3.3.1 - SUSE Linux Enterprise Module for Server Applications 15-SP3 (aarch64 ppc64le s390x x86_64): pgadmin4-4.30-150300.3.3.1 pgadmin4-debuginfo-4.30-150300.3.3.1 - SUSE Linux Enterprise Module for Server Applications 15-SP3 (noarch): pgadmin4-doc-4.30-150300.3.3.1 pgadmin4-web-4.30-150300.3.3.1

References

#1197143

Cross- CVE-2022-0959

CVSS scores:

CVE-2022-0959 (NVD) : 6.5 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

CVE-2022-0959 (SUSE): 7.4 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:N

Affected Products:

SUSE Linux Enterprise High Performance Computing 15-SP3

SUSE Linux Enterprise High Performance Computing 15-SP4

SUSE Linux Enterprise Module for Server Applications 15-SP3

SUSE Linux Enterprise Module for Server Applications 15-SP4

SUSE Linux Enterprise Server 15-SP3

SUSE Linux Enterprise Server 15-SP4

SUSE Linux Enterprise Server for SAP Applications 15-SP3

SUSE Linux Enterprise Server for SAP Applications 15-SP4

SUSE Manager Proxy 4.2

SUSE Manager Server 4.2

openSUSE Leap 15.3

openSUSE Leap 15.4

https://www.suse.com/security/cve/CVE-2022-0959.html

https://bugzilla.suse.com/1197143

Severity
Announcement ID: SUSE-SU-2022:1541-1
Rating: important

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.