SUSE Security Update: Security update for openldap2
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:1685-1
Rating:             important
References:         #1199240 
Cross-References:   CVE-2022-29155
CVSS scores:
                    CVE-2022-29155 (NVD) : 9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-29155 (SUSE): 9.4 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:H

Affected Products:
                    SUSE Linux Enterprise High Performance Computing
                    SUSE Linux Enterprise Module for Legacy Software 12
                    SUSE Linux Enterprise Server
                    SUSE Linux Enterprise Server for SAP 12-SP3
                    SUSE Linux Enterprise Server for SAP 12-SP4
                    SUSE Linux Enterprise Server for SAP 12-SP5
                    SUSE Linux Enterprise Server for SAP Applications
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for openldap2 fixes the following issues:

   - CVE-2022-29155: Fixed SQL injection in back-sql (bsc#1199240).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Server for SAP 12-SP5:

      zypper in -t patch SUSE-SLE-SAP-12-SP5-2022-1685=1

   - SUSE Linux Enterprise Server for SAP 12-SP4:

      zypper in -t patch SUSE-SLE-SAP-12-SP4-2022-1685=1

   - SUSE Linux Enterprise Server for SAP 12-SP3:

      zypper in -t patch SUSE-SLE-SAP-12-SP3-2022-1685=1

   - SUSE Linux Enterprise Module for Legacy Software 12:

      zypper in -t patch SUSE-SLE-Module-Legacy-12-2022-1685=1



Package List:

   - SUSE Linux Enterprise Server for SAP 12-SP5 (ppc64le x86_64):

      compat-libldap-2_3-0-2.3.37-42.1
      compat-libldap-2_3-0-debuginfo-2.3.37-42.1

   - SUSE Linux Enterprise Server for SAP 12-SP4 (ppc64le x86_64):

      compat-libldap-2_3-0-2.3.37-42.1
      compat-libldap-2_3-0-debuginfo-2.3.37-42.1

   - SUSE Linux Enterprise Server for SAP 12-SP3 (ppc64le x86_64):

      compat-libldap-2_3-0-2.3.37-42.1
      compat-libldap-2_3-0-debuginfo-2.3.37-42.1

   - SUSE Linux Enterprise Module for Legacy Software 12 (aarch64 ppc64le s390x x86_64):

      compat-libldap-2_3-0-2.3.37-42.1
      compat-libldap-2_3-0-debuginfo-2.3.37-42.1


References:

   https://www.suse.com/security/cve/CVE-2022-29155.html
   https://bugzilla.suse.com/1199240