SUSE: 2022:2082-1 important: the Linux Kernel | LinuxSecurity.com

   SUSE Security Update: Security update for the Linux Kernel
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:2082-1
Rating:             important
References:         #1051510 #1055710 #1065729 #1084513 #1087082 
                    #1126703 #1158266 #1173265 #1182171 #1183646 
                    #1183723 #1187055 #1191647 #1195651 #1196426 
                    #1197343 #1198031 #1198032 #1198516 #1198577 
                    #1198660 #1198687 #1198742 #1198962 #1198997 
                    #1199012 #1199063 #1199314 #1199426 #1199505 
                    #1199507 #1199605 #1199650 #1199785 #1200143 
                    #1200144 #1200249 
Cross-References:   CVE-2017-13695 CVE-2018-20784 CVE-2018-7755
                    CVE-2019-19377 CVE-2020-10769 CVE-2021-20292
                    CVE-2021-20321 CVE-2021-28688 CVE-2021-33061
                    CVE-2021-38208 CVE-2022-1011 CVE-2022-1184
                    CVE-2022-1353 CVE-2022-1419 CVE-2022-1516
                    CVE-2022-1652 CVE-2022-1729 CVE-2022-1734
                    CVE-2022-1974 CVE-2022-1975 CVE-2022-21123
                    CVE-2022-21125 CVE-2022-21127 CVE-2022-21166
                    CVE-2022-21180 CVE-2022-21499 CVE-2022-28388
                    CVE-2022-28390 CVE-2022-30594
CVSS scores:
                    CVE-2017-13695 (NVD) : 5.5 CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
                    CVE-2017-13695 (SUSE): 4 CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
                    CVE-2018-20784 (NVD) : 9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
                    CVE-2018-20784 (SUSE): 5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
                    CVE-2018-7755 (NVD) : 5.5 CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
                    CVE-2018-7755 (SUSE): 4 CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
                    CVE-2019-19377 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2019-19377 (SUSE): 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2020-10769 (NVD) : 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
                    CVE-2020-10769 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
                    CVE-2021-20292 (NVD) : 6.7 CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
                    CVE-2021-20292 (SUSE): 6.7 CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
                    CVE-2021-20321 (NVD) : 4.7 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H
                    CVE-2021-20321 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
                    CVE-2021-28688 (NVD) : 6.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H
                    CVE-2021-28688 (SUSE): 6.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H
                    CVE-2021-33061 (NVD) : 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
                    CVE-2021-33061 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
                    CVE-2021-38208 (NVD) : 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
                    CVE-2021-38208 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
                    CVE-2022-1011 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-1011 (SUSE): 7 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-1184 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
                    CVE-2022-1353 (NVD) : 7.1 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H
                    CVE-2022-1353 (SUSE): 6.1 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:H
                    CVE-2022-1419 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-1419 (SUSE): 6.7 CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-1516 (NVD) : 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
                    CVE-2022-1516 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
                    CVE-2022-1652 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-1652 (SUSE): 7 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-1729 (SUSE): 8.2 CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
                    CVE-2022-1734 (NVD) : 7 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-1734 (SUSE): 7.4 CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-1974 (SUSE): 6.8 CVSS:3.1/AV:A/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-1975 (SUSE): 4.5 CVSS:3.1/AV:A/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H
                    CVE-2022-21123 (SUSE): 6.1 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
                    CVE-2022-21125 (SUSE): 5.6 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N
                    CVE-2022-21127 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
                    CVE-2022-21166 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
                    CVE-2022-21180 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
                    CVE-2022-21499 (NVD) : 6.5 CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H
                    CVE-2022-21499 (SUSE): 8.4 CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-28388 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-28388 (SUSE): 5.3 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
                    CVE-2022-28390 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-28390 (SUSE): 5.3 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
                    CVE-2022-30594 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-30594 (SUSE): 8.4 CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Affected Products:
                    HPE Helion Openstack 8
                    SUSE Linux Enterprise High Availability 12-SP3
                    SUSE Linux Enterprise High Performance Computing 12-SP3
                    SUSE Linux Enterprise Server 12-SP3
                    SUSE Linux Enterprise Server 12-SP3-BCL
                    SUSE Linux Enterprise Server 12-SP3-LTSS
                    SUSE Linux Enterprise Server for SAP 12-SP3
                    SUSE OpenStack Cloud 8
                    SUSE OpenStack Cloud Crowbar 8
______________________________________________________________________________

   An update that solves 29 vulnerabilities and has 8 fixes is
   now available.

Description:


   The SUSE Linux Enterprise 12 SP3 kernel was updated to 3.12.31 to receive
   various security and bugfixes.

   The following security bugs were fixed:

   - CVE-2022-21127: Fixed a stale MMIO data transient which can be exploited
     to speculatively/transiently disclose information via spectre like
     attacks. (bsc#1199650)
   - CVE-2022-21123: Fixed a stale MMIO data transient which can be exploited
     to speculatively/transiently disclose information via spectre like
     attacks. (bsc#1199650)
   - CVE-2022-21125: Fixed a stale MMIO data transient which can be exploited
     to speculatively/transiently disclose information via spectre like
     attacks. (bsc#1199650)
   - CVE-2022-21180: Fixed a stale MMIO data transient which can be exploited
     to speculatively/transiently disclose information via spectre like
     attacks. (bsc#1199650)
   - CVE-2022-21166: Fixed a stale MMIO data transient which can be exploited
     to speculatively/transiently disclose information via spectre like
     attacks. (bsc#1199650)
   - CVE-2022-1975: Fixed a bug that allows an attacker to crash the linux
     kernel by simulating nfc device from user-space. (bsc#1200143)
   - CVE-2022-1974: Fixed an use-after-free that could causes kernel crash by
     simulating an nfc device from user-space. (bsc#1200144)
   - CVE-2019-19377: Fixed an user-after-free that could be triggered when an
     attacker mounts a crafted btrfs filesystem image. (bnc#1158266)
   - CVE-2022-1729: Fixed a sys_perf_event_open() race condition against self
     (bsc#1199507).
   - CVE-2022-1184: Fixed an use-after-free and memory errors in ext4 when
     mounting and operating on a corrupted image. (bsc#1198577)
   - CVE-2022-21499: Reinforce the kernel lockdown feature, until now it's
     been trivial to break out of it with kgdb or kdb. (bsc#1199426)
   - CVE-2017-13695: Fixed a bug that caused a stack dump allowing local
     users to obtain sensitive information from kernel memory and bypass the
     KASLR protection mechanism via a crafted ACPI table. (bnc#1055710)
   - CVE-2022-1652: Fixed a statically allocated error counter inside the
     floppy kernel module (bsc#1199063).
   - CVE-2022-1734: Fixed a r/w use-after-free when non synchronized between
     cleanup routine and firmware download routine. (bnc#1199605)
   - CVE-2022-30594: Fixed restriction bypass on setting the
     PT_SUSPEND_SECCOMP flag (bnc#1199505).
   - CVE-2021-28688: Fixed XSA-365 that includes initialization of pointers
     such that subsequent cleanup code wouldn't use uninitialized or stale
     values. This initialization went too far and may under certain
     conditions also overwrite pointers which are in need of cleaning up. The
     lack of cleanup would result in leaking persistent grants. The leak in
     turn would prevent fully cleaning up after a respective guest has died,
     leaving around zombie domains (bnc#1183646).
   - CVE-2020-10769: Fixed a buffer over-read flaw in the IPsec Cryptographic
     algorithm's module. This flaw allowed a local attacker with user
     privileges to cause a denial of service. (bnc#1173265)
   - CVE-2021-33061: Fixed insufficient control flow management for the
     Intel(R) 82599 Ethernet Controllers and Adapters that may have allowed
     an authenticated user to potentially enable denial of service via local
     access (bnc#1196426).
   - CVE-2022-1516: Fixed null-ptr-deref caused by x25_disconnect
     (bsc#1199012).
   - CVE-2021-20321: Fixed a race condition accessing file object in the
     OverlayFS subsystem in the way users do rename in specific way with
     OverlayFS. A local user could have used this flaw to crash the system
     (bnc#1191647).
   - CVE-2018-7755: Fixed an issue in the fd_locked_ioctl function in
     drivers/block/floppy.c. The floppy driver will copy a kernel pointer to
     user memory in response to the FDGETPRM ioctl. An attacker can send the
     FDGETPRM ioctl and use the obtained kernel pointer to discover the
     location of kernel code and data and bypass kernel security protections
     such as KASLR (bnc#1084513).
   - CVE-2022-1419: Fixed a concurrency use-after-free in
     vgem_gem_dumb_create (bsc#1198742).
   - CVE-2021-38208: Fixed a denial of service (NULL pointer dereference and
     BUG) by making a getsockname call after a certain type of failure of a
     bind call (bnc#1187055).
   - CVE-2022-1353: Fixed access controll to kernel memory in the
     pfkey_register function in net/key/af_key.c. (bnc#1198516)
   - CVE-2018-20784: Fixed a denial of service (infinite loop in
     update_blocked_averages) by mishandled leaf cfs_rq in
     kernel/sched/fair.c (bnc#1126703).
   - CVE-2021-20292: Fixed object validation prior to performing operations
     on the object in nouveau_sgdma_create_ttm in Nouveau DRM subsystem
     (bnc#1183723).
   - CVE-2022-28390: Fixed a double free in drivers/net/can/usb/ems_usb.c
     vulnerability in the Linux kernel (bnc#1198031).
   - CVE-2022-28388: Fixed a double free in drivers/net/can/usb/usb_8dev.c
     vulnerability in the Linux kernel (bnc#1198032).
   - CVE-2022-1011: Fixed an use-after-free vulnerability which could allow a
     local attacker to retireve (partial) /etc/shadow hashes or any other
     data from filesystem when he can mount a FUSE filesystems. (bnc#1197343)

   The following non-security bugs were fixed:

   - btrfs: tree-checker: fix incorrect printk format (bsc#1200249).
   - net: mana: Add handling of CQE_RX_TRUNCATED (bsc#1195651).
   - net: mana: Remove unnecessary check of cqe_type in mana_process_rx_cqe()
     (bsc#1195651).
   - PCI: hv: Do not set PCI_COMMAND_MEMORY to reduce VM boot time
     (bsc#1199314).
   - powerpc/pseries: extract host bridge from pci_bus prior to bus removal
     (bsc#1182171 ltc#190900 bsc#1198660 ltc#197803).
   - powerpc/pseries: Fix use after free in remove_phb_dynamic() (bsc#1065729
     bsc#1198660 ltc#197803).
   - vmbus: do not return values for uninitalized channels (bsc#1051510
     bsc#1198997).
   - vt: vt_ioctl: fix race in VT_RESIZEX (bsc#1199785).
   - x86/hyperv: Read TSC frequency from a synthetic MSR (bsc#1198962).
   - x86/speculation: Fix redundant MDS mitigation message (bsc#1199650).


Special Instructions and Notes:

   Please reboot the system after installing this update.

Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE OpenStack Cloud Crowbar 8:

      zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-8-2022-2082=1

   - SUSE OpenStack Cloud 8:

      zypper in -t patch SUSE-OpenStack-Cloud-8-2022-2082=1

   - SUSE Linux Enterprise Server for SAP 12-SP3:

      zypper in -t patch SUSE-SLE-SAP-12-SP3-2022-2082=1

   - SUSE Linux Enterprise Server 12-SP3-LTSS:

      zypper in -t patch SUSE-SLE-SERVER-12-SP3-2022-2082=1

   - SUSE Linux Enterprise Server 12-SP3-BCL:

      zypper in -t patch SUSE-SLE-SERVER-12-SP3-BCL-2022-2082=1

   - SUSE Linux Enterprise High Availability 12-SP3:

      zypper in -t patch SUSE-SLE-HA-12-SP3-2022-2082=1

   - HPE Helion Openstack 8:

      zypper in -t patch HPE-Helion-OpenStack-8-2022-2082=1



Package List:

   - SUSE OpenStack Cloud Crowbar 8 (noarch):

      kernel-devel-4.4.180-94.164.2
      kernel-macros-4.4.180-94.164.2
      kernel-source-4.4.180-94.164.2

   - SUSE OpenStack Cloud Crowbar 8 (x86_64):

      kernel-default-4.4.180-94.164.3
      kernel-default-base-4.4.180-94.164.3
      kernel-default-base-debuginfo-4.4.180-94.164.3
      kernel-default-debuginfo-4.4.180-94.164.3
      kernel-default-debugsource-4.4.180-94.164.3
      kernel-default-devel-4.4.180-94.164.3
      kernel-default-kgraft-4.4.180-94.164.3
      kernel-syms-4.4.180-94.164.2
      kgraft-patch-4_4_180-94_164-default-1-4.3.2
      kgraft-patch-4_4_180-94_164-default-debuginfo-1-4.3.2

   - SUSE OpenStack Cloud 8 (noarch):

      kernel-devel-4.4.180-94.164.2
      kernel-macros-4.4.180-94.164.2
      kernel-source-4.4.180-94.164.2

   - SUSE OpenStack Cloud 8 (x86_64):

      kernel-default-4.4.180-94.164.3
      kernel-default-base-4.4.180-94.164.3
      kernel-default-base-debuginfo-4.4.180-94.164.3
      kernel-default-debuginfo-4.4.180-94.164.3
      kernel-default-debugsource-4.4.180-94.164.3
      kernel-default-devel-4.4.180-94.164.3
      kernel-default-kgraft-4.4.180-94.164.3
      kernel-syms-4.4.180-94.164.2
      kgraft-patch-4_4_180-94_164-default-1-4.3.2
      kgraft-patch-4_4_180-94_164-default-debuginfo-1-4.3.2

   - SUSE Linux Enterprise Server for SAP 12-SP3 (ppc64le x86_64):

      kernel-default-4.4.180-94.164.3
      kernel-default-base-4.4.180-94.164.3
      kernel-default-base-debuginfo-4.4.180-94.164.3
      kernel-default-debuginfo-4.4.180-94.164.3
      kernel-default-debugsource-4.4.180-94.164.3
      kernel-default-devel-4.4.180-94.164.3
      kernel-default-kgraft-4.4.180-94.164.3
      kernel-syms-4.4.180-94.164.2
      kgraft-patch-4_4_180-94_164-default-1-4.3.2

   - SUSE Linux Enterprise Server for SAP 12-SP3 (x86_64):

      kgraft-patch-4_4_180-94_164-default-debuginfo-1-4.3.2

   - SUSE Linux Enterprise Server for SAP 12-SP3 (noarch):

      kernel-devel-4.4.180-94.164.2
      kernel-macros-4.4.180-94.164.2
      kernel-source-4.4.180-94.164.2

   - SUSE Linux Enterprise Server 12-SP3-LTSS (aarch64 ppc64le s390x x86_64):

      kernel-default-4.4.180-94.164.3
      kernel-default-base-4.4.180-94.164.3
      kernel-default-base-debuginfo-4.4.180-94.164.3
      kernel-default-debuginfo-4.4.180-94.164.3
      kernel-default-debugsource-4.4.180-94.164.3
      kernel-default-devel-4.4.180-94.164.3
      kernel-syms-4.4.180-94.164.2

   - SUSE Linux Enterprise Server 12-SP3-LTSS (ppc64le x86_64):

      kernel-default-kgraft-4.4.180-94.164.3
      kgraft-patch-4_4_180-94_164-default-1-4.3.2

   - SUSE Linux Enterprise Server 12-SP3-LTSS (x86_64):

      kgraft-patch-4_4_180-94_164-default-debuginfo-1-4.3.2

   - SUSE Linux Enterprise Server 12-SP3-LTSS (noarch):

      kernel-devel-4.4.180-94.164.2
      kernel-macros-4.4.180-94.164.2
      kernel-source-4.4.180-94.164.2

   - SUSE Linux Enterprise Server 12-SP3-LTSS (s390x):

      kernel-default-man-4.4.180-94.164.3

   - SUSE Linux Enterprise Server 12-SP3-BCL (noarch):

      kernel-devel-4.4.180-94.164.2
      kernel-macros-4.4.180-94.164.2
      kernel-source-4.4.180-94.164.2

   - SUSE Linux Enterprise Server 12-SP3-BCL (x86_64):

      kernel-default-4.4.180-94.164.3
      kernel-default-base-4.4.180-94.164.3
      kernel-default-base-debuginfo-4.4.180-94.164.3
      kernel-default-debuginfo-4.4.180-94.164.3
      kernel-default-debugsource-4.4.180-94.164.3
      kernel-default-devel-4.4.180-94.164.3
      kernel-syms-4.4.180-94.164.2

   - SUSE Linux Enterprise High Availability 12-SP3 (ppc64le s390x x86_64):

      cluster-md-kmp-default-4.4.180-94.164.3
      cluster-md-kmp-default-debuginfo-4.4.180-94.164.3
      dlm-kmp-default-4.4.180-94.164.3
      dlm-kmp-default-debuginfo-4.4.180-94.164.3
      gfs2-kmp-default-4.4.180-94.164.3
      gfs2-kmp-default-debuginfo-4.4.180-94.164.3
      kernel-default-debuginfo-4.4.180-94.164.3
      kernel-default-debugsource-4.4.180-94.164.3
      ocfs2-kmp-default-4.4.180-94.164.3
      ocfs2-kmp-default-debuginfo-4.4.180-94.164.3

   - HPE Helion Openstack 8 (x86_64):

      kernel-default-4.4.180-94.164.3
      kernel-default-base-4.4.180-94.164.3
      kernel-default-base-debuginfo-4.4.180-94.164.3
      kernel-default-debuginfo-4.4.180-94.164.3
      kernel-default-debugsource-4.4.180-94.164.3
      kernel-default-devel-4.4.180-94.164.3
      kernel-default-kgraft-4.4.180-94.164.3
      kernel-syms-4.4.180-94.164.2
      kgraft-patch-4_4_180-94_164-default-1-4.3.2
      kgraft-patch-4_4_180-94_164-default-debuginfo-1-4.3.2

   - HPE Helion Openstack 8 (noarch):

      kernel-devel-4.4.180-94.164.2
      kernel-macros-4.4.180-94.164.2
      kernel-source-4.4.180-94.164.2


References:

   https://www.suse.com/security/cve/CVE-2017-13695.html
   https://www.suse.com/security/cve/CVE-2018-20784.html
   https://www.suse.com/security/cve/CVE-2018-7755.html
   https://www.suse.com/security/cve/CVE-2019-19377.html
   https://www.suse.com/security/cve/CVE-2020-10769.html
   https://www.suse.com/security/cve/CVE-2021-20292.html
   https://www.suse.com/security/cve/CVE-2021-20321.html
   https://www.suse.com/security/cve/CVE-2021-28688.html
   https://www.suse.com/security/cve/CVE-2021-33061.html
   https://www.suse.com/security/cve/CVE-2021-38208.html
   https://www.suse.com/security/cve/CVE-2022-1011.html
   https://www.suse.com/security/cve/CVE-2022-1184.html
   https://www.suse.com/security/cve/CVE-2022-1353.html
   https://www.suse.com/security/cve/CVE-2022-1419.html
   https://www.suse.com/security/cve/CVE-2022-1516.html
   https://www.suse.com/security/cve/CVE-2022-1652.html
   https://www.suse.com/security/cve/CVE-2022-1729.html
   https://www.suse.com/security/cve/CVE-2022-1734.html
   https://www.suse.com/security/cve/CVE-2022-1974.html
   https://www.suse.com/security/cve/CVE-2022-1975.html
   https://www.suse.com/security/cve/CVE-2022-21123.html
   https://www.suse.com/security/cve/CVE-2022-21125.html
   https://www.suse.com/security/cve/CVE-2022-21127.html
   https://www.suse.com/security/cve/CVE-2022-21166.html
   https://www.suse.com/security/cve/CVE-2022-21180.html
   https://www.suse.com/security/cve/CVE-2022-21499.html
   https://www.suse.com/security/cve/CVE-2022-28388.html
   https://www.suse.com/security/cve/CVE-2022-28390.html
   https://www.suse.com/security/cve/CVE-2022-30594.html
   https://bugzilla.suse.com/1051510
   https://bugzilla.suse.com/1055710
   https://bugzilla.suse.com/1065729
   https://bugzilla.suse.com/1084513
   https://bugzilla.suse.com/1087082
   https://bugzilla.suse.com/1126703
   https://bugzilla.suse.com/1158266
   https://bugzilla.suse.com/1173265
   https://bugzilla.suse.com/1182171
   https://bugzilla.suse.com/1183646
   https://bugzilla.suse.com/1183723
   https://bugzilla.suse.com/1187055
   https://bugzilla.suse.com/1191647
   https://bugzilla.suse.com/1195651
   https://bugzilla.suse.com/1196426
   https://bugzilla.suse.com/1197343
   https://bugzilla.suse.com/1198031
   https://bugzilla.suse.com/1198032
   https://bugzilla.suse.com/1198516
   https://bugzilla.suse.com/1198577
   https://bugzilla.suse.com/1198660
   https://bugzilla.suse.com/1198687
   https://bugzilla.suse.com/1198742
   https://bugzilla.suse.com/1198962
   https://bugzilla.suse.com/1198997
   https://bugzilla.suse.com/1199012
   https://bugzilla.suse.com/1199063
   https://bugzilla.suse.com/1199314
   https://bugzilla.suse.com/1199426
   https://bugzilla.suse.com/1199505
   https://bugzilla.suse.com/1199507
   https://bugzilla.suse.com/1199605
   https://bugzilla.suse.com/1199650
   https://bugzilla.suse.com/1199785
   https://bugzilla.suse.com/1200143
   https://bugzilla.suse.com/1200144
   https://bugzilla.suse.com/1200249

SUSE: 2022:2082-1 important: the Linux Kernel

June 14, 2022
An update that solves 29 vulnerabilities and has 8 fixes is now available

Summary

The SUSE Linux Enterprise 12 SP3 kernel was updated to 3.12.31 to receive various security and bugfixes. The following security bugs were fixed: - CVE-2022-21127: Fixed a stale MMIO data transient which can be exploited to speculatively/transiently disclose information via spectre like attacks. (bsc#1199650) - CVE-2022-21123: Fixed a stale MMIO data transient which can be exploited to speculatively/transiently disclose information via spectre like attacks. (bsc#1199650) - CVE-2022-21125: Fixed a stale MMIO data transient which can be exploited to speculatively/transiently disclose information via spectre like attacks. (bsc#1199650) - CVE-2022-21180: Fixed a stale MMIO data transient which can be exploited to speculatively/transiently disclose information via spectre like attacks. (bsc#1199650) - CVE-2022-21166: Fixed a stale MMIO data transient which can be exploited to speculatively/transiently disclose information via spectre like attacks. (bsc#1199650) - CVE-2022-1975: Fixed a bug that allows an attacker to crash the linux kernel by simulating nfc device from user-space. (bsc#1200143) - CVE-2022-1974: Fixed an use-after-free that could causes kernel crash by simulating an nfc device from user-space. (bsc#1200144) - CVE-2019-19377: Fixed an user-after-free that could be triggered when an attacker mounts a crafted btrfs filesystem image. (bnc#1158266) - CVE-2022-1729: Fixed a sys_perf_event_open() race condition against self (bsc#1199507). - CVE-2022-1184: Fixed an use-after-free and memory errors in ext4 when mounting and operating on a corrupted image. (bsc#1198577) - CVE-2022-21499: Reinforce the kernel lockdown feature, until now it's been trivial to break out of it with kgdb or kdb. (bsc#1199426) - CVE-2017-13695: Fixed a bug that caused a stack dump allowing local users to obtain sensitive information from kernel memory and bypass the KASLR protection mechanism via a crafted ACPI table. (bnc#1055710) - CVE-2022-1652: Fixed a statically allocated error counter inside the floppy kernel module (bsc#1199063). - CVE-2022-1734: Fixed a r/w use-after-free when non synchronized between cleanup routine and firmware download routine. (bnc#1199605) - CVE-2022-30594: Fixed restriction bypass on setting the PT_SUSPEND_SECCOMP flag (bnc#1199505). - CVE-2021-28688: Fixed XSA-365 that includes initialization of pointers such that subsequent cleanup code wouldn't use uninitialized or stale values. This initialization went too far and may under certain conditions also overwrite pointers which are in need of cleaning up. The lack of cleanup would result in leaking persistent grants. The leak in turn would prevent fully cleaning up after a respective guest has died, leaving around zombie domains (bnc#1183646). - CVE-2020-10769: Fixed a buffer over-read flaw in the IPsec Cryptographic algorithm's module. This flaw allowed a local attacker with user privileges to cause a denial of service. (bnc#1173265) - CVE-2021-33061: Fixed insufficient control flow management for the Intel(R) 82599 Ethernet Controllers and Adapters that may have allowed an authenticated user to potentially enable denial of service via local access (bnc#1196426). - CVE-2022-1516: Fixed null-ptr-deref caused by x25_disconnect (bsc#1199012). - CVE-2021-20321: Fixed a race condition accessing file object in the OverlayFS subsystem in the way users do rename in specific way with OverlayFS. A local user could have used this flaw to crash the system (bnc#1191647). - CVE-2018-7755: Fixed an issue in the fd_locked_ioctl function in drivers/block/floppy.c. The floppy driver will copy a kernel pointer to user memory in response to the FDGETPRM ioctl. An attacker can send the FDGETPRM ioctl and use the obtained kernel pointer to discover the location of kernel code and data and bypass kernel security protections such as KASLR (bnc#1084513). - CVE-2022-1419: Fixed a concurrency use-after-free in vgem_gem_dumb_create (bsc#1198742). - CVE-2021-38208: Fixed a denial of service (NULL pointer dereference and BUG) by making a getsockname call after a certain type of failure of a bind call (bnc#1187055). - CVE-2022-1353: Fixed access controll to kernel memory in the pfkey_register function in net/key/af_key.c. (bnc#1198516) - CVE-2018-20784: Fixed a denial of service (infinite loop in update_blocked_averages) by mishandled leaf cfs_rq in kernel/sched/fair.c (bnc#1126703). - CVE-2021-20292: Fixed object validation prior to performing operations on the object in nouveau_sgdma_create_ttm in Nouveau DRM subsystem (bnc#1183723). - CVE-2022-28390: Fixed a double free in drivers/net/can/usb/ems_usb.c vulnerability in the Linux kernel (bnc#1198031). - CVE-2022-28388: Fixed a double free in drivers/net/can/usb/usb_8dev.c vulnerability in the Linux kernel (bnc#1198032). - CVE-2022-1011: Fixed an use-after-free vulnerability which could allow a local attacker to retireve (partial) /etc/shadow hashes or any other data from filesystem when he can mount a FUSE filesystems. (bnc#1197343) The following non-security bugs were fixed: - btrfs: tree-checker: fix incorrect printk format (bsc#1200249). - net: mana: Add handling of CQE_RX_TRUNCATED (bsc#1195651). - net: mana: Remove unnecessary check of cqe_type in mana_process_rx_cqe() (bsc#1195651). - PCI: hv: Do not set PCI_COMMAND_MEMORY to reduce VM boot time (bsc#1199314). - powerpc/pseries: extract host bridge from pci_bus prior to bus removal (bsc#1182171 ltc#190900 bsc#1198660 ltc#197803). - powerpc/pseries: Fix use after free in remove_phb_dynamic() (bsc#1065729 bsc#1198660 ltc#197803). - vmbus: do not return values for uninitalized channels (bsc#1051510 bsc#1198997). - vt: vt_ioctl: fix race in VT_RESIZEX (bsc#1199785). - x86/hyperv: Read TSC frequency from a synthetic MSR (bsc#1198962). - x86/speculation: Fix redundant MDS mitigation message (bsc#1199650).

References

#1051510 #1055710 #1065729 #1084513 #1087082

#1126703 #1158266 #1173265 #1182171 #1183646

#1183723 #1187055 #1191647 #1195651 #1196426

#1197343 #1198031 #1198032 #1198516 #1198577

#1198660 #1198687 #1198742 #1198962 #1198997

#1199012 #1199063 #1199314 #1199426 #1199505

#1199507 #1199605 #1199650 #1199785 #1200143

#1200144 #1200249

Cross- CVE-2017-13695 CVE-2018-20784 CVE-2018-7755

CVE-2019-19377 CVE-2020-10769 CVE-2021-20292

CVE-2021-20321 CVE-2021-28688 CVE-2021-33061

CVE-2021-38208 CVE-2022-1011 CVE-2022-1184

CVE-2022-1353 CVE-2022-1419 CVE-2022-1516

CVE-2022-1652 CVE-2022-1729 CVE-2022-1734

CVE-2022-1974 CVE-2022-1975 CVE-2022-21123

CVE-2022-21125 CVE-2022-21127 CVE-2022-21166

CVE-2022-21180 CVE-2022-21499 CVE-2022-28388

CVE-2022-28390 CVE-2022-30594

CVSS scores:

CVE-2017-13695 (NVD) : 5.5 CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

CVE-2017-13695 (SUSE): 4 CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

CVE-2018-20784 (NVD) : 9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

CVE-2018-20784 (SUSE): 5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

CVE-2018-7755 (NVD) : 5.5 CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

CVE-2018-7755 (SUSE): 4 CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

CVE-2019-19377 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

CVE-2019-19377 (SUSE): 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

CVE-2020-10769 (NVD) : 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

CVE-2020-10769 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

CVE-2021-20292 (NVD) : 6.7 CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

CVE-2021-20292 (SUSE): 6.7 CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

CVE-2021-20321 (NVD) : 4.7 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H

CVE-2021-20321 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

CVE-2021-28688 (NVD) : 6.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H

CVE-2021-28688 (SUSE): 6.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H

CVE-2021-33061 (NVD) : 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

CVE-2021-33061 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

CVE-2021-38208 (NVD) : 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

CVE-2021-38208 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

CVE-2022-1011 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

CVE-2022-1011 (SUSE): 7 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

CVE-2022-1184 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

CVE-2022-1353 (NVD) : 7.1 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H

CVE-2022-1353 (SUSE): 6.1 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:H

CVE-2022-1419 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

CVE-2022-1419 (SUSE): 6.7 CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

CVE-2022-1516 (NVD) : 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

CVE-2022-1516 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

CVE-2022-1652 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

CVE-2022-1652 (SUSE): 7 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

CVE-2022-1729 (SUSE): 8.2 CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H

CVE-2022-1734 (NVD) : 7 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

CVE-2022-1734 (SUSE): 7.4 CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

CVE-2022-1974 (SUSE): 6.8 CVSS:3.1/AV:A/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

CVE-2022-1975 (SUSE): 4.5 CVSS:3.1/AV:A/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H

CVE-2022-21123 (SUSE): 6.1 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N

CVE-2022-21125 (SUSE): 5.6 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N

CVE-2022-21127 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

CVE-2022-21166 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

CVE-2022-21180 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

CVE-2022-21499 (NVD) : 6.5 CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H

CVE-2022-21499 (SUSE): 8.4 CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

CVE-2022-28388 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

CVE-2022-28388 (SUSE): 5.3 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L

CVE-2022-28390 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

CVE-2022-28390 (SUSE): 5.3 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L

CVE-2022-30594 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

CVE-2022-30594 (SUSE): 8.4 CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Affected Products:

HPE Helion Openstack 8

SUSE Linux Enterprise High Availability 12-SP3

SUSE Linux Enterprise High Performance Computing 12-SP3

SUSE Linux Enterprise Server 12-SP3

SUSE Linux Enterprise Server 12-SP3-BCL

SUSE Linux Enterprise Server 12-SP3-LTSS

SUSE Linux Enterprise Server for SAP 12-SP3

SUSE OpenStack Cloud 8

SUSE OpenStack Cloud Crowbar 8

https://www.suse.com/security/cve/CVE-2017-13695.html

https://www.suse.com/security/cve/CVE-2018-20784.html

https://www.suse.com/security/cve/CVE-2018-7755.html

https://www.suse.com/security/cve/CVE-2019-19377.html

https://www.suse.com/security/cve/CVE-2020-10769.html

https://www.suse.com/security/cve/CVE-2021-20292.html

https://www.suse.com/security/cve/CVE-2021-20321.html

https://www.suse.com/security/cve/CVE-2021-28688.html

https://www.suse.com/security/cve/CVE-2021-33061.html

https://www.suse.com/security/cve/CVE-2021-38208.html

https://www.suse.com/security/cve/CVE-2022-1011.html

https://www.suse.com/security/cve/CVE-2022-1184.html

https://www.suse.com/security/cve/CVE-2022-1353.html

https://www.suse.com/security/cve/CVE-2022-1419.html

https://www.suse.com/security/cve/CVE-2022-1516.html

https://www.suse.com/security/cve/CVE-2022-1652.html

https://www.suse.com/security/cve/CVE-2022-1729.html

https://www.suse.com/security/cve/CVE-2022-1734.html

https://www.suse.com/security/cve/CVE-2022-1974.html

https://www.suse.com/security/cve/CVE-2022-1975.html

https://www.suse.com/security/cve/CVE-2022-21123.html

https://www.suse.com/security/cve/CVE-2022-21125.html

https://www.suse.com/security/cve/CVE-2022-21127.html

https://www.suse.com/security/cve/CVE-2022-21166.html

https://www.suse.com/security/cve/CVE-2022-21180.html

https://www.suse.com/security/cve/CVE-2022-21499.html

https://www.suse.com/security/cve/CVE-2022-28388.html

https://www.suse.com/security/cve/CVE-2022-28390.html

https://www.suse.com/security/cve/CVE-2022-30594.html

https://bugzilla.suse.com/1051510

https://bugzilla.suse.com/1055710

https://bugzilla.suse.com/1065729

https://bugzilla.suse.com/1084513

https://bugzilla.suse.com/1087082

https://bugzilla.suse.com/1126703

https://bugzilla.suse.com/1158266

https://bugzilla.suse.com/1173265

https://bugzilla.suse.com/1182171

https://bugzilla.suse.com/1183646

https://bugzilla.suse.com/1183723

https://bugzilla.suse.com/1187055

https://bugzilla.suse.com/1191647

https://bugzilla.suse.com/1195651

https://bugzilla.suse.com/1196426

https://bugzilla.suse.com/1197343

https://bugzilla.suse.com/1198031

https://bugzilla.suse.com/1198032

https://bugzilla.suse.com/1198516

https://bugzilla.suse.com/1198577

https://bugzilla.suse.com/1198660

https://bugzilla.suse.com/1198687

https://bugzilla.suse.com/1198742

https://bugzilla.suse.com/1198962

https://bugzilla.suse.com/1198997

https://bugzilla.suse.com/1199012

https://bugzilla.suse.com/1199063

https://bugzilla.suse.com/1199314

https://bugzilla.suse.com/1199426

https://bugzilla.suse.com/1199505

https://bugzilla.suse.com/1199507

https://bugzilla.suse.com/1199605

https://bugzilla.suse.com/1199650

https://bugzilla.suse.com/1199785

https://bugzilla.suse.com/1200143

https://bugzilla.suse.com/1200144

https://bugzilla.suse.com/1200249

Severity
Announcement ID: SUSE-SU-2022:2082-1
Rating: important

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.