SUSE: 2022:2154-1 important: salt | LinuxSecurity.com

   SUSE Security Update: Security update for salt
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:2154-1
Rating:             important
References:         #1200566 
Cross-References:   CVE-2022-22967
CVSS scores:
                    CVE-2022-22967 (SUSE): 7.5 CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Affected Products:
                    SUSE Linux Enterprise High Performance Computing 12
                    SUSE Linux Enterprise Module for Advanced Systems Management 12
                    SUSE Linux Enterprise Server 12
                    SUSE Linux Enterprise Server 12-SP3
                    SUSE Linux Enterprise Server 12-SP4
                    SUSE Linux Enterprise Server 12-SP5
                    SUSE Linux Enterprise Server for SAP Applications 12
                    SUSE Linux Enterprise Server for SAP Applications 12-SP3
                    SUSE Linux Enterprise Server for SAP Applications 12-SP4
                    SUSE Linux Enterprise Server for SAP Applications 12-SP5
                    SUSE Manager Tools 12
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for salt fixes the following issues:

   - CVE-2022-22967: Fixed missing check for PAM_ACCT_MGM return value that
     could lead to authentication bypass when using PAM (bsc#1200566)


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE Manager Tools 12:

      zypper in -t patch SUSE-SLE-Manager-Tools-12-2022-2154=1

   - SUSE Linux Enterprise Module for Advanced Systems Management 12:

      zypper in -t patch SUSE-SLE-Module-Adv-Systems-Management-12-2022-2154=1



Package List:

   - SUSE Manager Tools 12 (aarch64 ppc64le s390x x86_64):

      python2-salt-3000-65.1
      python3-salt-3000-65.1
      salt-3000-65.1
      salt-doc-3000-65.1
      salt-minion-3000-65.1

   - SUSE Linux Enterprise Module for Advanced Systems Management 12 (ppc64le s390x x86_64):

      python2-salt-3000-65.1
      salt-3000-65.1
      salt-api-3000-65.1
      salt-cloud-3000-65.1
      salt-doc-3000-65.1
      salt-master-3000-65.1
      salt-minion-3000-65.1
      salt-proxy-3000-65.1
      salt-ssh-3000-65.1
      salt-standalone-formulas-configuration-3000-65.1
      salt-syndic-3000-65.1

   - SUSE Linux Enterprise Module for Advanced Systems Management 12 (noarch):

      salt-bash-completion-3000-65.1
      salt-zsh-completion-3000-65.1


References:

   https://www.suse.com/security/cve/CVE-2022-22967.html
   https://bugzilla.suse.com/1200566

SUSE: 2022:2154-1 important: salt

June 22, 2022
An update that fixes one vulnerability is now available

Summary

This update for salt fixes the following issues: - CVE-2022-22967: Fixed missing check for PAM_ACCT_MGM return value that could lead to authentication bypass when using PAM (bsc#1200566) Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - SUSE Manager Tools 12: zypper in -t patch SUSE-SLE-Manager-Tools-12-2022-2154=1 - SUSE Linux Enterprise Module for Advanced Systems Management 12: zypper in -t patch SUSE-SLE-Module-Adv-Systems-Management-12-2022-2154=1 Package List: - SUSE Manager Tools 12 (aarch64 ppc64le s390x x86_64): python2-salt-3000-65.1 python3-salt-3000-65.1 salt-3000-65.1 salt-doc-3000-65.1 salt-minion-3000-65.1 - SUSE Linux Enterprise Module for Advanced Systems Management 12 (ppc64le s390x x86_64): python2-salt-3000-65.1 salt-3000-65.1 salt-api-3000-65.1 salt-cloud-3000-65.1 salt-doc-3000-65.1 salt-master-3000-65.1 salt-minion-3000-65.1 salt-proxy-3000-65.1 salt-ssh-3000-65.1 salt-standalone-formulas-configuration-3000-65.1 salt-syndic-3000-65.1 - SUSE Linux Enterprise Module for Advanced Systems Management 12 (noarch): salt-bash-completion-3000-65.1 salt-zsh-completion-3000-65.1

References

#1200566

Cross- CVE-2022-22967

CVSS scores:

CVE-2022-22967 (SUSE): 7.5 CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Affected Products:

SUSE Linux Enterprise High Performance Computing 12

SUSE Linux Enterprise Module for Advanced Systems Management 12

SUSE Linux Enterprise Server 12

SUSE Linux Enterprise Server 12-SP3

SUSE Linux Enterprise Server 12-SP4

SUSE Linux Enterprise Server 12-SP5

SUSE Linux Enterprise Server for SAP Applications 12

SUSE Linux Enterprise Server for SAP Applications 12-SP3

SUSE Linux Enterprise Server for SAP Applications 12-SP4

SUSE Linux Enterprise Server for SAP Applications 12-SP5

SUSE Manager Tools 12

https://www.suse.com/security/cve/CVE-2022-22967.html

https://bugzilla.suse.com/1200566

Severity
Announcement ID: SUSE-SU-2022:2154-1
Rating: important

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.