SUSE: 2022:2301-1 moderate: ImageMagick

Advisories


   SUSE Security Update: Security update for ImageMagick
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:2301-1
Rating:             moderate
References:         #1200387 #1200388 #1200389 
Cross-References:   CVE-2022-32545 CVE-2022-32546 CVE-2022-32547
                   
CVSS scores:
                    CVE-2022-32545 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2022-32545 (SUSE): 3.3 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
                    CVE-2022-32546 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2022-32546 (SUSE): 3.3 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
                    CVE-2022-32547 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2022-32547 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Affected Products:
                    SUSE Linux Enterprise Desktop 15-SP4
                    SUSE Linux Enterprise High Performance Computing 15-SP4
                    SUSE Linux Enterprise Module for Desktop Applications 15-SP4
                    SUSE Linux Enterprise Module for Development Tools 15-SP4
                    SUSE Linux Enterprise Server 15-SP4
                    SUSE Linux Enterprise Server for SAP Applications 15-SP4
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that fixes three vulnerabilities is now available.

Description:

   This update for ImageMagick fixes the following issues:

     - CVE-2022-32545: Fixed an outside the range of representable values of
       type. (bsc#1200388)
     - CVE-2022-32546: Fixed an outside the range of representable values of
       type. (bsc#1200389)
     - CVE-2022-32547: Fixed a load of misaligned address at
       MagickCore/property.c. (bsc#1200387)


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-2301=1

   - SUSE Linux Enterprise Module for Development Tools 15-SP4:

      zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP4-2022-2301=1

   - SUSE Linux Enterprise Module for Desktop Applications 15-SP4:

      zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-SP4-2022-2301=1



Package List:

   - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

      ImageMagick-7.1.0.9-150400.6.3.1
      ImageMagick-config-7-SUSE-7.1.0.9-150400.6.3.1
      ImageMagick-config-7-upstream-7.1.0.9-150400.6.3.1
      ImageMagick-debuginfo-7.1.0.9-150400.6.3.1
      ImageMagick-debugsource-7.1.0.9-150400.6.3.1
      ImageMagick-devel-7.1.0.9-150400.6.3.1
      ImageMagick-extra-7.1.0.9-150400.6.3.1
      ImageMagick-extra-debuginfo-7.1.0.9-150400.6.3.1
      libMagick++-7_Q16HDRI5-7.1.0.9-150400.6.3.1
      libMagick++-7_Q16HDRI5-debuginfo-7.1.0.9-150400.6.3.1
      libMagick++-devel-7.1.0.9-150400.6.3.1
      libMagickCore-7_Q16HDRI10-7.1.0.9-150400.6.3.1
      libMagickCore-7_Q16HDRI10-debuginfo-7.1.0.9-150400.6.3.1
      libMagickWand-7_Q16HDRI10-7.1.0.9-150400.6.3.1
      libMagickWand-7_Q16HDRI10-debuginfo-7.1.0.9-150400.6.3.1
      perl-PerlMagick-7.1.0.9-150400.6.3.1
      perl-PerlMagick-debuginfo-7.1.0.9-150400.6.3.1

   - openSUSE Leap 15.4 (x86_64):

      ImageMagick-devel-32bit-7.1.0.9-150400.6.3.1
      libMagick++-7_Q16HDRI5-32bit-7.1.0.9-150400.6.3.1
      libMagick++-7_Q16HDRI5-32bit-debuginfo-7.1.0.9-150400.6.3.1
      libMagick++-devel-32bit-7.1.0.9-150400.6.3.1
      libMagickCore-7_Q16HDRI10-32bit-7.1.0.9-150400.6.3.1
      libMagickCore-7_Q16HDRI10-32bit-debuginfo-7.1.0.9-150400.6.3.1
      libMagickWand-7_Q16HDRI10-32bit-7.1.0.9-150400.6.3.1
      libMagickWand-7_Q16HDRI10-32bit-debuginfo-7.1.0.9-150400.6.3.1

   - openSUSE Leap 15.4 (noarch):

      ImageMagick-doc-7.1.0.9-150400.6.3.1

   - SUSE Linux Enterprise Module for Development Tools 15-SP4 (aarch64 ppc64le s390x x86_64):

      ImageMagick-debuginfo-7.1.0.9-150400.6.3.1
      ImageMagick-debugsource-7.1.0.9-150400.6.3.1
      perl-PerlMagick-7.1.0.9-150400.6.3.1
      perl-PerlMagick-debuginfo-7.1.0.9-150400.6.3.1

   - SUSE Linux Enterprise Module for Desktop Applications 15-SP4 (aarch64 ppc64le s390x x86_64):

      ImageMagick-7.1.0.9-150400.6.3.1
      ImageMagick-config-7-SUSE-7.1.0.9-150400.6.3.1
      ImageMagick-config-7-upstream-7.1.0.9-150400.6.3.1
      ImageMagick-debuginfo-7.1.0.9-150400.6.3.1
      ImageMagick-debugsource-7.1.0.9-150400.6.3.1
      ImageMagick-devel-7.1.0.9-150400.6.3.1
      libMagick++-7_Q16HDRI5-7.1.0.9-150400.6.3.1
      libMagick++-7_Q16HDRI5-debuginfo-7.1.0.9-150400.6.3.1
      libMagick++-devel-7.1.0.9-150400.6.3.1
      libMagickCore-7_Q16HDRI10-7.1.0.9-150400.6.3.1
      libMagickCore-7_Q16HDRI10-debuginfo-7.1.0.9-150400.6.3.1
      libMagickWand-7_Q16HDRI10-7.1.0.9-150400.6.3.1
      libMagickWand-7_Q16HDRI10-debuginfo-7.1.0.9-150400.6.3.1


References:

   https://www.suse.com/security/cve/CVE-2022-32545.html
   https://www.suse.com/security/cve/CVE-2022-32546.html
   https://www.suse.com/security/cve/CVE-2022-32547.html
   https://bugzilla.suse.com/1200387
   https://bugzilla.suse.com/1200388
   https://bugzilla.suse.com/1200389

SUSE: 2022:2301-1 moderate: ImageMagick

July 6, 2022
An update that fixes three vulnerabilities is now available

Summary

This update for ImageMagick fixes the following issues: - CVE-2022-32545: Fixed an outside the range of representable values of type. (bsc#1200388) - CVE-2022-32546: Fixed an outside the range of representable values of type. (bsc#1200389) - CVE-2022-32547: Fixed a load of misaligned address at MagickCore/property.c. (bsc#1200387) Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.4: zypper in -t patch openSUSE-SLE-15.4-2022-2301=1 - SUSE Linux Enterprise Module for Development Tools 15-SP4: zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP4-2022-2301=1 - SUSE Linux Enterprise Module for Desktop Applications 15-SP4: zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-SP4-2022-2301=1 Package List: - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64): ImageMagick-7.1.0.9-150400.6.3.1 ImageMagick-config-7-SUSE-7.1.0.9-150400.6.3.1 ImageMagick-config-7-upstream-7.1.0.9-150400.6.3.1 ImageMagick-debuginfo-7.1.0.9-150400.6.3.1 ImageMagick-debugsource-7.1.0.9-150400.6.3.1 ImageMagick-devel-7.1.0.9-150400.6.3.1 ImageMagick-extra-7.1.0.9-150400.6.3.1 ImageMagick-extra-debuginfo-7.1.0.9-150400.6.3.1 libMagick++-7_Q16HDRI5-7.1.0.9-150400.6.3.1 libMagick++-7_Q16HDRI5-debuginfo-7.1.0.9-150400.6.3.1 libMagick++-devel-7.1.0.9-150400.6.3.1 libMagickCore-7_Q16HDRI10-7.1.0.9-150400.6.3.1 libMagickCore-7_Q16HDRI10-debuginfo-7.1.0.9-150400.6.3.1 libMagickWand-7_Q16HDRI10-7.1.0.9-150400.6.3.1 libMagickWand-7_Q16HDRI10-debuginfo-7.1.0.9-150400.6.3.1 perl-PerlMagick-7.1.0.9-150400.6.3.1 perl-PerlMagick-debuginfo-7.1.0.9-150400.6.3.1 - openSUSE Leap 15.4 (x86_64): ImageMagick-devel-32bit-7.1.0.9-150400.6.3.1 libMagick++-7_Q16HDRI5-32bit-7.1.0.9-150400.6.3.1 libMagick++-7_Q16HDRI5-32bit-debuginfo-7.1.0.9-150400.6.3.1 libMagick++-devel-32bit-7.1.0.9-150400.6.3.1 libMagickCore-7_Q16HDRI10-32bit-7.1.0.9-150400.6.3.1 libMagickCore-7_Q16HDRI10-32bit-debuginfo-7.1.0.9-150400.6.3.1 libMagickWand-7_Q16HDRI10-32bit-7.1.0.9-150400.6.3.1 libMagickWand-7_Q16HDRI10-32bit-debuginfo-7.1.0.9-150400.6.3.1 - openSUSE Leap 15.4 (noarch): ImageMagick-doc-7.1.0.9-150400.6.3.1 - SUSE Linux Enterprise Module for Development Tools 15-SP4 (aarch64 ppc64le s390x x86_64): ImageMagick-debuginfo-7.1.0.9-150400.6.3.1 ImageMagick-debugsource-7.1.0.9-150400.6.3.1 perl-PerlMagick-7.1.0.9-150400.6.3.1 perl-PerlMagick-debuginfo-7.1.0.9-150400.6.3.1 - SUSE Linux Enterprise Module for Desktop Applications 15-SP4 (aarch64 ppc64le s390x x86_64): ImageMagick-7.1.0.9-150400.6.3.1 ImageMagick-config-7-SUSE-7.1.0.9-150400.6.3.1 ImageMagick-config-7-upstream-7.1.0.9-150400.6.3.1 ImageMagick-debuginfo-7.1.0.9-150400.6.3.1 ImageMagick-debugsource-7.1.0.9-150400.6.3.1 ImageMagick-devel-7.1.0.9-150400.6.3.1 libMagick++-7_Q16HDRI5-7.1.0.9-150400.6.3.1 libMagick++-7_Q16HDRI5-debuginfo-7.1.0.9-150400.6.3.1 libMagick++-devel-7.1.0.9-150400.6.3.1 libMagickCore-7_Q16HDRI10-7.1.0.9-150400.6.3.1 libMagickCore-7_Q16HDRI10-debuginfo-7.1.0.9-150400.6.3.1 libMagickWand-7_Q16HDRI10-7.1.0.9-150400.6.3.1 libMagickWand-7_Q16HDRI10-debuginfo-7.1.0.9-150400.6.3.1

References

#1200387 #1200388 #1200389

Cross- CVE-2022-32545 CVE-2022-32546 CVE-2022-32547

CVSS scores:

CVE-2022-32545 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

CVE-2022-32545 (SUSE): 3.3 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L

CVE-2022-32546 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

CVE-2022-32546 (SUSE): 3.3 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L

CVE-2022-32547 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

CVE-2022-32547 (SUSE): 5.5 CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Affected Products:

SUSE Linux Enterprise Desktop 15-SP4

SUSE Linux Enterprise High Performance Computing 15-SP4

SUSE Linux Enterprise Module for Desktop Applications 15-SP4

SUSE Linux Enterprise Module for Development Tools 15-SP4

SUSE Linux Enterprise Server 15-SP4

SUSE Linux Enterprise Server for SAP Applications 15-SP4

openSUSE Leap 15.4

https://www.suse.com/security/cve/CVE-2022-32545.html

https://www.suse.com/security/cve/CVE-2022-32546.html

https://www.suse.com/security/cve/CVE-2022-32547.html

https://bugzilla.suse.com/1200387

https://bugzilla.suse.com/1200388

https://bugzilla.suse.com/1200389

Severity
Announcement ID: SUSE-SU-2022:2301-1
Rating: moderate

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.