SUSE: 2022:2333-1 important: rsyslog

Advisories


   SUSE Security Update: Security update for rsyslog
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:2333-1
Rating:             important
References:         #1199061 
Cross-References:   CVE-2022-24903
CVSS scores:
                    CVE-2022-24903 (NVD) : 8.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-24903 (SUSE): 8.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Affected Products:
                    SUSE Linux Enterprise Server 12-SP2-BCL
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for rsyslog fixes the following issues:

   - CVE-2022-24903: Fixed potential heap buffer overflow in modules for TCP
     syslog reception (bsc#1199061).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Server 12-SP2-BCL:

      zypper in -t patch SUSE-SLE-SERVER-12-SP2-BCL-2022-2333=1



Package List:

   - SUSE Linux Enterprise Server 12-SP2-BCL (x86_64):

      rsyslog-8.4.0-18.16.1
      rsyslog-debuginfo-8.4.0-18.16.1
      rsyslog-debugsource-8.4.0-18.16.1
      rsyslog-diag-tools-8.4.0-18.16.1
      rsyslog-diag-tools-debuginfo-8.4.0-18.16.1
      rsyslog-doc-8.4.0-18.16.1
      rsyslog-module-gssapi-8.4.0-18.16.1
      rsyslog-module-gssapi-debuginfo-8.4.0-18.16.1
      rsyslog-module-gtls-8.4.0-18.16.1
      rsyslog-module-gtls-debuginfo-8.4.0-18.16.1
      rsyslog-module-mysql-8.4.0-18.16.1
      rsyslog-module-mysql-debuginfo-8.4.0-18.16.1
      rsyslog-module-pgsql-8.4.0-18.16.1
      rsyslog-module-pgsql-debuginfo-8.4.0-18.16.1
      rsyslog-module-relp-8.4.0-18.16.1
      rsyslog-module-relp-debuginfo-8.4.0-18.16.1
      rsyslog-module-snmp-8.4.0-18.16.1
      rsyslog-module-snmp-debuginfo-8.4.0-18.16.1
      rsyslog-module-udpspoof-8.4.0-18.16.1
      rsyslog-module-udpspoof-debuginfo-8.4.0-18.16.1


References:

   https://www.suse.com/security/cve/CVE-2022-24903.html
   https://bugzilla.suse.com/1199061

SUSE: 2022:2333-1 important: rsyslog

July 8, 2022
An update that fixes one vulnerability is now available

Summary

This update for rsyslog fixes the following issues: - CVE-2022-24903: Fixed potential heap buffer overflow in modules for TCP syslog reception (bsc#1199061). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - SUSE Linux Enterprise Server 12-SP2-BCL: zypper in -t patch SUSE-SLE-SERVER-12-SP2-BCL-2022-2333=1 Package List: - SUSE Linux Enterprise Server 12-SP2-BCL (x86_64): rsyslog-8.4.0-18.16.1 rsyslog-debuginfo-8.4.0-18.16.1 rsyslog-debugsource-8.4.0-18.16.1 rsyslog-diag-tools-8.4.0-18.16.1 rsyslog-diag-tools-debuginfo-8.4.0-18.16.1 rsyslog-doc-8.4.0-18.16.1 rsyslog-module-gssapi-8.4.0-18.16.1 rsyslog-module-gssapi-debuginfo-8.4.0-18.16.1 rsyslog-module-gtls-8.4.0-18.16.1 rsyslog-module-gtls-debuginfo-8.4.0-18.16.1 rsyslog-module-mysql-8.4.0-18.16.1 rsyslog-module-mysql-debuginfo-8.4.0-18.16.1 rsyslog-module-pgsql-8.4.0-18.16.1 rsyslog-module-pgsql-debuginfo-8.4.0-18.16.1 rsyslog-module-relp-8.4.0-18.16.1 rsyslog-module-relp-debuginfo-8.4.0-18.16.1 rsyslog-module-snmp-8.4.0-18.16.1 rsyslog-module-snmp-debuginfo-8.4.0-18.16.1 rsyslog-module-udpspoof-8.4.0-18.16.1 rsyslog-module-udpspoof-debuginfo-8.4.0-18.16.1

References

#1199061

Cross- CVE-2022-24903

CVSS scores:

CVE-2022-24903 (NVD) : 8.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

CVE-2022-24903 (SUSE): 8.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Affected Products:

SUSE Linux Enterprise Server 12-SP2-BCL

https://www.suse.com/security/cve/CVE-2022-24903.html

https://bugzilla.suse.com/1199061

Severity
Announcement ID: SUSE-SU-2022:2333-1
Rating: important

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.