SUSE: 2022:2369-1 important: xorg-x11-server

Advisories


   SUSE Security Update: Security update for xorg-x11-server
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:2369-1
Rating:             important
References:         #1194179 #1194181 
Cross-References:   CVE-2022-2319 CVE-2022-2320
CVSS scores:
                    CVE-2022-2320 (SUSE): 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Affected Products:
                    SUSE Linux Enterprise Server 12-SP4-LTSS
                    SUSE Linux Enterprise Server for SAP 12-SP4
                    SUSE OpenStack Cloud 9
                    SUSE OpenStack Cloud Crowbar 9
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for xorg-x11-server fixes the following issues:

   - CVE-2022-2319: Fixed out-of-bounds access in _CheckSetSections()
     (ZDI-CAN-16062) (bsc#1194179).
   - CVE-2022-2320: Fixed out-of-bounds access in CheckSetDeviceIndicators()
     (ZDI-CAN-16070) (bsc#1194181).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE OpenStack Cloud Crowbar 9:

      zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2022-2369=1

   - SUSE OpenStack Cloud 9:

      zypper in -t patch SUSE-OpenStack-Cloud-9-2022-2369=1

   - SUSE Linux Enterprise Server for SAP 12-SP4:

      zypper in -t patch SUSE-SLE-SAP-12-SP4-2022-2369=1

   - SUSE Linux Enterprise Server 12-SP4-LTSS:

      zypper in -t patch SUSE-SLE-SERVER-12-SP4-LTSS-2022-2369=1



Package List:

   - SUSE OpenStack Cloud Crowbar 9 (x86_64):

      xorg-x11-server-1.19.6-4.31.1
      xorg-x11-server-debuginfo-1.19.6-4.31.1
      xorg-x11-server-debugsource-1.19.6-4.31.1
      xorg-x11-server-extra-1.19.6-4.31.1
      xorg-x11-server-extra-debuginfo-1.19.6-4.31.1

   - SUSE OpenStack Cloud 9 (x86_64):

      xorg-x11-server-1.19.6-4.31.1
      xorg-x11-server-debuginfo-1.19.6-4.31.1
      xorg-x11-server-debugsource-1.19.6-4.31.1
      xorg-x11-server-extra-1.19.6-4.31.1
      xorg-x11-server-extra-debuginfo-1.19.6-4.31.1

   - SUSE Linux Enterprise Server for SAP 12-SP4 (ppc64le x86_64):

      xorg-x11-server-1.19.6-4.31.1
      xorg-x11-server-debuginfo-1.19.6-4.31.1
      xorg-x11-server-debugsource-1.19.6-4.31.1
      xorg-x11-server-extra-1.19.6-4.31.1
      xorg-x11-server-extra-debuginfo-1.19.6-4.31.1

   - SUSE Linux Enterprise Server 12-SP4-LTSS (aarch64 ppc64le s390x x86_64):

      xorg-x11-server-1.19.6-4.31.1
      xorg-x11-server-debuginfo-1.19.6-4.31.1
      xorg-x11-server-debugsource-1.19.6-4.31.1
      xorg-x11-server-extra-1.19.6-4.31.1
      xorg-x11-server-extra-debuginfo-1.19.6-4.31.1


References:

   https://www.suse.com/security/cve/CVE-2022-2319.html
   https://www.suse.com/security/cve/CVE-2022-2320.html
   https://bugzilla.suse.com/1194179
   https://bugzilla.suse.com/1194181

SUSE: 2022:2369-1 important: xorg-x11-server

July 12, 2022
An update that fixes two vulnerabilities is now available

Summary

This update for xorg-x11-server fixes the following issues: - CVE-2022-2319: Fixed out-of-bounds access in _CheckSetSections() (ZDI-CAN-16062) (bsc#1194179). - CVE-2022-2320: Fixed out-of-bounds access in CheckSetDeviceIndicators() (ZDI-CAN-16070) (bsc#1194181). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - SUSE OpenStack Cloud Crowbar 9: zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2022-2369=1 - SUSE OpenStack Cloud 9: zypper in -t patch SUSE-OpenStack-Cloud-9-2022-2369=1 - SUSE Linux Enterprise Server for SAP 12-SP4: zypper in -t patch SUSE-SLE-SAP-12-SP4-2022-2369=1 - SUSE Linux Enterprise Server 12-SP4-LTSS: zypper in -t patch SUSE-SLE-SERVER-12-SP4-LTSS-2022-2369=1 Package List: - SUSE OpenStack Cloud Crowbar 9 (x86_64): xorg-x11-server-1.19.6-4.31.1 xorg-x11-server-debuginfo-1.19.6-4.31.1 xorg-x11-server-debugsource-1.19.6-4.31.1 xorg-x11-server-extra-1.19.6-4.31.1 xorg-x11-server-extra-debuginfo-1.19.6-4.31.1 - SUSE OpenStack Cloud 9 (x86_64): xorg-x11-server-1.19.6-4.31.1 xorg-x11-server-debuginfo-1.19.6-4.31.1 xorg-x11-server-debugsource-1.19.6-4.31.1 xorg-x11-server-extra-1.19.6-4.31.1 xorg-x11-server-extra-debuginfo-1.19.6-4.31.1 - SUSE Linux Enterprise Server for SAP 12-SP4 (ppc64le x86_64): xorg-x11-server-1.19.6-4.31.1 xorg-x11-server-debuginfo-1.19.6-4.31.1 xorg-x11-server-debugsource-1.19.6-4.31.1 xorg-x11-server-extra-1.19.6-4.31.1 xorg-x11-server-extra-debuginfo-1.19.6-4.31.1 - SUSE Linux Enterprise Server 12-SP4-LTSS (aarch64 ppc64le s390x x86_64): xorg-x11-server-1.19.6-4.31.1 xorg-x11-server-debuginfo-1.19.6-4.31.1 xorg-x11-server-debugsource-1.19.6-4.31.1 xorg-x11-server-extra-1.19.6-4.31.1 xorg-x11-server-extra-debuginfo-1.19.6-4.31.1

References

#1194179 #1194181

Cross- CVE-2022-2319 CVE-2022-2320

CVSS scores:

CVE-2022-2320 (SUSE): 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Affected Products:

SUSE Linux Enterprise Server 12-SP4-LTSS

SUSE Linux Enterprise Server for SAP 12-SP4

SUSE OpenStack Cloud 9

SUSE OpenStack Cloud Crowbar 9

https://www.suse.com/security/cve/CVE-2022-2319.html

https://www.suse.com/security/cve/CVE-2022-2320.html

https://bugzilla.suse.com/1194179

https://bugzilla.suse.com/1194181

Severity
Announcement ID: SUSE-SU-2022:2369-1
Rating: important

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.