SUSE: 2022:2618-1 important: dovecot22 | LinuxSecurity.com

Advisories


   SUSE Security Update: Security update for dovecot22
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:2618-1
Rating:             important
References:         #1201267 
Cross-References:   CVE-2022-30550
CVSS scores:
                    CVE-2022-30550 (NVD) : 8.8 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
                    CVE-2022-30550 (SUSE): 6.8 CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N

Affected Products:
                    SUSE Linux Enterprise Server 12-SP2-BCL
                    SUSE Linux Enterprise Server 12-SP3-BCL
                    SUSE Linux Enterprise Server 12-SP4-LTSS
                    SUSE Linux Enterprise Server 12-SP5
                    SUSE Linux Enterprise Server for SAP 12-SP4
                    SUSE Linux Enterprise Server for SAP Applications 12-SP5
                    SUSE Linux Enterprise Software Development Kit 12-SP5
                    SUSE OpenStack Cloud 9
                    SUSE OpenStack Cloud Crowbar 9
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for dovecot22 fixes the following issues:

   - CVE-2022-30550: Fixed privilege escalation in dovecot when similar
     master and non-master passdbs are used (bsc#1201267).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE OpenStack Cloud Crowbar 9:

      zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2022-2618=1

   - SUSE OpenStack Cloud 9:

      zypper in -t patch SUSE-OpenStack-Cloud-9-2022-2618=1

   - SUSE Linux Enterprise Software Development Kit 12-SP5:

      zypper in -t patch SUSE-SLE-SDK-12-SP5-2022-2618=1

   - SUSE Linux Enterprise Server for SAP 12-SP4:

      zypper in -t patch SUSE-SLE-SAP-12-SP4-2022-2618=1

   - SUSE Linux Enterprise Server 12-SP5:

      zypper in -t patch SUSE-SLE-SERVER-12-SP5-2022-2618=1

   - SUSE Linux Enterprise Server 12-SP4-LTSS:

      zypper in -t patch SUSE-SLE-SERVER-12-SP4-LTSS-2022-2618=1

   - SUSE Linux Enterprise Server 12-SP3-BCL:

      zypper in -t patch SUSE-SLE-SERVER-12-SP3-BCL-2022-2618=1

   - SUSE Linux Enterprise Server 12-SP2-BCL:

      zypper in -t patch SUSE-SLE-SERVER-12-SP2-BCL-2022-2618=1



Package List:

   - SUSE OpenStack Cloud Crowbar 9 (x86_64):

      dovecot22-2.2.31-19.29.1
      dovecot22-backend-mysql-2.2.31-19.29.1
      dovecot22-backend-mysql-debuginfo-2.2.31-19.29.1
      dovecot22-backend-pgsql-2.2.31-19.29.1
      dovecot22-backend-pgsql-debuginfo-2.2.31-19.29.1
      dovecot22-backend-sqlite-2.2.31-19.29.1
      dovecot22-backend-sqlite-debuginfo-2.2.31-19.29.1
      dovecot22-debuginfo-2.2.31-19.29.1
      dovecot22-debugsource-2.2.31-19.29.1

   - SUSE OpenStack Cloud 9 (x86_64):

      dovecot22-2.2.31-19.29.1
      dovecot22-backend-mysql-2.2.31-19.29.1
      dovecot22-backend-mysql-debuginfo-2.2.31-19.29.1
      dovecot22-backend-pgsql-2.2.31-19.29.1
      dovecot22-backend-pgsql-debuginfo-2.2.31-19.29.1
      dovecot22-backend-sqlite-2.2.31-19.29.1
      dovecot22-backend-sqlite-debuginfo-2.2.31-19.29.1
      dovecot22-debuginfo-2.2.31-19.29.1
      dovecot22-debugsource-2.2.31-19.29.1

   - SUSE Linux Enterprise Software Development Kit 12-SP5 (aarch64 ppc64le s390x x86_64):

      dovecot22-debuginfo-2.2.31-19.29.1
      dovecot22-debugsource-2.2.31-19.29.1
      dovecot22-devel-2.2.31-19.29.1

   - SUSE Linux Enterprise Server for SAP 12-SP4 (ppc64le x86_64):

      dovecot22-2.2.31-19.29.1
      dovecot22-backend-mysql-2.2.31-19.29.1
      dovecot22-backend-mysql-debuginfo-2.2.31-19.29.1
      dovecot22-backend-pgsql-2.2.31-19.29.1
      dovecot22-backend-pgsql-debuginfo-2.2.31-19.29.1
      dovecot22-backend-sqlite-2.2.31-19.29.1
      dovecot22-backend-sqlite-debuginfo-2.2.31-19.29.1
      dovecot22-debuginfo-2.2.31-19.29.1
      dovecot22-debugsource-2.2.31-19.29.1

   - SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64):

      dovecot22-2.2.31-19.29.1
      dovecot22-backend-mysql-2.2.31-19.29.1
      dovecot22-backend-mysql-debuginfo-2.2.31-19.29.1
      dovecot22-backend-pgsql-2.2.31-19.29.1
      dovecot22-backend-pgsql-debuginfo-2.2.31-19.29.1
      dovecot22-backend-sqlite-2.2.31-19.29.1
      dovecot22-backend-sqlite-debuginfo-2.2.31-19.29.1
      dovecot22-debuginfo-2.2.31-19.29.1
      dovecot22-debugsource-2.2.31-19.29.1

   - SUSE Linux Enterprise Server 12-SP4-LTSS (aarch64 ppc64le s390x x86_64):

      dovecot22-2.2.31-19.29.1
      dovecot22-backend-mysql-2.2.31-19.29.1
      dovecot22-backend-mysql-debuginfo-2.2.31-19.29.1
      dovecot22-backend-pgsql-2.2.31-19.29.1
      dovecot22-backend-pgsql-debuginfo-2.2.31-19.29.1
      dovecot22-backend-sqlite-2.2.31-19.29.1
      dovecot22-backend-sqlite-debuginfo-2.2.31-19.29.1
      dovecot22-debuginfo-2.2.31-19.29.1
      dovecot22-debugsource-2.2.31-19.29.1

   - SUSE Linux Enterprise Server 12-SP3-BCL (x86_64):

      dovecot22-2.2.31-19.29.1
      dovecot22-backend-mysql-2.2.31-19.29.1
      dovecot22-backend-mysql-debuginfo-2.2.31-19.29.1
      dovecot22-backend-pgsql-2.2.31-19.29.1
      dovecot22-backend-pgsql-debuginfo-2.2.31-19.29.1
      dovecot22-backend-sqlite-2.2.31-19.29.1
      dovecot22-backend-sqlite-debuginfo-2.2.31-19.29.1
      dovecot22-debuginfo-2.2.31-19.29.1
      dovecot22-debugsource-2.2.31-19.29.1

   - SUSE Linux Enterprise Server 12-SP2-BCL (x86_64):

      dovecot22-2.2.31-19.29.1
      dovecot22-backend-mysql-2.2.31-19.29.1
      dovecot22-backend-mysql-debuginfo-2.2.31-19.29.1
      dovecot22-backend-pgsql-2.2.31-19.29.1
      dovecot22-backend-pgsql-debuginfo-2.2.31-19.29.1
      dovecot22-backend-sqlite-2.2.31-19.29.1
      dovecot22-backend-sqlite-debuginfo-2.2.31-19.29.1
      dovecot22-debuginfo-2.2.31-19.29.1
      dovecot22-debugsource-2.2.31-19.29.1


References:

   https://www.suse.com/security/cve/CVE-2022-30550.html
   https://bugzilla.suse.com/1201267

SUSE: 2022:2618-1 important: dovecot22

August 1, 2022
An update that fixes one vulnerability is now available

Summary

This update for dovecot22 fixes the following issues: - CVE-2022-30550: Fixed privilege escalation in dovecot when similar master and non-master passdbs are used (bsc#1201267). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - SUSE OpenStack Cloud Crowbar 9: zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2022-2618=1 - SUSE OpenStack Cloud 9: zypper in -t patch SUSE-OpenStack-Cloud-9-2022-2618=1 - SUSE Linux Enterprise Software Development Kit 12-SP5: zypper in -t patch SUSE-SLE-SDK-12-SP5-2022-2618=1 - SUSE Linux Enterprise Server for SAP 12-SP4: zypper in -t patch SUSE-SLE-SAP-12-SP4-2022-2618=1 - SUSE Linux Enterprise Server 12-SP5: zypper in -t patch SUSE-SLE-SERVER-12-SP5-2022-2618=1 - SUSE Linux Enterprise Server 12-SP4-LTSS: zypper in -t patch SUSE-SLE-SERVER-12-SP4-LTSS-2022-2618=1 - SUSE Linux Enterprise Server 12-SP3-BCL: zypper in -t patch SUSE-SLE-SERVER-12-SP3-BCL-2022-2618=1 - SUSE Linux Enterprise Server 12-SP2-BCL: zypper in -t patch SUSE-SLE-SERVER-12-SP2-BCL-2022-2618=1 Package List: - SUSE OpenStack Cloud Crowbar 9 (x86_64): dovecot22-2.2.31-19.29.1 dovecot22-backend-mysql-2.2.31-19.29.1 dovecot22-backend-mysql-debuginfo-2.2.31-19.29.1 dovecot22-backend-pgsql-2.2.31-19.29.1 dovecot22-backend-pgsql-debuginfo-2.2.31-19.29.1 dovecot22-backend-sqlite-2.2.31-19.29.1 dovecot22-backend-sqlite-debuginfo-2.2.31-19.29.1 dovecot22-debuginfo-2.2.31-19.29.1 dovecot22-debugsource-2.2.31-19.29.1 - SUSE OpenStack Cloud 9 (x86_64): dovecot22-2.2.31-19.29.1 dovecot22-backend-mysql-2.2.31-19.29.1 dovecot22-backend-mysql-debuginfo-2.2.31-19.29.1 dovecot22-backend-pgsql-2.2.31-19.29.1 dovecot22-backend-pgsql-debuginfo-2.2.31-19.29.1 dovecot22-backend-sqlite-2.2.31-19.29.1 dovecot22-backend-sqlite-debuginfo-2.2.31-19.29.1 dovecot22-debuginfo-2.2.31-19.29.1 dovecot22-debugsource-2.2.31-19.29.1 - SUSE Linux Enterprise Software Development Kit 12-SP5 (aarch64 ppc64le s390x x86_64): dovecot22-debuginfo-2.2.31-19.29.1 dovecot22-debugsource-2.2.31-19.29.1 dovecot22-devel-2.2.31-19.29.1 - SUSE Linux Enterprise Server for SAP 12-SP4 (ppc64le x86_64): dovecot22-2.2.31-19.29.1 dovecot22-backend-mysql-2.2.31-19.29.1 dovecot22-backend-mysql-debuginfo-2.2.31-19.29.1 dovecot22-backend-pgsql-2.2.31-19.29.1 dovecot22-backend-pgsql-debuginfo-2.2.31-19.29.1 dovecot22-backend-sqlite-2.2.31-19.29.1 dovecot22-backend-sqlite-debuginfo-2.2.31-19.29.1 dovecot22-debuginfo-2.2.31-19.29.1 dovecot22-debugsource-2.2.31-19.29.1 - SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64): dovecot22-2.2.31-19.29.1 dovecot22-backend-mysql-2.2.31-19.29.1 dovecot22-backend-mysql-debuginfo-2.2.31-19.29.1 dovecot22-backend-pgsql-2.2.31-19.29.1 dovecot22-backend-pgsql-debuginfo-2.2.31-19.29.1 dovecot22-backend-sqlite-2.2.31-19.29.1 dovecot22-backend-sqlite-debuginfo-2.2.31-19.29.1 dovecot22-debuginfo-2.2.31-19.29.1 dovecot22-debugsource-2.2.31-19.29.1 - SUSE Linux Enterprise Server 12-SP4-LTSS (aarch64 ppc64le s390x x86_64): dovecot22-2.2.31-19.29.1 dovecot22-backend-mysql-2.2.31-19.29.1 dovecot22-backend-mysql-debuginfo-2.2.31-19.29.1 dovecot22-backend-pgsql-2.2.31-19.29.1 dovecot22-backend-pgsql-debuginfo-2.2.31-19.29.1 dovecot22-backend-sqlite-2.2.31-19.29.1 dovecot22-backend-sqlite-debuginfo-2.2.31-19.29.1 dovecot22-debuginfo-2.2.31-19.29.1 dovecot22-debugsource-2.2.31-19.29.1 - SUSE Linux Enterprise Server 12-SP3-BCL (x86_64): dovecot22-2.2.31-19.29.1 dovecot22-backend-mysql-2.2.31-19.29.1 dovecot22-backend-mysql-debuginfo-2.2.31-19.29.1 dovecot22-backend-pgsql-2.2.31-19.29.1 dovecot22-backend-pgsql-debuginfo-2.2.31-19.29.1 dovecot22-backend-sqlite-2.2.31-19.29.1 dovecot22-backend-sqlite-debuginfo-2.2.31-19.29.1 dovecot22-debuginfo-2.2.31-19.29.1 dovecot22-debugsource-2.2.31-19.29.1 - SUSE Linux Enterprise Server 12-SP2-BCL (x86_64): dovecot22-2.2.31-19.29.1 dovecot22-backend-mysql-2.2.31-19.29.1 dovecot22-backend-mysql-debuginfo-2.2.31-19.29.1 dovecot22-backend-pgsql-2.2.31-19.29.1 dovecot22-backend-pgsql-debuginfo-2.2.31-19.29.1 dovecot22-backend-sqlite-2.2.31-19.29.1 dovecot22-backend-sqlite-debuginfo-2.2.31-19.29.1 dovecot22-debuginfo-2.2.31-19.29.1 dovecot22-debugsource-2.2.31-19.29.1

References

#1201267

Cross- CVE-2022-30550

CVSS scores:

CVE-2022-30550 (NVD) : 8.8 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

CVE-2022-30550 (SUSE): 6.8 CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N

Affected Products:

SUSE Linux Enterprise Server 12-SP2-BCL

SUSE Linux Enterprise Server 12-SP3-BCL

SUSE Linux Enterprise Server 12-SP4-LTSS

SUSE Linux Enterprise Server 12-SP5

SUSE Linux Enterprise Server for SAP 12-SP4

SUSE Linux Enterprise Server for SAP Applications 12-SP5

SUSE Linux Enterprise Software Development Kit 12-SP5

SUSE OpenStack Cloud 9

SUSE OpenStack Cloud Crowbar 9

https://www.suse.com/security/cve/CVE-2022-30550.html

https://bugzilla.suse.com/1201267

Severity
Announcement ID: SUSE-SU-2022:2618-1
Rating: important

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.