SUSE: 2022:3193-1 important: postgresql12 | LinuxSecurity.com

Advisories


   SUSE Security Update: Security update for postgresql12
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:3193-1
Rating:             important
References:         #1198166 #1202368 
Cross-References:   CVE-2022-2625
CVSS scores:
                    CVE-2022-2625 (NVD) : 8 CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
                    CVE-2022-2625 (SUSE): 7.1 CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H

Affected Products:
                    SUSE Linux Enterprise Server 12-SP2-BCL
                    SUSE Linux Enterprise Server 12-SP3-BCL
                    SUSE Linux Enterprise Server 12-SP4-LTSS
                    SUSE Linux Enterprise Server 12-SP5
                    SUSE Linux Enterprise Server for SAP 12-SP4
                    SUSE Linux Enterprise Server for SAP Applications 12-SP5
                    SUSE Linux Enterprise Software Development Kit 12-SP5
                    SUSE OpenStack Cloud 9
                    SUSE OpenStack Cloud Crowbar 9
______________________________________________________________________________

   An update that solves one vulnerability and has one errata
   is now available.

Description:

   This update for postgresql12 fixes the following issues:

   - Update to 12.12:
   - CVE-2022-2625: Fixed an issue where extension scripts would replace
     objects not belonging to that extension (bsc#1202368).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE OpenStack Cloud Crowbar 9:

      zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2022-3193=1

   - SUSE OpenStack Cloud 9:

      zypper in -t patch SUSE-OpenStack-Cloud-9-2022-3193=1

   - SUSE Linux Enterprise Software Development Kit 12-SP5:

      zypper in -t patch SUSE-SLE-SDK-12-SP5-2022-3193=1

   - SUSE Linux Enterprise Server for SAP 12-SP4:

      zypper in -t patch SUSE-SLE-SAP-12-SP4-2022-3193=1

   - SUSE Linux Enterprise Server 12-SP5:

      zypper in -t patch SUSE-SLE-SERVER-12-SP5-2022-3193=1

   - SUSE Linux Enterprise Server 12-SP4-LTSS:

      zypper in -t patch SUSE-SLE-SERVER-12-SP4-LTSS-2022-3193=1

   - SUSE Linux Enterprise Server 12-SP3-BCL:

      zypper in -t patch SUSE-SLE-SERVER-12-SP3-BCL-2022-3193=1

   - SUSE Linux Enterprise Server 12-SP2-BCL:

      zypper in -t patch SUSE-SLE-SERVER-12-SP2-BCL-2022-3193=1



Package List:

   - SUSE OpenStack Cloud Crowbar 9 (noarch):

      postgresql-14-4.17.2
      postgresql-contrib-14-4.17.2
      postgresql-docs-14-4.17.2
      postgresql-plperl-14-4.17.2
      postgresql-plpython-14-4.17.2
      postgresql-pltcl-14-4.17.2
      postgresql-server-14-4.17.2

   - SUSE OpenStack Cloud 9 (noarch):

      postgresql-14-4.17.2
      postgresql-contrib-14-4.17.2
      postgresql-docs-14-4.17.2
      postgresql-plperl-14-4.17.2
      postgresql-plpython-14-4.17.2
      postgresql-pltcl-14-4.17.2
      postgresql-server-14-4.17.2

   - SUSE Linux Enterprise Software Development Kit 12-SP5 (aarch64 ppc64le s390x x86_64):

      postgresql12-debugsource-12.12-3.30.2
      postgresql12-devel-12.12-3.30.2
      postgresql12-devel-debuginfo-12.12-3.30.2

   - SUSE Linux Enterprise Software Development Kit 12-SP5 (ppc64le s390x x86_64):

      postgresql12-server-devel-12.12-3.30.2
      postgresql12-server-devel-debuginfo-12.12-3.30.2

   - SUSE Linux Enterprise Software Development Kit 12-SP5 (noarch):

      postgresql-devel-14-4.17.2
      postgresql-server-devel-14-4.17.2

   - SUSE Linux Enterprise Server for SAP 12-SP4 (noarch):

      postgresql-14-4.17.2
      postgresql-contrib-14-4.17.2
      postgresql-docs-14-4.17.2
      postgresql-plperl-14-4.17.2
      postgresql-plpython-14-4.17.2
      postgresql-pltcl-14-4.17.2
      postgresql-server-14-4.17.2

   - SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64):

      postgresql12-12.12-3.30.2
      postgresql12-contrib-12.12-3.30.2
      postgresql12-contrib-debuginfo-12.12-3.30.2
      postgresql12-debuginfo-12.12-3.30.2
      postgresql12-debugsource-12.12-3.30.2
      postgresql12-plperl-12.12-3.30.2
      postgresql12-plperl-debuginfo-12.12-3.30.2
      postgresql12-plpython-12.12-3.30.2
      postgresql12-plpython-debuginfo-12.12-3.30.2
      postgresql12-pltcl-12.12-3.30.2
      postgresql12-pltcl-debuginfo-12.12-3.30.2
      postgresql12-server-12.12-3.30.2
      postgresql12-server-debuginfo-12.12-3.30.2

   - SUSE Linux Enterprise Server 12-SP5 (noarch):

      postgresql-14-4.17.2
      postgresql-contrib-14-4.17.2
      postgresql-docs-14-4.17.2
      postgresql-plperl-14-4.17.2
      postgresql-plpython-14-4.17.2
      postgresql-pltcl-14-4.17.2
      postgresql-server-14-4.17.2
      postgresql12-docs-12.12-3.30.2

   - SUSE Linux Enterprise Server 12-SP4-LTSS (noarch):

      postgresql-14-4.17.2
      postgresql-contrib-14-4.17.2
      postgresql-docs-14-4.17.2
      postgresql-plperl-14-4.17.2
      postgresql-plpython-14-4.17.2
      postgresql-pltcl-14-4.17.2
      postgresql-server-14-4.17.2

   - SUSE Linux Enterprise Server 12-SP3-BCL (noarch):

      postgresql-14-4.17.2
      postgresql-contrib-14-4.17.2
      postgresql-docs-14-4.17.2
      postgresql-plperl-14-4.17.2
      postgresql-plpython-14-4.17.2
      postgresql-pltcl-14-4.17.2
      postgresql-server-14-4.17.2

   - SUSE Linux Enterprise Server 12-SP2-BCL (noarch):

      postgresql-14-4.17.2
      postgresql-contrib-14-4.17.2
      postgresql-docs-14-4.17.2
      postgresql-plperl-14-4.17.2
      postgresql-plpython-14-4.17.2
      postgresql-pltcl-14-4.17.2
      postgresql-server-14-4.17.2


References:

   https://www.suse.com/security/cve/CVE-2022-2625.html
   https://bugzilla.suse.com/1198166
   https://bugzilla.suse.com/1202368

SUSE: 2022:3193-1 important: postgresql12

September 8, 2022
An update that solves one vulnerability and has one errata is now available

Summary

This update for postgresql12 fixes the following issues: - Update to 12.12: - CVE-2022-2625: Fixed an issue where extension scripts would replace objects not belonging to that extension (bsc#1202368). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - SUSE OpenStack Cloud Crowbar 9: zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2022-3193=1 - SUSE OpenStack Cloud 9: zypper in -t patch SUSE-OpenStack-Cloud-9-2022-3193=1 - SUSE Linux Enterprise Software Development Kit 12-SP5: zypper in -t patch SUSE-SLE-SDK-12-SP5-2022-3193=1 - SUSE Linux Enterprise Server for SAP 12-SP4: zypper in -t patch SUSE-SLE-SAP-12-SP4-2022-3193=1 - SUSE Linux Enterprise Server 12-SP5: zypper in -t patch SUSE-SLE-SERVER-12-SP5-2022-3193=1 - SUSE Linux Enterprise Server 12-SP4-LTSS: zypper in -t patch SUSE-SLE-SERVER-12-SP4-LTSS-2022-3193=1 - SUSE Linux Enterprise Server 12-SP3-BCL: zypper in -t patch SUSE-SLE-SERVER-12-SP3-BCL-2022-3193=1 - SUSE Linux Enterprise Server 12-SP2-BCL: zypper in -t patch SUSE-SLE-SERVER-12-SP2-BCL-2022-3193=1 Package List: - SUSE OpenStack Cloud Crowbar 9 (noarch): postgresql-14-4.17.2 postgresql-contrib-14-4.17.2 postgresql-docs-14-4.17.2 postgresql-plperl-14-4.17.2 postgresql-plpython-14-4.17.2 postgresql-pltcl-14-4.17.2 postgresql-server-14-4.17.2 - SUSE OpenStack Cloud 9 (noarch): postgresql-14-4.17.2 postgresql-contrib-14-4.17.2 postgresql-docs-14-4.17.2 postgresql-plperl-14-4.17.2 postgresql-plpython-14-4.17.2 postgresql-pltcl-14-4.17.2 postgresql-server-14-4.17.2 - SUSE Linux Enterprise Software Development Kit 12-SP5 (aarch64 ppc64le s390x x86_64): postgresql12-debugsource-12.12-3.30.2 postgresql12-devel-12.12-3.30.2 postgresql12-devel-debuginfo-12.12-3.30.2 - SUSE Linux Enterprise Software Development Kit 12-SP5 (ppc64le s390x x86_64): postgresql12-server-devel-12.12-3.30.2 postgresql12-server-devel-debuginfo-12.12-3.30.2 - SUSE Linux Enterprise Software Development Kit 12-SP5 (noarch): postgresql-devel-14-4.17.2 postgresql-server-devel-14-4.17.2 - SUSE Linux Enterprise Server for SAP 12-SP4 (noarch): postgresql-14-4.17.2 postgresql-contrib-14-4.17.2 postgresql-docs-14-4.17.2 postgresql-plperl-14-4.17.2 postgresql-plpython-14-4.17.2 postgresql-pltcl-14-4.17.2 postgresql-server-14-4.17.2 - SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64): postgresql12-12.12-3.30.2 postgresql12-contrib-12.12-3.30.2 postgresql12-contrib-debuginfo-12.12-3.30.2 postgresql12-debuginfo-12.12-3.30.2 postgresql12-debugsource-12.12-3.30.2 postgresql12-plperl-12.12-3.30.2 postgresql12-plperl-debuginfo-12.12-3.30.2 postgresql12-plpython-12.12-3.30.2 postgresql12-plpython-debuginfo-12.12-3.30.2 postgresql12-pltcl-12.12-3.30.2 postgresql12-pltcl-debuginfo-12.12-3.30.2 postgresql12-server-12.12-3.30.2 postgresql12-server-debuginfo-12.12-3.30.2 - SUSE Linux Enterprise Server 12-SP5 (noarch): postgresql-14-4.17.2 postgresql-contrib-14-4.17.2 postgresql-docs-14-4.17.2 postgresql-plperl-14-4.17.2 postgresql-plpython-14-4.17.2 postgresql-pltcl-14-4.17.2 postgresql-server-14-4.17.2 postgresql12-docs-12.12-3.30.2 - SUSE Linux Enterprise Server 12-SP4-LTSS (noarch): postgresql-14-4.17.2 postgresql-contrib-14-4.17.2 postgresql-docs-14-4.17.2 postgresql-plperl-14-4.17.2 postgresql-plpython-14-4.17.2 postgresql-pltcl-14-4.17.2 postgresql-server-14-4.17.2 - SUSE Linux Enterprise Server 12-SP3-BCL (noarch): postgresql-14-4.17.2 postgresql-contrib-14-4.17.2 postgresql-docs-14-4.17.2 postgresql-plperl-14-4.17.2 postgresql-plpython-14-4.17.2 postgresql-pltcl-14-4.17.2 postgresql-server-14-4.17.2 - SUSE Linux Enterprise Server 12-SP2-BCL (noarch): postgresql-14-4.17.2 postgresql-contrib-14-4.17.2 postgresql-docs-14-4.17.2 postgresql-plperl-14-4.17.2 postgresql-plpython-14-4.17.2 postgresql-pltcl-14-4.17.2 postgresql-server-14-4.17.2

References

#1198166 #1202368

Cross- CVE-2022-2625

CVSS scores:

CVE-2022-2625 (NVD) : 8 CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

CVE-2022-2625 (SUSE): 7.1 CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H

Affected Products:

SUSE Linux Enterprise Server 12-SP2-BCL

SUSE Linux Enterprise Server 12-SP3-BCL

SUSE Linux Enterprise Server 12-SP4-LTSS

SUSE Linux Enterprise Server 12-SP5

SUSE Linux Enterprise Server for SAP 12-SP4

SUSE Linux Enterprise Server for SAP Applications 12-SP5

SUSE Linux Enterprise Software Development Kit 12-SP5

SUSE OpenStack Cloud 9

SUSE OpenStack Cloud Crowbar 9

https://www.suse.com/security/cve/CVE-2022-2625.html

https://bugzilla.suse.com/1198166

https://bugzilla.suse.com/1202368

Severity
Announcement ID: SUSE-SU-2022:3193-1
Rating: important

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.