SUSE: 2022:3199-1 moderate: yast2-samba-provision | LinuxSecurity.com

Advisories


   SUSE Security Update: Security update for yast2-samba-provision
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:3199-1
Rating:             moderate
References:         #1117597 #1132676 #1140548 #1184897 
Cross-References:   CVE-2018-17956
CVSS scores:
                    CVE-2018-17956 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Affected Products:
                    SUSE Linux Enterprise High Performance Computing 15-SP4
                    SUSE Linux Enterprise Module for Server Applications 15-SP4
                    SUSE Linux Enterprise Server 15-SP4
                    SUSE Linux Enterprise Server for SAP Applications 15-SP4
                    SUSE Manager Proxy 4.3
                    SUSE Manager Retail Branch Server 4.3
                    SUSE Manager Server 4.3
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that solves one vulnerability and has three fixes
   is now available.

Description:

   This update for yast2-samba-provision fixes the following issues:

   Security issue fixed:

   - CVE-2018-17956: Fixed a credentials leak (bsc#1117597).

   Non-Security issues fixed:

   - Stop packaging docdir, it only contained the license which is now in
     licensedir. (bsc#1184897)
   - Catch and show internal python exceptions. (bsc#1140548)
   - Show a dialog with provision details or errors. (bsc#1132676)
   - Add metainfo (fate#319035)


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-3199=1

   - SUSE Linux Enterprise Module for Server Applications 15-SP4:

      zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP4-2022-3199=1



Package List:

   - openSUSE Leap 15.4 (noarch):

      yast2-samba-provision-1.0.5-150400.9.3.3

   - SUSE Linux Enterprise Module for Server Applications 15-SP4 (noarch):

      yast2-samba-provision-1.0.5-150400.9.3.3


References:

   https://www.suse.com/security/cve/CVE-2018-17956.html
   https://bugzilla.suse.com/1117597
   https://bugzilla.suse.com/1132676
   https://bugzilla.suse.com/1140548
   https://bugzilla.suse.com/1184897

SUSE: 2022:3199-1 moderate: yast2-samba-provision

September 8, 2022
An update that solves one vulnerability and has three fixes is now available

Summary

This update for yast2-samba-provision fixes the following issues: Security issue fixed: - CVE-2018-17956: Fixed a credentials leak (bsc#1117597). Non-Security issues fixed: - Stop packaging docdir, it only contained the license which is now in licensedir. (bsc#1184897) - Catch and show internal python exceptions. (bsc#1140548) - Show a dialog with provision details or errors. (bsc#1132676) - Add metainfo (fate#319035) Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.4: zypper in -t patch openSUSE-SLE-15.4-2022-3199=1 - SUSE Linux Enterprise Module for Server Applications 15-SP4: zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP4-2022-3199=1 Package List: - openSUSE Leap 15.4 (noarch): yast2-samba-provision-1.0.5-150400.9.3.3 - SUSE Linux Enterprise Module for Server Applications 15-SP4 (noarch): yast2-samba-provision-1.0.5-150400.9.3.3

References

#1117597 #1132676 #1140548 #1184897

Cross- CVE-2018-17956

CVSS scores:

CVE-2018-17956 (NVD) : 7.8 CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Affected Products:

SUSE Linux Enterprise High Performance Computing 15-SP4

SUSE Linux Enterprise Module for Server Applications 15-SP4

SUSE Linux Enterprise Server 15-SP4

SUSE Linux Enterprise Server for SAP Applications 15-SP4

SUSE Manager Proxy 4.3

SUSE Manager Retail Branch Server 4.3

SUSE Manager Server 4.3

openSUSE Leap 15.4

https://www.suse.com/security/cve/CVE-2018-17956.html

https://bugzilla.suse.com/1117597

https://bugzilla.suse.com/1132676

https://bugzilla.suse.com/1140548

https://bugzilla.suse.com/1184897

Severity
Announcement ID: SUSE-SU-2022:3199-1
Rating: moderate

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.