SUSE: 2022:3331-1 important: libconfuse0 | LinuxSecurity.com

   SUSE Security Update: Security update for libconfuse0
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:3331-1
Rating:             important
References:         #1203326 
Cross-References:   CVE-2022-40320
CVSS scores:
                    CVE-2022-40320 (NVD) : 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
                    CVE-2022-40320 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Affected Products:
                    SUSE Linux Enterprise Module for HPC 12
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for libconfuse0 fixes the following issues:

   - CVE-2022-40320: Fixed a heap-based buffer over-read in cfg_tilde_expand
     in confuse.c (bsc#1203326).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE Linux Enterprise Module for HPC 12:

      zypper in -t patch SUSE-SLE-Module-HPC-12-2022-3331=1



Package List:

   - SUSE Linux Enterprise Module for HPC 12 (aarch64 x86_64):

      libconfuse-devel-2.8-3.6.1
      libconfuse0-2.8-3.6.1
      libconfuse0-debuginfo-2.8-3.6.1
      libconfuse0-debugsource-2.8-3.6.1

   - SUSE Linux Enterprise Module for HPC 12 (noarch):

      libconfuse0-lang-2.8-3.6.1


References:

   https://www.suse.com/security/cve/CVE-2022-40320.html
   https://bugzilla.suse.com/1203326

SUSE: 2022:3331-1 important: libconfuse0

September 21, 2022
An update that fixes one vulnerability is now available

Summary

This update for libconfuse0 fixes the following issues: - CVE-2022-40320: Fixed a heap-based buffer over-read in cfg_tilde_expand in confuse.c (bsc#1203326). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - SUSE Linux Enterprise Module for HPC 12: zypper in -t patch SUSE-SLE-Module-HPC-12-2022-3331=1 Package List: - SUSE Linux Enterprise Module for HPC 12 (aarch64 x86_64): libconfuse-devel-2.8-3.6.1 libconfuse0-2.8-3.6.1 libconfuse0-debuginfo-2.8-3.6.1 libconfuse0-debugsource-2.8-3.6.1 - SUSE Linux Enterprise Module for HPC 12 (noarch): libconfuse0-lang-2.8-3.6.1

References

#1203326

Cross- CVE-2022-40320

CVSS scores:

CVE-2022-40320 (NVD) : 8.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

CVE-2022-40320 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Affected Products:

SUSE Linux Enterprise Module for HPC 12

https://www.suse.com/security/cve/CVE-2022-40320.html

https://bugzilla.suse.com/1203326

Severity
Announcement ID: SUSE-SU-2022:3331-1
Rating: important

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.