SUSE: 2022:3334-1 important: cdi-apiserver-container, cdi-cloner-co...

   SUSE Security Update: Security update for cdi-apiserver-container, cdi-cloner-container, cdi-controller-container, cdi-importer-container, cdi-operator-container, cdi-uploadproxy-container, cdi-uploadserver-container, containerized-data-importer
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:3334-1
Rating:             important
References:         #1200528 
Cross-References:   CVE-2022-1996
CVSS scores:
                    CVE-2022-1996 (NVD) : 9.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
                    CVE-2022-1996 (SUSE): 7.5 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Affected Products:
                    SUSE Linux Enterprise High Performance Computing 15-SP4
                    SUSE Linux Enterprise Module for Containers 15-SP4
                    SUSE Linux Enterprise Server 15-SP4
                    SUSE Linux Enterprise Server for SAP Applications 15-SP4
                    SUSE Manager Proxy 4.3
                    SUSE Manager Retail Branch Server 4.3
                    SUSE Manager Server 4.3
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for cdi-apiserver-container, cdi-cloner-container,
   cdi-controller-container, cdi-importer-container, cdi-operator-container,
   cdi-uploadproxy-container, cdi-uploadserver-container,
   containerized-data-importer fixes the following issues:

   Update to version 1.51.0

   - Release notes
   https://github.com/kubevirt/containerized-data-importer/releases/tag/v1.51.
     0

   Security issues fixed in vendored dependencies:

   - CVE-2022-1996: Fixed CORS bypass (bsc#1200528)

   - Include additional tools used by cdi-importer: cdi-containerimage-server
     cdi-image-size-detection cdi-source-update-poller

   - Pack only cdi-operator and cdi-cr release manifests
   - Install tar for cloning filesystem PVCs


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-3334=1

   - SUSE Linux Enterprise Module for Containers 15-SP4:

      zypper in -t patch SUSE-SLE-Module-Containers-15-SP4-2022-3334=1



Package List:

   - openSUSE Leap 15.4 (x86_64):

      containerized-data-importer-api-1.51.0-150400.4.3.1
      containerized-data-importer-api-debuginfo-1.51.0-150400.4.3.1
      containerized-data-importer-cloner-1.51.0-150400.4.3.1
      containerized-data-importer-cloner-debuginfo-1.51.0-150400.4.3.1
      containerized-data-importer-controller-1.51.0-150400.4.3.1
      containerized-data-importer-controller-debuginfo-1.51.0-150400.4.3.1
      containerized-data-importer-importer-1.51.0-150400.4.3.1
      containerized-data-importer-importer-debuginfo-1.51.0-150400.4.3.1
      containerized-data-importer-manifests-1.51.0-150400.4.3.1
      containerized-data-importer-operator-1.51.0-150400.4.3.1
      containerized-data-importer-operator-debuginfo-1.51.0-150400.4.3.1
      containerized-data-importer-uploadproxy-1.51.0-150400.4.3.1
      containerized-data-importer-uploadproxy-debuginfo-1.51.0-150400.4.3.1
      containerized-data-importer-uploadserver-1.51.0-150400.4.3.1
      containerized-data-importer-uploadserver-debuginfo-1.51.0-150400.4.3.1
      obs-service-cdi_containers_meta-1.51.0-150400.4.3.1

   - SUSE Linux Enterprise Module for Containers 15-SP4 (x86_64):

      containerized-data-importer-manifests-1.51.0-150400.4.3.1


References:

   https://www.suse.com/security/cve/CVE-2022-1996.html
   https://bugzilla.suse.com/1200528

SUSE: 2022:3334-1 important: cdi-apiserver-container, cdi-cloner-container, cdi-controller

September 22, 2022
An update that fixes one vulnerability is now available

Summary

This update for cdi-apiserver-container, cdi-cloner-container, cdi-controller-container, cdi-importer-container, cdi-operator-container, cdi-uploadproxy-container, cdi-uploadserver-container, containerized-data-importer fixes the following issues: Update to version 1.51.0 - Release notes https://github.com/kubevirt/containerized-data-importer/releases/tag/v1.51. 0 Security issues fixed in vendored dependencies: - CVE-2022-1996: Fixed CORS bypass (bsc#1200528) - Include additional tools used by cdi-importer: cdi-containerimage-server cdi-image-size-detection cdi-source-update-poller - Pack only cdi-operator and cdi-cr release manifests - Install tar for cloning filesystem PVCs Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.4: zypper in -t patch openSUSE-SLE-15.4-2022-3334=1 - SUSE Linux Enterprise Module for Containers 15-SP4: zypper in -t patch SUSE-SLE-Module-Containers-15-SP4-2022-3334=1 Package List: - openSUSE Leap 15.4 (x86_64): containerized-data-importer-api-1.51.0-150400.4.3.1 containerized-data-importer-api-debuginfo-1.51.0-150400.4.3.1 containerized-data-importer-cloner-1.51.0-150400.4.3.1 containerized-data-importer-cloner-debuginfo-1.51.0-150400.4.3.1 containerized-data-importer-controller-1.51.0-150400.4.3.1 containerized-data-importer-controller-debuginfo-1.51.0-150400.4.3.1 containerized-data-importer-importer-1.51.0-150400.4.3.1 containerized-data-importer-importer-debuginfo-1.51.0-150400.4.3.1 containerized-data-importer-manifests-1.51.0-150400.4.3.1 containerized-data-importer-operator-1.51.0-150400.4.3.1 containerized-data-importer-operator-debuginfo-1.51.0-150400.4.3.1 containerized-data-importer-uploadproxy-1.51.0-150400.4.3.1 containerized-data-importer-uploadproxy-debuginfo-1.51.0-150400.4.3.1 containerized-data-importer-uploadserver-1.51.0-150400.4.3.1 containerized-data-importer-uploadserver-debuginfo-1.51.0-150400.4.3.1 obs-service-cdi_containers_meta-1.51.0-150400.4.3.1 - SUSE Linux Enterprise Module for Containers 15-SP4 (x86_64): containerized-data-importer-manifests-1.51.0-150400.4.3.1

References

#1200528

Cross- CVE-2022-1996

CVSS scores:

CVE-2022-1996 (NVD) : 9.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

CVE-2022-1996 (SUSE): 7.5 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Affected Products:

SUSE Linux Enterprise High Performance Computing 15-SP4

SUSE Linux Enterprise Module for Containers 15-SP4

SUSE Linux Enterprise Server 15-SP4

SUSE Linux Enterprise Server for SAP Applications 15-SP4

SUSE Manager Proxy 4.3

SUSE Manager Retail Branch Server 4.3

SUSE Manager Server 4.3

openSUSE Leap 15.4

https://www.suse.com/security/cve/CVE-2022-1996.html

https://bugzilla.suse.com/1200528

Severity
Announcement ID: SUSE-SU-2022:3334-1
Rating: important

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.