SUSE: 2022:3656-1 important: nodejs16 | LinuxSecurity.com

   SUSE Security Update: Security update for nodejs16
______________________________________________________________________________

Announcement ID:    SUSE-SU-2022:3656-1
Rating:             important
References:         #1201325 #1201327 #1203831 #1203832 
Cross-References:   CVE-2022-32213 CVE-2022-32215 CVE-2022-35255
                    CVE-2022-35256
CVSS scores:
                    CVE-2022-32213 (NVD) : 9.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
                    CVE-2022-32213 (SUSE): 6.8 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:H
                    CVE-2022-32215 (NVD) : 9.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
                    CVE-2022-32215 (SUSE): 6.8 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
                    CVE-2022-35255 (SUSE): 8.2 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
                    CVE-2022-35256 (SUSE): 6.5 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Affected Products:
                    SUSE Linux Enterprise High Performance Computing 15-SP4
                    SUSE Linux Enterprise Module for Web Scripting 15-SP4
                    SUSE Linux Enterprise Server 15-SP4
                    SUSE Linux Enterprise Server for SAP Applications 15-SP4
                    SUSE Manager Proxy 4.3
                    SUSE Manager Retail Branch Server 4.3
                    SUSE Manager Server 4.3
                    openSUSE Leap 15.4
______________________________________________________________________________

   An update that fixes four vulnerabilities is now available.

Description:

   This update for nodejs16 fixes the following issues:

   Updated to version 16.17.1:

   - CVE-2022-32213: Fixed bypass via obs-fold mechanic (bsc#1201325).
   - CVE-2022-32215: Fixed incorrect Parsing of Multi-line Transfer-Encoding
     (bsc#1201327).
   - CVE-2022-35256: Fixed incorrect Parsing of Header Fields (bsc#1203832).
   - CVE-2022-35255: FIxed weak randomness in WebCrypto keygen (bsc#1203831).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.4:

      zypper in -t patch openSUSE-SLE-15.4-2022-3656=1

   - SUSE Linux Enterprise Module for Web Scripting 15-SP4:

      zypper in -t patch SUSE-SLE-Module-Web-Scripting-15-SP4-2022-3656=1



Package List:

   - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

      corepack16-16.17.1-150400.3.9.1
      nodejs16-16.17.1-150400.3.9.1
      nodejs16-debuginfo-16.17.1-150400.3.9.1
      nodejs16-debugsource-16.17.1-150400.3.9.1
      nodejs16-devel-16.17.1-150400.3.9.1
      npm16-16.17.1-150400.3.9.1

   - openSUSE Leap 15.4 (noarch):

      nodejs16-docs-16.17.1-150400.3.9.1

   - SUSE Linux Enterprise Module for Web Scripting 15-SP4 (aarch64 ppc64le s390x x86_64):

      nodejs16-16.17.1-150400.3.9.1
      nodejs16-debuginfo-16.17.1-150400.3.9.1
      nodejs16-debugsource-16.17.1-150400.3.9.1
      nodejs16-devel-16.17.1-150400.3.9.1
      npm16-16.17.1-150400.3.9.1

   - SUSE Linux Enterprise Module for Web Scripting 15-SP4 (noarch):

      nodejs16-docs-16.17.1-150400.3.9.1


References:

   https://www.suse.com/security/cve/CVE-2022-32213.html
   https://www.suse.com/security/cve/CVE-2022-32215.html
   https://www.suse.com/security/cve/CVE-2022-35255.html
   https://www.suse.com/security/cve/CVE-2022-35256.html
   https://bugzilla.suse.com/1201325
   https://bugzilla.suse.com/1201327
   https://bugzilla.suse.com/1203831
   https://bugzilla.suse.com/1203832

SUSE: 2022:3656-1 important: nodejs16

October 19, 2022
An update that fixes four vulnerabilities is now available

Summary

This update for nodejs16 fixes the following issues: Updated to version 16.17.1: - CVE-2022-32213: Fixed bypass via obs-fold mechanic (bsc#1201325). - CVE-2022-32215: Fixed incorrect Parsing of Multi-line Transfer-Encoding (bsc#1201327). - CVE-2022-35256: Fixed incorrect Parsing of Header Fields (bsc#1203832). - CVE-2022-35255: FIxed weak randomness in WebCrypto keygen (bsc#1203831). Patch Instructions: To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Leap 15.4: zypper in -t patch openSUSE-SLE-15.4-2022-3656=1 - SUSE Linux Enterprise Module for Web Scripting 15-SP4: zypper in -t patch SUSE-SLE-Module-Web-Scripting-15-SP4-2022-3656=1 Package List: - openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64): corepack16-16.17.1-150400.3.9.1 nodejs16-16.17.1-150400.3.9.1 nodejs16-debuginfo-16.17.1-150400.3.9.1 nodejs16-debugsource-16.17.1-150400.3.9.1 nodejs16-devel-16.17.1-150400.3.9.1 npm16-16.17.1-150400.3.9.1 - openSUSE Leap 15.4 (noarch): nodejs16-docs-16.17.1-150400.3.9.1 - SUSE Linux Enterprise Module for Web Scripting 15-SP4 (aarch64 ppc64le s390x x86_64): nodejs16-16.17.1-150400.3.9.1 nodejs16-debuginfo-16.17.1-150400.3.9.1 nodejs16-debugsource-16.17.1-150400.3.9.1 nodejs16-devel-16.17.1-150400.3.9.1 npm16-16.17.1-150400.3.9.1 - SUSE Linux Enterprise Module for Web Scripting 15-SP4 (noarch): nodejs16-docs-16.17.1-150400.3.9.1

References

#1201325 #1201327 #1203831 #1203832

Cross- CVE-2022-32213 CVE-2022-32215 CVE-2022-35255

CVE-2022-35256

CVSS scores:

CVE-2022-32213 (NVD) : 9.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

CVE-2022-32213 (SUSE): 6.8 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:H

CVE-2022-32215 (NVD) : 9.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

CVE-2022-32215 (SUSE): 6.8 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N

CVE-2022-35255 (SUSE): 8.2 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N

CVE-2022-35256 (SUSE): 6.5 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Affected Products:

SUSE Linux Enterprise High Performance Computing 15-SP4

SUSE Linux Enterprise Module for Web Scripting 15-SP4

SUSE Linux Enterprise Server 15-SP4

SUSE Linux Enterprise Server for SAP Applications 15-SP4

SUSE Manager Proxy 4.3

SUSE Manager Retail Branch Server 4.3

SUSE Manager Server 4.3

openSUSE Leap 15.4

https://www.suse.com/security/cve/CVE-2022-32213.html

https://www.suse.com/security/cve/CVE-2022-32215.html

https://www.suse.com/security/cve/CVE-2022-35255.html

https://www.suse.com/security/cve/CVE-2022-35256.html

https://bugzilla.suse.com/1201325

https://bugzilla.suse.com/1201327

https://bugzilla.suse.com/1203831

https://bugzilla.suse.com/1203832

Severity
Announcement ID: SUSE-SU-2022:3656-1
Rating: important

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.